Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Динамический рейтинг по балам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Динамический рейтинг по балам (Формулы/Formulas)
Динамический рейтинг по балам
nelltan Дата: Понедельник, 30.10.2017, 20:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
просьба помочь с написанием формулы. Есть таблица с тестирование, на основании которой создается рейтинг участников теста. Во вкладке рейтинг нашел пару форумов и кое-как составил рейтинг, вроде даже считает, но сегодня обнаружил, что формула не подставляет участников тестирование, если у них средний бал равен 0.
К сообщению приложен файл: 8948377.xls(44Kb)
 
Ответить
СообщениеДобрый день!
просьба помочь с написанием формулы. Есть таблица с тестирование, на основании которой создается рейтинг участников теста. Во вкладке рейтинг нашел пару форумов и кое-как составил рейтинг, вроде даже считает, но сегодня обнаружил, что формула не подставляет участников тестирование, если у них средний бал равен 0.

Автор - nelltan
Дата добавления - 30.10.2017 в 20:53
pabchek Дата: Вторник, 31.10.2017, 10:07 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 779
Репутация: 173 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Получилось длинненько, но вроде работает. Смотрите, устроит?
К сообщению приложен файл: 9091061.xls(46Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеЗдравствуйте!
Получилось длинненько, но вроде работает. Смотрите, устроит?

Автор - pabchek
Дата добавления - 31.10.2017 в 10:07
_Boroda_ Дата: Вторник, 31.10.2017, 10:30 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11644
Репутация: 4825 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У меня тоже не очень коротко получилось. Формула массива, вводится одновременным нажатием Контрл ШИфт ЕНтер
Код
=ЕСЛИОШИБКА(ИНДЕКС(Відомість!A:A;1/ОСТАТ(НАИБОЛЬШИЙ(ЕСЛИ(Відомість!B$8:B$99="Тест";Відомість!K$8:K$99+1/СТРОКА(Відомість!K$8:K$99));СТРОКА(A1));1)+1%);"")

nelltan, общее количество баллов у разных людей ведь может быть одинаковым, да?
К сообщению приложен файл: 9091061_2.xls(59Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ меня тоже не очень коротко получилось. Формула массива, вводится одновременным нажатием Контрл ШИфт ЕНтер
Код
=ЕСЛИОШИБКА(ИНДЕКС(Відомість!A:A;1/ОСТАТ(НАИБОЛЬШИЙ(ЕСЛИ(Відомість!B$8:B$99="Тест";Відомість!K$8:K$99+1/СТРОКА(Відомість!K$8:K$99));СТРОКА(A1));1)+1%);"")

nelltan, общее количество баллов у разных людей ведь может быть одинаковым, да?

Автор - _Boroda_
Дата добавления - 31.10.2017 в 10:30
nelltan Дата: Четверг, 02.11.2017, 11:16 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
pabchek, Почти, но когда общее количество балов совпадает, то подставляет одного человека , не разных
 
Ответить
Сообщениеpabchek, Почти, но когда общее количество балов совпадает, то подставляет одного человека , не разных

Автор - nelltan
Дата добавления - 02.11.2017 в 11:16
nelltan Дата: Четверг, 02.11.2017, 11:17 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Супер, то что надо. Благадарю
 
Ответить
Сообщение_Boroda_, Супер, то что надо. Благадарю

Автор - nelltan
Дата добавления - 02.11.2017 в 11:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Динамический рейтинг по балам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!