Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/принадлежит ли точка заштрихованной области - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » принадлежит ли точка заштрихованной области (Формулы/Formulas)
принадлежит ли точка заштрихованной области
alex2003 Дата: Вторник, 31.10.2017, 15:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Ребята не могу сообразить как решить лабу
задание следующее: Сформировать логическую функцию, отвечающую на вопрос: принадлежит ли точка с координатами (х,у) заштрихованной области
К сообщению приложен файл: _3.xlsx(72Kb)
 
Ответить
СообщениеРебята не могу сообразить как решить лабу
задание следующее: Сформировать логическую функцию, отвечающую на вопрос: принадлежит ли точка с координатами (х,у) заштрихованной области

Автор - alex2003
Дата добавления - 31.10.2017 в 15:10
buchlotnik Дата: Вторник, 31.10.2017, 15:44 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3325
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
не оптимизировал:
Код
=ЕСЛИ(СУММКВ(B1:B2)<=1;ЕСЛИ(И(B2<0,5;ABS(B2)>=(1-ABS(B1)));"принадлежит";ЕСЛИ(И(B2>=0,5;ABS(B2)<=(1-ABS(B1)));"принадлежит";"не принадлежит"));"не принадлежит")
чутка короче:
К сообщению приложен файл: _3-1-.xlsx(73Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 01.11.2017, 01:29
 
Ответить
Сообщениене оптимизировал:
Код
=ЕСЛИ(СУММКВ(B1:B2)<=1;ЕСЛИ(И(B2<0,5;ABS(B2)>=(1-ABS(B1)));"принадлежит";ЕСЛИ(И(B2>=0,5;ABS(B2)<=(1-ABS(B1)));"принадлежит";"не принадлежит"));"не принадлежит")
чутка короче:

Автор - buchlotnik
Дата добавления - 31.10.2017 в 15:44
Pelena Дата: Вторник, 31.10.2017, 15:46 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11755
Репутация: 2596 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
У меня почти так же
Код
=ЕСЛИ(И(B1^2+B2^2<=1;ИЛИ(И(B2>=0,5;ABS(B2)<=1-ABS(B1));И(B2<=0,5;ABS(B2)>=1-ABS(B1))));"принадлежит";"не принадлежит")

При попадании на линию - принадлежит
К сообщению приложен файл: 8017966.xlsx(80Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеУ меня почти так же
Код
=ЕСЛИ(И(B1^2+B2^2<=1;ИЛИ(И(B2>=0,5;ABS(B2)<=1-ABS(B1));И(B2<=0,5;ABS(B2)>=1-ABS(B1))));"принадлежит";"не принадлежит")

При попадании на линию - принадлежит

Автор - Pelena
Дата добавления - 31.10.2017 в 15:46
alex2003 Дата: Вторник, 31.10.2017, 16:50 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, Спасибо огромное
 
Ответить
Сообщениеbuchlotnik, Спасибо огромное

Автор - alex2003
Дата добавления - 31.10.2017 в 16:50
alex2003 Дата: Вторник, 31.10.2017, 16:51 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, спасибо вам огромное hands
 
Ответить
СообщениеPelena, спасибо вам огромное hands

Автор - alex2003
Дата добавления - 31.10.2017 в 16:51
buchlotnik Дата: Среда, 01.11.2017, 00:00 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3325
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Дописал сокращённые варианты в сообщение выше - на всякий случай под спойлер - не МШ, конечно, но задачка понравилась


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
СообщениеДописал сокращённые варианты в сообщение выше - на всякий случай под спойлер - не МШ, конечно, но задачка понравилась

Автор - buchlotnik
Дата добавления - 01.11.2017 в 00:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » принадлежит ли точка заштрихованной области (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!