Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборочный перенос данных по 2ум условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборочный перенос данных по 2ум условиям (Формулы/Formulas)
Выборочный перенос данных по 2ум условиям
gipsy14 Дата: Среда, 01.11.2017, 12:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
Пожалуйста помогите!
Из столбца J таблицы 1 автоматически переносятся данные (при условии, что значение >0) в столбец С таблицы 2.
Необходим перенос дат из таблицы 1 (столбца G или H) в таблицу 2 (в столбец b) по следующим условиям:
1. Значение в столбце J таблицы 1 > 0. (J12, J13). Это условие обязательно для соблюдения.
2. =ЕСЛИ(I13>0;H13;B13), т.е. если при этом значение в столбце I строкой ниже (I13) значение >0, то дату берем из столбца H (ячейка H14)....если значение в I <= (не больше) 0, то значение берем из столбца G (строка на 1 ниже суммы из J) - ячейка G13.
Даты должны переноситься именно по 2ум условиям.

В таблице 2 красным выделены ячейки с формулой массива, но они переносят только даты из столбца G.

Благодарю за помощь!
К сообщению приложен файл: __-V2.1.1.xlsm(27Kb)
 
Ответить
СообщениеДобрый день!
Пожалуйста помогите!
Из столбца J таблицы 1 автоматически переносятся данные (при условии, что значение >0) в столбец С таблицы 2.
Необходим перенос дат из таблицы 1 (столбца G или H) в таблицу 2 (в столбец b) по следующим условиям:
1. Значение в столбце J таблицы 1 > 0. (J12, J13). Это условие обязательно для соблюдения.
2. =ЕСЛИ(I13>0;H13;B13), т.е. если при этом значение в столбце I строкой ниже (I13) значение >0, то дату берем из столбца H (ячейка H14)....если значение в I <= (не больше) 0, то значение берем из столбца G (строка на 1 ниже суммы из J) - ячейка G13.
Даты должны переноситься именно по 2ум условиям.

В таблице 2 красным выделены ячейки с формулой массива, но они переносят только даты из столбца G.

Благодарю за помощь!

Автор - gipsy14
Дата добавления - 01.11.2017 в 12:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборочный перенос данных по 2ум условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!