Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт по значениям, а не наименованиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт по значениям, а не наименованиям (Формулы/Formulas)
Подсчёт по значениям, а не наименованиям
nechehov Дата: Среда, 01.11.2017, 13:53 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Я хочу подсчитать количество произведённых операций за один и тот же период в разные годы. Но формула подсчитывает не значения в данном периоде, а количество строк. Как это можно исправить?
К сообщению приложен файл: 5265937.xlsx(9Kb)
 
Ответить
СообщениеДобрый день! Я хочу подсчитать количество произведённых операций за один и тот же период в разные годы. Но формула подсчитывает не значения в данном периоде, а количество строк. Как это можно исправить?

Автор - nechehov
Дата добавления - 01.11.2017 в 13:53
buchlotnik Дата: Среда, 01.11.2017, 14:10 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3327
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так замените функцию:
Код
=СУММЕСЛИ($J$2:$J$6;B2;$M$2:$M$6)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениетак замените функцию:
Код
=СУММЕСЛИ($J$2:$J$6;B2;$M$2:$M$6)

Автор - buchlotnik
Дата добавления - 01.11.2017 в 14:10
Nic70y Дата: Среда, 01.11.2017, 14:11 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4185
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
Код
=СЧЁТЕСЛИМН($J$2:$J$6;$B2;K$2:K$6;"<>")
так?
К сообщению приложен файл: 2679613.xlsx(9Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИМН($J$2:$J$6;$B2;K$2:K$6;"<>")
так?

Автор - Nic70y
Дата добавления - 01.11.2017 в 14:11
nechehov Дата: Среда, 01.11.2017, 14:32 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
buchlotnik, СУММЕСЛИ не подходит, т.к. мне нужно не складывать значения, а посчитать их количество.
 
Ответить
Сообщениеbuchlotnik, СУММЕСЛИ не подходит, т.к. мне нужно не складывать значения, а посчитать их количество.

Автор - nechehov
Дата добавления - 01.11.2017 в 14:32
nechehov Дата: Среда, 01.11.2017, 14:34 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, Спасибо! А что означает "<>" ?
 
Ответить
СообщениеNic70y, Спасибо! А что означает "<>" ?

Автор - nechehov
Дата добавления - 01.11.2017 в 14:34
Nic70y Дата: Среда, 01.11.2017, 15:04 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4185
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
не равно пустоте


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениене равно пустоте

Автор - Nic70y
Дата добавления - 01.11.2017 в 15:04
Che79 Дата: Среда, 01.11.2017, 15:30 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 597
Репутация: 108 ±
Замечаний: 0% ±

Excel 2007, 2013
вариант
Код
=СУММПРОИЗВ((K$2:K$6>0)*($J$2:$J$6=$B2))


Делай нормально и будет нормально!
 
Ответить
Сообщениевариант
Код
=СУММПРОИЗВ((K$2:K$6>0)*($J$2:$J$6=$B2))

Автор - Che79
Дата добавления - 01.11.2017 в 15:30
Фомулист Дата: Среда, 01.11.2017, 15:45 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 169
Репутация: -13 ±
Замечаний: 60% ±

Excel 2003
Простите, что опять суют нос, но разве эксель понимает запись "<>"? Я "не равно пустоте" всегда пишу так: <>"".


Терпение и труд всё перетрут!
 
Ответить
СообщениеПростите, что опять суют нос, но разве эксель понимает запись "<>"? Я "не равно пустоте" всегда пишу так: <>"".

Автор - Фомулист
Дата добавления - 01.11.2017 в 15:45
buchlotnik Дата: Среда, 01.11.2017, 15:49 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3327
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
всегда пишу так
мдя?! а взять и попробовать воткнуть вашу "рабочую" конструкцию в вышеприведённую формулу слабо? И глянуть, что Excel на это скажет


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 01.11.2017, 16:15
 
Ответить
Сообщение
Цитата
всегда пишу так
мдя?! а взять и попробовать воткнуть вашу "рабочую" конструкцию в вышеприведённую формулу слабо? И глянуть, что Excel на это скажет

Автор - buchlotnik
Дата добавления - 01.11.2017 в 15:49
Фомулист Дата: Среда, 01.11.2017, 16:19 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 169
Репутация: -13 ±
Замечаний: 60% ±

Excel 2003
вашу "рабочую" конструкцию

Я имел в виду, что я пишу так: B2<>"" (это абстрактный пример конструкции. Под данный - некогда файл смотреть).


Терпение и труд всё перетрут!

Сообщение отредактировал Фомулист - Среда, 01.11.2017, 16:22
 
Ответить
Сообщение
вашу "рабочую" конструкцию

Я имел в виду, что я пишу так: B2<>"" (это абстрактный пример конструкции. Под данный - некогда файл смотреть).

Автор - Фомулист
Дата добавления - 01.11.2017 в 16:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт по значениям, а не наименованиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!