Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод ячеек, при выполнении условий в другом столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод ячеек, при выполнении условий в другом столбце (Формулы/Formulas)
Вывод ячеек, при выполнении условий в другом столбце
Осел Дата: Четверг, 02.11.2017, 12:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день! Прошу помочь в решении вопроса. Есть таблица с заданием на образцы (задание в хаотичном порядке). Мне нужно что бы лабораторные номера образцов, с определенным заданием выводились на соседние листы, без пропусков (в файле есть пример). Я это делал просто сортируя каждый столбец, но появилась необходимость перевести процесс в автоматический режим. Пришел в тупик, никак не могу заставить его пропускать пустые ячейки.
К сообщению приложен файл: _218.xls(58Kb)
 
Ответить
СообщениеДобрый день! Прошу помочь в решении вопроса. Есть таблица с заданием на образцы (задание в хаотичном порядке). Мне нужно что бы лабораторные номера образцов, с определенным заданием выводились на соседние листы, без пропусков (в файле есть пример). Я это делал просто сортируя каждый столбец, но появилась необходимость перевести процесс в автоматический режим. Пришел в тупик, никак не могу заставить его пропускать пустые ячейки.

Автор - Осел
Дата добавления - 02.11.2017 в 12:09
_Boroda_ Дата: Четверг, 02.11.2017, 13:02 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11644
Репутация: 4825 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно? Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=ЕСЛИОШИБКА(ИНДЕКС(Реестр!$C:$C;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(Реестр!$I10:$AK99;;ПОИСКПОЗ(ЛЕВБ(ПСТР(ЯЧЕЙКА("имяфайла";A1);ПОИСК("]";ЯЧЕЙКА("имяфайла";A1))+1;99);15)&"*";Реестр!$I8:$AK8;))="+";СТРОКА(Реестр!$C10:$C99));СТОЛБЕЦ(A4)));"")

Только следите за тем, чтобы названия листов (первые 15 символов) точно совпадали с теми названиями, которые у Вас в шапке таблицы
К сообщению приложен файл: _218_1.xlsm(22Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно? Формула массива, вводится одновременным нажатием Контрл Шифт Ентер
Код
=ЕСЛИОШИБКА(ИНДЕКС(Реестр!$C:$C;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(Реестр!$I10:$AK99;;ПОИСКПОЗ(ЛЕВБ(ПСТР(ЯЧЕЙКА("имяфайла";A1);ПОИСК("]";ЯЧЕЙКА("имяфайла";A1))+1;99);15)&"*";Реестр!$I8:$AK8;))="+";СТРОКА(Реестр!$C10:$C99));СТОЛБЕЦ(A4)));"")

Только следите за тем, чтобы названия листов (первые 15 символов) точно совпадали с теми названиями, которые у Вас в шапке таблицы

Автор - _Boroda_
Дата добавления - 02.11.2017 в 13:02
Nic70y Дата: Четверг, 02.11.2017, 13:27 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4184
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
вариант
Код
=ИНДЕКС(Реестр!$C6:$C119;ПОИСКПОЗ("+";ИНДЕКС(Реестр!$B6:$AL119;ПОИСКПОЗ(A3;Реестр!$C6:$C119;)+1;-ПРАВБ(ЯЧЕЙКА("filename";A1);4)):ИНДЕКС(Реестр!$B6:$AL119;113;-ПРАВБ(ЯЧЕЙКА("filename";A1);4));)+ПОИСКПОЗ(A3;Реестр!$C6:$C119;))
(ы) в файле
К сообщению приложен файл: 1591852.xls(57Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениевариант
Код
=ИНДЕКС(Реестр!$C6:$C119;ПОИСКПОЗ("+";ИНДЕКС(Реестр!$B6:$AL119;ПОИСКПОЗ(A3;Реестр!$C6:$C119;)+1;-ПРАВБ(ЯЧЕЙКА("filename";A1);4)):ИНДЕКС(Реестр!$B6:$AL119;113;-ПРАВБ(ЯЧЕЙКА("filename";A1);4));)+ПОИСКПОЗ(A3;Реестр!$C6:$C119;))
(ы) в файле

Автор - Nic70y
Дата добавления - 02.11.2017 в 13:27
_Boroda_ Дата: Четверг, 02.11.2017, 13:58 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11644
Репутация: 4825 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ааа, вот что такое 24!
Тогда еще (ы) в файле
Код
=НАИМЕНЬШИЙ(ЕСЛИ((Реестр!$I9:$AE9=$A1)*(Реестр!$I10:$AE32="+");Реестр!$C10:$C32);СТОЛБЕЦ(A6))
К сообщению приложен файл: _218_2.xlsm(22Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАаа, вот что такое 24!
Тогда еще (ы) в файле
Код
=НАИМЕНЬШИЙ(ЕСЛИ((Реестр!$I9:$AE9=$A1)*(Реестр!$I10:$AE32="+");Реестр!$C10:$C32);СТОЛБЕЦ(A6))

Автор - _Boroda_
Дата добавления - 02.11.2017 в 13:58
Осел Дата: Вторник, 14.11.2017, 10:05 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Nic70y, спасибо, все сработало!
 
Ответить
Сообщение_Boroda_, Nic70y, спасибо, все сработало!

Автор - Осел
Дата добавления - 14.11.2017 в 10:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод ячеек, при выполнении условий в другом столбце (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!