Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Гиперсылка на скрытый лист - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Гиперсылка на скрытый лист (Формулы/Formulas)
Гиперсылка на скрытый лист
Dgerri Дата: Пятница, 10.11.2017, 11:31 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброе время суток уважаемые Гуру!
Хочу создать в файле Excel:
1. Содержание
2. Лист2, Лист3, Лист4 содержат информацию, но хочу их спрятать с глаз долой
3. Цель - переход по гиперссылкам на спрятанные листы.

На сейчас в примере, когда листы не спрятаны переход есть, а вот когда листы прячешь (скрываешь) перехода нет.
Можно как то решить этот вопрос?

Заранее спасибо
К сообщению приложен файл: 5266892.xlsx(10Kb)
 
Ответить
СообщениеДоброе время суток уважаемые Гуру!
Хочу создать в файле Excel:
1. Содержание
2. Лист2, Лист3, Лист4 содержат информацию, но хочу их спрятать с глаз долой
3. Цель - переход по гиперссылкам на спрятанные листы.

На сейчас в примере, когда листы не спрятаны переход есть, а вот когда листы прячешь (скрываешь) перехода нет.
Можно как то решить этот вопрос?

Заранее спасибо

Автор - Dgerri
Дата добавления - 10.11.2017 в 11:31
buchlotnik Дата: Пятница, 10.11.2017, 11:49 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3325
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Так, а может просто скрыть ярлычки листов, а навигацию по гиперссылкам делать? И оглавление я бы на формулах собирал, а не ручками каждый лист (см. файл)
Имя оглавление:
Код
=ЗАМЕНИТЬ(ПОЛУЧИТЬ.РАБОЧУЮ.КНИГУ(1);1;НАЙТИ("]";ПОЛУЧИТЬ.РАБОЧУЮ.КНИГУ(1));"")&Т(ТДАТА())
переход на листы:
Код
=ЕСЛИОШИБКА(ГИПЕРССЫЛКА("#"&ИНДЕКС(Оглавление;СТРОКА(A2))&"!A1";ИНДЕКС(Оглавление;СТРОКА(A2)));"")
переход назад:
Код
=ГИПЕРССЫЛКА("#Содержание!A1";"в начало")
К сообщению приложен файл: 5266892.xlsm(14Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 10.11.2017, 11:51
 
Ответить
СообщениеТак, а может просто скрыть ярлычки листов, а навигацию по гиперссылкам делать? И оглавление я бы на формулах собирал, а не ручками каждый лист (см. файл)
Имя оглавление:
Код
=ЗАМЕНИТЬ(ПОЛУЧИТЬ.РАБОЧУЮ.КНИГУ(1);1;НАЙТИ("]";ПОЛУЧИТЬ.РАБОЧУЮ.КНИГУ(1));"")&Т(ТДАТА())
переход на листы:
Код
=ЕСЛИОШИБКА(ГИПЕРССЫЛКА("#"&ИНДЕКС(Оглавление;СТРОКА(A2))&"!A1";ИНДЕКС(Оглавление;СТРОКА(A2)));"")
переход назад:
Код
=ГИПЕРССЫЛКА("#Содержание!A1";"в начало")

Автор - buchlotnik
Дата добавления - 10.11.2017 в 11:49
Dgerri Дата: Пятница, 10.11.2017, 12:05 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо за идею, попробую...
но макросы однозначно нет, админы у нас их боятся...

Файл находится в общем доступе, содержит порядка 25 листов, которые между собой связаны формулами,
каждый сотрудник вносит свои данные только в своем листе, а далее это все собирается, умножается, делится...

Поэтому хочу и вижу как:
Видим только лист Содержание, сотрудник тыцкает на свою ссылку (название), попадает на лист, вносит данные и сохраняет...
все остальные листы будут запаролены как говорится во избежания...

п.с. вот сижу и думаю - может я много хочу?


Сообщение отредактировал Dgerri - Пятница, 10.11.2017, 12:06
 
Ответить
СообщениеСпасибо за идею, попробую...
но макросы однозначно нет, админы у нас их боятся...

Файл находится в общем доступе, содержит порядка 25 листов, которые между собой связаны формулами,
каждый сотрудник вносит свои данные только в своем листе, а далее это все собирается, умножается, делится...

Поэтому хочу и вижу как:
Видим только лист Содержание, сотрудник тыцкает на свою ссылку (название), попадает на лист, вносит данные и сохраняет...
все остальные листы будут запаролены как говорится во избежания...

п.с. вот сижу и думаю - может я много хочу?

Автор - Dgerri
Дата добавления - 10.11.2017 в 12:05
buchlotnik Дата: Пятница, 10.11.2017, 12:10 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3325
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Макросы там только для создания оглавления - сделайте список листов ручками, остальное по описанию выше
К сообщению приложен файл: 5266892-1-.xlsm(14Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 10.11.2017, 12:13
 
Ответить
СообщениеМакросы там только для создания оглавления - сделайте список листов ручками, остальное по описанию выше

Автор - buchlotnik
Дата добавления - 10.11.2017 в 12:10
Dgerri Дата: Пятница, 10.11.2017, 12:25 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
отлично, то, что нужно...
осталось понять как мне листы, если потребуется, показать
 
Ответить
Сообщениеотлично, то, что нужно...
осталось понять как мне листы, если потребуется, показать

Автор - Dgerri
Дата добавления - 10.11.2017 в 12:25
sboy Дата: Пятница, 10.11.2017, 12:30 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1103
Репутация: 276 ±
Замечаний: 0% ±

Excel 2010
без макросов никак...
 
Ответить
Сообщениебез макросов никак...

Автор - sboy
Дата добавления - 10.11.2017 в 12:30
китин Дата: Пятница, 10.11.2017, 12:31 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4409
Репутация: 697 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
файл - параметры-дополнительно-показывать ярлыки листов.


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениефайл - параметры-дополнительно-показывать ярлыки листов.

Автор - китин
Дата добавления - 10.11.2017 в 12:31
Dgerri Дата: Пятница, 10.11.2017, 12:40 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Ребята спасибо hands
 
Ответить
СообщениеРебята спасибо hands

Автор - Dgerri
Дата добавления - 10.11.2017 в 12:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Гиперсылка на скрытый лист (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!