Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сравнение данных и выведение числа при нескольких условиях - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сравнение данных и выведение числа при нескольких условиях (Формулы/Formulas)
сравнение данных и выведение числа при нескольких условиях
Лагуна Дата: Суббота, 11.11.2017, 01:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
добрый день.
нужно вторую табл. собрать из двух оставшихся 1 и 3. (данная таблица для примера, реальных данных очень много около 20 000 в каждой таблице)
данные разные поэтому нужна формула, которая сможет: найти данные наименования из 2таб. в 1 таб., но если не находит - смотрит в табл. 3 в статус

значения в табл.2 зависят от наличия совпадения в табл. 1 и от статуса в табл. 3(если в наличии - д.б. 1, если вернули - 0
если моркови нет , значит см. 3 таблицу столбец " статус", ее вернули значит в наличии нет, значит G6- 0

под этим нолем или 1 должна быть формула
К сообщению приложен файл: _Microsoft_Exce.xlsx(8Kb)


Сообщение отредактировал Лагуна - Суббота, 11.11.2017, 01:49
 
Ответить
Сообщениедобрый день.
нужно вторую табл. собрать из двух оставшихся 1 и 3. (данная таблица для примера, реальных данных очень много около 20 000 в каждой таблице)
данные разные поэтому нужна формула, которая сможет: найти данные наименования из 2таб. в 1 таб., но если не находит - смотрит в табл. 3 в статус

значения в табл.2 зависят от наличия совпадения в табл. 1 и от статуса в табл. 3(если в наличии - д.б. 1, если вернули - 0
если моркови нет , значит см. 3 таблицу столбец " статус", ее вернули значит в наличии нет, значит G6- 0

под этим нолем или 1 должна быть формула

Автор - Лагуна
Дата добавления - 11.11.2017 в 01:47
Pelena Дата: Суббота, 11.11.2017, 07:43 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11755
Репутация: 2596 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Не совсем понятно, зачем смотреть в табл.1
Код
=ЕСЛИ(ВПР(F4;$M$4:$N$8;2;0)="в наличии";1;ЕСЛИ(ВПР(F4;$M$4:$N$8;2;0)="вернули";0;""))
К сообщению приложен файл: 9230793.xlsx(9Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Не совсем понятно, зачем смотреть в табл.1
Код
=ЕСЛИ(ВПР(F4;$M$4:$N$8;2;0)="в наличии";1;ЕСЛИ(ВПР(F4;$M$4:$N$8;2;0)="вернули";0;""))

Автор - Pelena
Дата добавления - 11.11.2017 в 07:43
Лагуна Дата: Суббота, 11.11.2017, 10:37 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо за формулу. Но в 1 табл. нужно проверить обязательно, т.к. данные разнятся в таблицах, а в 1 табл. если имеется, значит 100% есть в наличии, в 3 табл. возможны ошибки, а 2 табл. у нас сборная(основная) с верными результатами.

буду благодарна, если поможете
 
Ответить
СообщениеСпасибо за формулу. Но в 1 табл. нужно проверить обязательно, т.к. данные разнятся в таблицах, а в 1 табл. если имеется, значит 100% есть в наличии, в 3 табл. возможны ошибки, а 2 табл. у нас сборная(основная) с верными результатами.

буду благодарна, если поможете

Автор - Лагуна
Дата добавления - 11.11.2017 в 10:37
gling Дата: Суббота, 11.11.2017, 11:11 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1656
Репутация: 403 ±
Замечаний: 0% ±

2010
Здравствуйте.
Код
=ЕСЛИОШИБКА(--((СЧЁТЕСЛИ($A$4:$A$19;F5)+(ВПР(F5;$M$4:$N$19;2;0)="в наличии"))>0);"")
Кросс.


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(--((СЧЁТЕСЛИ($A$4:$A$19;F5)+(ВПР(F5;$M$4:$N$19;2;0)="в наличии"))>0);"")
Кросс.

Автор - gling
Дата добавления - 11.11.2017 в 11:11
Лагуна Дата: Суббота, 11.11.2017, 11:58 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Излишнее цитирование удалено. Прочитайте Правила форума

вроде работает, спасибо. Я буду эту формулу применять к др. таблице, подскажите, пожалуйста, какой номер столбца мне выбирать,не конкретно, а на что опираться, на что смотреть в формуле ВПР?


Сообщение отредактировал _Boroda_ - Воскресенье, 12.11.2017, 00:48
 
Ответить
СообщениеИзлишнее цитирование удалено. Прочитайте Правила форума

вроде работает, спасибо. Я буду эту формулу применять к др. таблице, подскажите, пожалуйста, какой номер столбца мне выбирать,не конкретно, а на что опираться, на что смотреть в формуле ВПР?

Автор - Лагуна
Дата добавления - 11.11.2017 в 11:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сравнение данных и выведение числа при нескольких условиях (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!