Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/НАИБОЛЬШИЙ 2го 3го чисел а не повторение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » НАИБОЛЬШИЙ 2го 3го чисел а не повторение (Формулы/Formulas)
НАИБОЛЬШИЙ 2го 3го чисел а не повторение
sarxip Дата: Суббота, 11.11.2017, 11:06 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте
Код
=НАИБОЛЬШИЙ(AW18:AW27;1)
работает хорошо.
Код
=НАИБОЛЬШИЙ(AW18:AW27;2)
2 число не берет, а выводит повтор

я попробовал написать так
Код
=НАИБОЛЬШИЙ(AW18:AW27;{1;0:3;0})
и опять не работает
%)
К сообщению приложен файл: 9376993.xlsx(43Kb)


иии
 
Ответить
СообщениеЗдравствуйте
Код
=НАИБОЛЬШИЙ(AW18:AW27;1)
работает хорошо.
Код
=НАИБОЛЬШИЙ(AW18:AW27;2)
2 число не берет, а выводит повтор

я попробовал написать так
Код
=НАИБОЛЬШИЙ(AW18:AW27;{1;0:3;0})
и опять не работает
%)

Автор - sarxip
Дата добавления - 11.11.2017 в 11:06
Nic70y Дата: Суббота, 11.11.2017, 11:22 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4184
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
массивная
Код
=НАИБОЛЬШИЙ(ЕСЛИ(ПОИСКПОЗ(AW$18:AW$27;AW$18:AW$27;)=СТРОКА(AW$18:AW$27)-17;AW$18:AW$27);СТРОКА(AV1))
К сообщению приложен файл: 6106051.xlsx(41Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениемассивная
Код
=НАИБОЛЬШИЙ(ЕСЛИ(ПОИСКПОЗ(AW$18:AW$27;AW$18:AW$27;)=СТРОКА(AW$18:AW$27)-17;AW$18:AW$27);СТРОКА(AV1))

Автор - Nic70y
Дата добавления - 11.11.2017 в 11:22
TimSha Дата: Суббота, 11.11.2017, 11:27 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 525
Репутация: 82 ±
Замечаний: 0% ±

Excel 2013 Pro +
И чего вы еще хотите, когда у вас: 3 раза - 1100 и 4 раза - 520, итого 7 наибольших.
ps Надо думать о наибольших среди УНИКАЛЬНЫХ, как вариант, однако... ;)


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
СообщениеИ чего вы еще хотите, когда у вас: 3 раза - 1100 и 4 раза - 520, итого 7 наибольших.
ps Надо думать о наибольших среди УНИКАЛЬНЫХ, как вариант, однако... ;)

Автор - TimSha
Дата добавления - 11.11.2017 в 11:27
Nic70y Дата: Суббота, 11.11.2017, 11:38 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4184
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
УНИКАЛЬНЫХ

не, уникальные, это у которых счетесли=1, а тут
не повторение
все верно (как немного неграмотно может...)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
УНИКАЛЬНЫХ

не, уникальные, это у которых счетесли=1, а тут
не повторение
все верно (как немного неграмотно может...)

Автор - Nic70y
Дата добавления - 11.11.2017 в 11:38
sarxip Дата: Суббота, 11.11.2017, 11:55 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
а если внедрить формулу
Код
=ЕСЛИ()......


иии
 
Ответить
Сообщениеа если внедрить формулу
Код
=ЕСЛИ()......

Автор - sarxip
Дата добавления - 11.11.2017 в 11:55
Nic70y Дата: Суббота, 11.11.2017, 13:07 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4184
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
а если
а если посмотреть сообщение #2


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Суббота, 11.11.2017, 13:08
 
Ответить
Сообщение
а если
а если посмотреть сообщение #2

Автор - Nic70y
Дата добавления - 11.11.2017 в 13:07
sarxip Дата: Суббота, 11.11.2017, 13:31 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
ну эта формула не работает
Код
=НАИБОЛЬШИЙ(ЕСЛИ(ПОИСКПОЗ(AW$18:AW$27;AW$18:AW$27;)=СТРОКА(AW$18:AW$27)-17;AW$18:AW$27);СТРОКА(AV1))


иии
 
Ответить
Сообщениену эта формула не работает
Код
=НАИБОЛЬШИЙ(ЕСЛИ(ПОИСКПОЗ(AW$18:AW$27;AW$18:AW$27;)=СТРОКА(AW$18:AW$27)-17;AW$18:AW$27);СТРОКА(AV1))

Автор - sarxip
Дата добавления - 11.11.2017 в 13:31
Nic70y Дата: Суббота, 11.11.2017, 14:50 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4184
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
не работает
чем докажите?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
не работает
чем докажите?

Автор - Nic70y
Дата добавления - 11.11.2017 в 14:50
vikttur Дата: Суббота, 11.11.2017, 15:19 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2511
Репутация: 452 ±
Замечаний: 0% ±

ну эта формула не работает

Работает. Формулу нужно вводить как формулу массива - тремя клавишами Ctrl+SHIFT+ENTER

Вариант немассивной:
Код
=НАИБОЛЬШИЙ($AW$18:$AW$27;СУММПРОИЗВ(СЧЁТЕСЛИ($AW$18:$AW$27;$AW$10:AW10))+1)

Если мешает ошибка в нижних ячейках:
Код
=ЕСЛИОШИБКА(формула_выше;)


Сообщение отредактировал vikttur - Суббота, 11.11.2017, 15:22
 
Ответить
Сообщение
ну эта формула не работает

Работает. Формулу нужно вводить как формулу массива - тремя клавишами Ctrl+SHIFT+ENTER

Вариант немассивной:
Код
=НАИБОЛЬШИЙ($AW$18:$AW$27;СУММПРОИЗВ(СЧЁТЕСЛИ($AW$18:$AW$27;$AW$10:AW10))+1)

Если мешает ошибка в нижних ячейках:
Код
=ЕСЛИОШИБКА(формула_выше;)

Автор - vikttur
Дата добавления - 11.11.2017 в 15:19
Nic70y Дата: Суббота, 11.11.2017, 19:34 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4184
Репутация: 903 ±
Замечаний: 0% ±

Excel 2013
если в AW10 вписать 9E+307, можно так:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(AW$18:AW$27;СЧЁТЕСЛИ(AW$18:AW$27;"<"&AW10));"")
К сообщению приложен файл: 6563892.xlsx(42Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеесли в AW10 вписать 9E+307, можно так:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(AW$18:AW$27;СЧЁТЕСЛИ(AW$18:AW$27;"<"&AW10));"")

Автор - Nic70y
Дата добавления - 11.11.2017 в 19:34
sarxip Дата: Воскресенье, 12.11.2017, 11:43 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
hands
СУПЕР БЛАГОДАРЮ ВАС УВАЖАЕМЫЕ :D hands hands
Последнею формулу, которую вы прислали ОНА ЗАРАБОТАЛА
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(AW$18:AW$27;СЧЁТЕСЛИ(AW$18:AW$27;"<"&AW10));"")

потом я стал вводить (как формулу массива - тремя клавишами Ctrl+SHIFT+ENTER) весь столбец показывает наибольшее значение
я в первую клетку столбца вел формулу
Код
=НАИБОЛЬШИЙ(AW133:AW142;1)

а последующие, клетки в низ формулу вашу
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(AW$18:AW$27;СЧЁТЕСЛИ(AW$18:AW$27;"<"&AW10));"")

и ВУАЛЯ РАБОТАЕТ
вот что получилось
БЛАГОДАРЮ hands
К сообщению приложен файл: 9017106.xlsx(84Kb)


иии
 
Ответить
Сообщениеhands
СУПЕР БЛАГОДАРЮ ВАС УВАЖАЕМЫЕ :D hands hands
Последнею формулу, которую вы прислали ОНА ЗАРАБОТАЛА
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(AW$18:AW$27;СЧЁТЕСЛИ(AW$18:AW$27;"<"&AW10));"")

потом я стал вводить (как формулу массива - тремя клавишами Ctrl+SHIFT+ENTER) весь столбец показывает наибольшее значение
я в первую клетку столбца вел формулу
Код
=НАИБОЛЬШИЙ(AW133:AW142;1)

а последующие, клетки в низ формулу вашу
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(AW$18:AW$27;СЧЁТЕСЛИ(AW$18:AW$27;"<"&AW10));"")

и ВУАЛЯ РАБОТАЕТ
вот что получилось
БЛАГОДАРЮ hands

Автор - sarxip
Дата добавления - 12.11.2017 в 11:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » НАИБОЛЬШИЙ 2го 3го чисел а не повторение (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!