Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как убрать отображение ошибки #ЧИСЛА в шаблоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как убрать отображение ошибки #ЧИСЛА в шаблоне (Формулы/Formulas)
Как убрать отображение ошибки #ЧИСЛА в шаблоне
krasno Дата: Воскресенье, 12.11.2017, 01:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Подскажите пожалуйста, как убрать ошибку #ЧИСЛА при пустой таблице, чтобы не захламлять шаблон
К сообщению приложен файл: 0403186.xlsx(15Kb)
 
Ответить
СообщениеПодскажите пожалуйста, как убрать ошибку #ЧИСЛА при пустой таблице, чтобы не захламлять шаблон

Автор - krasno
Дата добавления - 12.11.2017 в 01:09
gling Дата: Воскресенье, 12.11.2017, 01:46 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1656
Репутация: 403 ±
Замечаний: 0% ±

2010
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(B2:I2;СЧЁТЕСЛИ(B2:I2;0)+1);"")


ЯД-41001506838083
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(B2:I2;СЧЁТЕСЛИ(B2:I2;0)+1);"")

Автор - gling
Дата добавления - 12.11.2017 в 01:46
krasno Дата: Воскресенье, 12.11.2017, 01:51 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Но в таком случае "СЧЕТЕСЛИ" становится бесполезной, пустые ячейки форматируются цветной заливной, относительно столбцов J и K
M и Q исправил, спасибо


Сообщение отредактировал krasno - Воскресенье, 12.11.2017, 01:56
 
Ответить
СообщениеНо в таком случае "СЧЕТЕСЛИ" становится бесполезной, пустые ячейки форматируются цветной заливной, относительно столбцов J и K
M и Q исправил, спасибо

Автор - krasno
Дата добавления - 12.11.2017 в 01:51
_Boroda_ Дата: Воскресенье, 12.11.2017, 02:16 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11644
Репутация: 4825 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Хорошо, тогда напишите так
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(B2:I2;СЧЁТЕСЛИ(B2:I2;0)+1);" ")
К сообщению приложен файл: 0403186_1.xlsx(15Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеХорошо, тогда напишите так
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(B2:I2;СЧЁТЕСЛИ(B2:I2;0)+1);" ")

Автор - _Boroda_
Дата добавления - 12.11.2017 в 02:16
krasno Дата: Воскресенье, 12.11.2017, 10:21 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Извините за глупость, но как то же самое добавить сюда?
Код
=ИНДЕКС(B$1:I$1;ПОИСКПОЗ(J2;B2:I2;))


Сообщение отредактировал krasno - Воскресенье, 12.11.2017, 10:50
 
Ответить
СообщениеИзвините за глупость, но как то же самое добавить сюда?
Код
=ИНДЕКС(B$1:I$1;ПОИСКПОЗ(J2;B2:I2;))

Автор - krasno
Дата добавления - 12.11.2017 в 10:21
Manyasha Дата: Воскресенье, 12.11.2017, 10:45 | Сообщение № 6
Группа: Модераторы
Ранг: Старожил
Сообщений: 2008
Репутация: 837 ±
Замечаний: 0% ±

Excel 2010, 2016
krasno, Оформите формулу тегами (кнопка fx)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеkrasno, Оформите формулу тегами (кнопка fx)

Автор - Manyasha
Дата добавления - 12.11.2017 в 10:45
krasno Дата: Воскресенье, 12.11.2017, 14:16 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Дико извиняюсь, не заметил файл экслевский, вопрос решен. Спасибо большое
 
Ответить
СообщениеДико извиняюсь, не заметил файл экслевский, вопрос решен. Спасибо большое

Автор - krasno
Дата добавления - 12.11.2017 в 14:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как убрать отображение ошибки #ЧИСЛА в шаблоне (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!