Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отображение нуля при использовании формулы округления - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение нуля при использовании формулы округления (Формулы/Formulas)
Отображение нуля при использовании формулы округления
ttv Дата: Понедельник, 13.11.2017, 12:25 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте, уважаемые форумчане!
Использую формулу для округления до значащих цифр.
Как избавиться от 2 проблем:
1) чтобы ноль являющийся значащей цифрой - отображался в ячейке, например число 0,104 округляем до двух значащих цифр - это будет 0,10, а в ячейке пишется 0,1. Использовать кнопку добавления разрядности неудобно, т.к. значений будет много и в каждом случае будет разная разрядность.
2) как обойти ошибку при округлении 0? Т. е. ячейки к которым будут применяться значения округления получаются из расчетов и где-то может получиться 0. Для дальнейших расчетов используются округленные значения. Так вот надо чтобы этот ноль и оставался нулем, не отображался как ошибка.

Может есть какие-то другие способы округлить до значащих цифр?
К сообщению приложен файл: 0004.xlsx(9Kb)


Сообщение отредактировал ttv - Понедельник, 13.11.2017, 12:31
 
Ответить
СообщениеЗдравствуйте, уважаемые форумчане!
Использую формулу для округления до значащих цифр.
Как избавиться от 2 проблем:
1) чтобы ноль являющийся значащей цифрой - отображался в ячейке, например число 0,104 округляем до двух значащих цифр - это будет 0,10, а в ячейке пишется 0,1. Использовать кнопку добавления разрядности неудобно, т.к. значений будет много и в каждом случае будет разная разрядность.
2) как обойти ошибку при округлении 0? Т. е. ячейки к которым будут применяться значения округления получаются из расчетов и где-то может получиться 0. Для дальнейших расчетов используются округленные значения. Так вот надо чтобы этот ноль и оставался нулем, не отображался как ошибка.

Может есть какие-то другие способы округлить до значащих цифр?

Автор - ttv
Дата добавления - 13.11.2017 в 12:25
buchlotnik Дата: Понедельник, 13.11.2017, 12:35 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3325
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
В лоб как-то так:
Код
=ЕСЛИ(A2>10;ОКРУГЛ(A2;2-(ЦЕЛОЕ(LOG10(ABS(A2)))+1));ТЕКСТ(A2;"0,"&ПОВТОР(0;ЕСЛИОШИБКА(2-(ЦЕЛОЕ(LOG10(ABS(A2)))+1);1))))
К сообщению приложен файл: 6537294.xlsx(9Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
СообщениеВ лоб как-то так:
Код
=ЕСЛИ(A2>10;ОКРУГЛ(A2;2-(ЦЕЛОЕ(LOG10(ABS(A2)))+1));ТЕКСТ(A2;"0,"&ПОВТОР(0;ЕСЛИОШИБКА(2-(ЦЕЛОЕ(LOG10(ABS(A2)))+1);1))))

Автор - buchlotnik
Дата добавления - 13.11.2017 в 12:35
ttv Дата: Среда, 15.11.2017, 11:48 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, сложноватая конструкция, но работает, спасибо!
Придется доп.столбец вводить...
 
Ответить
Сообщениеbuchlotnik, сложноватая конструкция, но работает, спасибо!
Придется доп.столбец вводить...

Автор - ttv
Дата добавления - 15.11.2017 в 11:48
buchlotnik Дата: Среда, 15.11.2017, 12:06 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3325
Репутация: 886 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
Придется доп.столбец вводить...
не понял - зачем?


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
Придется доп.столбец вводить...
не понял - зачем?

Автор - buchlotnik
Дата добавления - 15.11.2017 в 12:06
AlexM Дата: Среда, 15.11.2017, 13:23 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3598
Репутация: 903 ±
Замечаний: 0% ±

Excel 2003
Код
=ТЕКСТ(A2;"[>=10]0;0,"&ПОВТОР(0;1-ЕСЛИ(ЕОШ(A2^0);;ЦЕЛОЕ(LOG10(ABS(A2))))))
или так
Код
=ТЕКСТ(A2;"[>=10]0;0,"&ПОВТОР(0;1-ЦЕЛОЕ(LOG((A2=0)+ABS(A2)))))
К сообщению приложен файл: 0004_01.xlsx(9Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 15.11.2017, 14:48
 
Ответить
Сообщение
Код
=ТЕКСТ(A2;"[>=10]0;0,"&ПОВТОР(0;1-ЕСЛИ(ЕОШ(A2^0);;ЦЕЛОЕ(LOG10(ABS(A2))))))
или так
Код
=ТЕКСТ(A2;"[>=10]0;0,"&ПОВТОР(0;1-ЦЕЛОЕ(LOG((A2=0)+ABS(A2)))))

Автор - AlexM
Дата добавления - 15.11.2017 в 13:23
ttv Дата: Четверг, 16.11.2017, 04:49 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
не понял - зачем?

ячейки, которые надо округлять, сами из формул состоят, причем иногда довольно сложных с несколькими "если". Слишком громоздко будет. Проще посчитать результат формулой в один столбец, а потом добавить еще столбец с округлением и дальше уже работать с ним.
 
Ответить
Сообщение
не понял - зачем?

ячейки, которые надо округлять, сами из формул состоят, причем иногда довольно сложных с несколькими "если". Слишком громоздко будет. Проще посчитать результат формулой в один столбец, а потом добавить еще столбец с округлением и дальше уже работать с ним.

Автор - ttv
Дата добавления - 16.11.2017 в 04:49
ttv Дата: Четверг, 16.11.2017, 04:51 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
AlexM, спасибо, попробую и так :-)
 
Ответить
СообщениеAlexM, спасибо, попробую и так :-)

Автор - ttv
Дата добавления - 16.11.2017 в 04:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение нуля при использовании формулы округления (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!