Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск значений по нескольким условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значений по нескольким условиям (Формулы/Formulas)
поиск значений по нескольким условиям
deda Дата: Понедельник, 13.11.2017, 17:58 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Друзья, никак не могу додуматься до формулы.
В файле примере необходимо заполнить колонку B по следующим критериям:
-если в ячейке D "центр" - то берется адрес с ячейки C той-же строки. (это понятно как ;) )
-если в ячейке D не "центр", то берется адрес из ячейки C, который соответствует наименованию(ячейке А) и имеет состояние "центр".
-если "центра" по одному наименование в колонке А нет, то оставлять ячейку пустой.
К сообщению приложен файл: 3842290.xlsx(10Kb)


Сообщение отредактировал deda - Понедельник, 13.11.2017, 17:59
 
Ответить
СообщениеДрузья, никак не могу додуматься до формулы.
В файле примере необходимо заполнить колонку B по следующим критериям:
-если в ячейке D "центр" - то берется адрес с ячейки C той-же строки. (это понятно как ;) )
-если в ячейке D не "центр", то берется адрес из ячейки C, который соответствует наименованию(ячейке А) и имеет состояние "центр".
-если "центра" по одному наименование в колонке А нет, то оставлять ячейку пустой.

Автор - deda
Дата добавления - 13.11.2017 в 17:58
krosav4ig Дата: Понедельник, 13.11.2017, 18:51 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1480
Репутация: 599 ±
Замечаний: 0% ±

Excel 2007, 2013
здравствуйте
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($D$2:$D$22="Центр")/($A$2:$A$22=A2);$C$2:$C$22);"")
К сообщению приложен файл: 6187866.xlsx(10Kb)


(_)Õvõ(_)
 
Ответить
Сообщениездравствуйте
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($D$2:$D$22="Центр")/($A$2:$A$22=A2);$C$2:$C$22);"")

Автор - krosav4ig
Дата добавления - 13.11.2017 в 18:51
deda Дата: Понедельник, 13.11.2017, 19:04 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
krosav4ig, Благодарю.
Под вечер мозг уже не работает.
 
Ответить
Сообщениеkrosav4ig, Благодарю.
Под вечер мозг уже не работает.

Автор - deda
Дата добавления - 13.11.2017 в 19:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значений по нескольким условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!