Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать определенный диапазон событий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать определенный диапазон событий (Формулы/Formulas)
Посчитать определенный диапазон событий
stoniq Дата: Вторник, 21.11.2017, 15:41 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день всем!
В столбец "А" прилетают значения (прикрепил файл). Правее есть календарь, необходимо фиксировать события, которые происходили в столбце "А" по датам через СЧЕТЕСЛИМН (наверное). Интересуют события только с 9:00 до 18:00.
К сообщению приложен файл: test.xlsx(9Kb)
 
Ответить
СообщениеДобрый день всем!
В столбец "А" прилетают значения (прикрепил файл). Правее есть календарь, необходимо фиксировать события, которые происходили в столбце "А" по датам через СЧЕТЕСЛИМН (наверное). Интересуют события только с 9:00 до 18:00.

Автор - stoniq
Дата добавления - 21.11.2017 в 15:41
sboy Дата: Вторник, 21.11.2017, 16:49 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1166
Репутация: 294 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
вот так получилось
Код
=СУММПРОИЗВ((ОТБР($A$2:$A$59)=C$1)*(($A$2:$A$59-ОТБР($A$2:$A$59))<18/24)*(($A$2:$A$59-ОТБР($A$2:$A$59))>9/24))
К сообщению приложен файл: test-4-.xlsx(9Kb)
 
Ответить
СообщениеДобрый день.
вот так получилось
Код
=СУММПРОИЗВ((ОТБР($A$2:$A$59)=C$1)*(($A$2:$A$59-ОТБР($A$2:$A$59))<18/24)*(($A$2:$A$59-ОТБР($A$2:$A$59))>9/24))

Автор - sboy
Дата добавления - 21.11.2017 в 16:49
stoniq Дата: Вторник, 21.11.2017, 17:26 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 38
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
sboy,
Спасибо, супер!
 
Ответить
Сообщениеsboy,
Спасибо, супер!

Автор - stoniq
Дата добавления - 21.11.2017 в 17:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать определенный диапазон событий (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!