Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Совместить формат и формулу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Совместить формат и формулу (Формулы/Formulas)
Совместить формат и формулу
ovechkin1973 Дата: Вторник, 21.11.2017, 17:10 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 180
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Если не верно в теме суть проблемы описал, то прошу модераторов поправить..
Есть проблема, которую не знаю как решить. Файл с телефонами и населенными пунктами. Для удобной записи кода населенного пункта сделал формат 8" "(#).
Чтобы код населенного пункта проставлялся автоматом в зависимости от его названия написал формулу
Код
ЕСЛИ(B2="Екатеринбург";"343";"")

После этого у меня мой формат не работает. Как можно решить проблему?
К сообщению приложен файл: 5629176.xlsx(9Kb)


Плохо когда не знаешь, да еще забудешь.

Сообщение отредактировал ovechkin1973 - Вторник, 21.11.2017, 17:11
 
Ответить
СообщениеЕсли не верно в теме суть проблемы описал, то прошу модераторов поправить..
Есть проблема, которую не знаю как решить. Файл с телефонами и населенными пунктами. Для удобной записи кода населенного пункта сделал формат 8" "(#).
Чтобы код населенного пункта проставлялся автоматом в зависимости от его названия написал формулу
Код
ЕСЛИ(B2="Екатеринбург";"343";"")

После этого у меня мой формат не работает. Как можно решить проблему?

Автор - ovechkin1973
Дата добавления - 21.11.2017 в 17:10
pabchek Дата: Вторник, 21.11.2017, 17:14 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 788
Репутация: 177 ±
Замечаний: 0% ±

Excel 2007
Попробуйте убрать кавычки
Код
=ЕСЛИ(B2="Екатеринбург";343;"")


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеПопробуйте убрать кавычки
Код
=ЕСЛИ(B2="Екатеринбург";343;"")

Автор - pabchek
Дата добавления - 21.11.2017 в 17:14
_Boroda_ Дата: Вторник, 21.11.2017, 17:42 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У Вас там наверняка не только Екатеринбург, да? Тогда вот так можно
Код
=ЕСЛИОШИБКА(ВЫБОР(ПОИСКПОЗ(B2;{"Екатеринбург":"Москва":"Новосибирск":"Еще город"};);343;444;555;222);"")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ Вас там наверняка не только Екатеринбург, да? Тогда вот так можно
Код
=ЕСЛИОШИБКА(ВЫБОР(ПОИСКПОЗ(B2;{"Екатеринбург":"Москва":"Новосибирск":"Еще город"};);343;444;555;222);"")

Автор - _Boroda_
Дата добавления - 21.11.2017 в 17:42
ovechkin1973 Дата: Вторник, 21.11.2017, 19:47 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 180
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
век живи и век учись.. а помрешь все равно не грамотным.. Спасибо pabchek, _Boroda_, - оба варианта работают... Формула _Boroda_, намного "легче", чем 11 проверок ЕСЛИ в моем случае.


Плохо когда не знаешь, да еще забудешь.
 
Ответить
Сообщениевек живи и век учись.. а помрешь все равно не грамотным.. Спасибо pabchek, _Boroda_, - оба варианта работают... Формула _Boroda_, намного "легче", чем 11 проверок ЕСЛИ в моем случае.

Автор - ovechkin1973
Дата добавления - 21.11.2017 в 19:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Совместить формат и формулу (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!