Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сцепить данные из двух ячеек в определенной последовательнос - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сцепить данные из двух ячеек в определенной последовательнос (Формулы/Formulas)
Сцепить данные из двух ячеек в определенной последовательнос
Diadar Дата: Четверг, 23.11.2017, 18:09 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Есть таблица с данными.

Есть основная ячейка в таблице - у нее название начинается с КОД (C2, C5, C10) и под каждым кодом есть несколько его модификаций: например в ячейка C2 крем белый.

Нужно составить формулу с помощью которой можно получить данные, как в колонке M (как должно быть).

То есть чтобы система брала ячейку с кодом сцепляла ее с модификациями и дальше если встречает новую ячейку с кодом, то брала уже ее и также сцепляла с ее модификациями.

Спасибо.
К сообщению приложен файл: 7956732.xls(32.5 Kb)
 
Ответить
СообщениеЕсть таблица с данными.

Есть основная ячейка в таблице - у нее название начинается с КОД (C2, C5, C10) и под каждым кодом есть несколько его модификаций: например в ячейка C2 крем белый.

Нужно составить формулу с помощью которой можно получить данные, как в колонке M (как должно быть).

То есть чтобы система брала ячейку с кодом сцепляла ее с модификациями и дальше если встречает новую ячейку с кодом, то брала уже ее и также сцепляла с ее модификациями.

Спасибо.

Автор - Diadar
Дата добавления - 23.11.2017 в 18:09
Karataev Дата: Четверг, 23.11.2017, 18:28 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1233
Репутация: 464 ±
Замечаний: 0% ±

Excel
Формула для "M3":
Код
=ЕСЛИ(K3<>"";ЕСЛИ(ЛЕВСИМВ(C2;3)="код";C2&" "&C3;ЛЕВСИМВ(M2;ДЛСТР(M2)-ДЛСТР(C2))&C3);"")
К сообщению приложен файл: 7956732_kar.xls(33.0 Kb)


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288


Сообщение отредактировал Karataev - Четверг, 23.11.2017, 18:30
 
Ответить
СообщениеФормула для "M3":
Код
=ЕСЛИ(K3<>"";ЕСЛИ(ЛЕВСИМВ(C2;3)="код";C2&" "&C3;ЛЕВСИМВ(M2;ДЛСТР(M2)-ДЛСТР(C2))&C3);"")

Автор - Karataev
Дата добавления - 23.11.2017 в 18:28
_Boroda_ Дата: Четверг, 23.11.2017, 19:39 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12126
Репутация: 5004 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ЕСЛИ(K1="";"";ПРОСМОТР(;-1/ЕПУСТО(K$1:K1);C$1:C1)&" "&C1)
К сообщению приложен файл: 7956732_1.xls(34.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ЕСЛИ(K1="";"";ПРОСМОТР(;-1/ЕПУСТО(K$1:K1);C$1:C1)&" "&C1)

Автор - _Boroda_
Дата добавления - 23.11.2017 в 19:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сцепить данные из двух ячеек в определенной последовательнос (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!