Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Корректировка формулы для подсчета отфильтр-го диапозона - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Корректировка формулы для подсчета отфильтр-го диапозона (Формулы/Formulas)
Корректировка формулы для подсчета отфильтр-го диапозона
konsta-spb Дата: Пятница, 24.11.2017, 16:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
В прошлом запросе по подсчету времени в ячейках с прописанными значениями времени. мне очень помог Уважаемый Boroda!
В данный момент столкнулся с тем, что применяя фильтр, чтобы видеть только к примеру исходящие звонки колл-центра, формула естественно считает и скрытые ячейки.
Возможно ли внести корректировку в формулу, чтобы она игнорировала скрытые ячейки? Или допустим сделать рядом вторую таблицу, в которой будут считать только отфильтрованные ячейки?
Вот пример:
К сообщению приложен файл: 0647593.xlsx(14Kb)
 
Ответить
СообщениеДобрый день!
В прошлом запросе по подсчету времени в ячейках с прописанными значениями времени. мне очень помог Уважаемый Boroda!
В данный момент столкнулся с тем, что применяя фильтр, чтобы видеть только к примеру исходящие звонки колл-центра, формула естественно считает и скрытые ячейки.
Возможно ли внести корректировку в формулу, чтобы она игнорировала скрытые ячейки? Или допустим сделать рядом вторую таблицу, в которой будут считать только отфильтрованные ячейки?
Вот пример:

Автор - konsta-spb
Дата добавления - 24.11.2017 в 16:39
Pelena Дата: Пятница, 24.11.2017, 18:11 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11841
Репутация: 2608 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Вариант с доп. столбцом
----------------------------
UPD. Или без доп. столбца
Код
=СУММ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ($C$2;СТРОКА($1:$234);0))*ПОДСТАВИТЬ(ПОДСТАВИТЬ(ЕСЛИ(ЕЧИСЛО(ПОИСК(",";C3:C236));"0:";"0:0:")&C3:C236;" мин, ";":");" сек";))
К сообщению приложен файл: 5571727.xlsx(13Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Вариант с доп. столбцом
----------------------------
UPD. Или без доп. столбца
Код
=СУММ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ($C$2;СТРОКА($1:$234);0))*ПОДСТАВИТЬ(ПОДСТАВИТЬ(ЕСЛИ(ЕЧИСЛО(ПОИСК(",";C3:C236));"0:";"0:0:")&C3:C236;" мин, ";":");" сек";))

Автор - Pelena
Дата добавления - 24.11.2017 в 18:11
konsta-spb Дата: Понедельник, 27.11.2017, 09:35 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Большое спасибо!
 
Ответить
СообщениеБольшое спасибо!

Автор - konsta-spb
Дата добавления - 27.11.2017 в 09:35
_Boroda_ Дата: Понедельник, 27.11.2017, 09:47 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Похожий вариант
Код
=СУММ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;ДВССЫЛ("C"&СТРОКА(3:236)))*ПОДСТАВИТЬ(ПОДСТАВИТЬ(ЕСЛИ(ЕЧИСЛО(ПОИСК(",";C3:C236));"0:";"0:0:")&C3:C236;" мин, ";":");" сек";))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПохожий вариант
Код
=СУММ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;ДВССЫЛ("C"&СТРОКА(3:236)))*ПОДСТАВИТЬ(ПОДСТАВИТЬ(ЕСЛИ(ЕЧИСЛО(ПОИСК(",";C3:C236));"0:";"0:0:")&C3:C236;" мин, ";":");" сек";))

Автор - _Boroda_
Дата добавления - 27.11.2017 в 09:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Корректировка формулы для подсчета отфильтр-го диапозона (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!