Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма общего количества повторяющихся значений в столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма общего количества повторяющихся значений в столбце (Формулы/Formulas)
Сумма общего количества повторяющихся значений в столбце
stns Дата: Воскресенье, 26.11.2017, 16:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте!

Нужно подсчитать в таблице, где много тысяч строк, общее количество вагонов. Вся сложность в том, что некоторые вагоны несколько раз съездили туда-сюда (в прилагаемом файле выделил два таких разными цветами) и они не попадают под критерий формул

Код
=СУММПРОИЗВ(1/СЧЁТЕСЛИ(В2:В75;В8:В75))


или

Код
=СУММ(ЕСЛИ(ЧАСТОТА(ПОИСКПОЗ(B2:B75;B2:B75;0);ПОИСКПОЗ(B2:B75;B2:B75;0))>0;1))


и еще сложность, что по условиям оформления отчета, что каждой позиции продукции в вагоне уделена отдельная строка, и номер вагона повторяется в зависимости от количества этих позиций. Количество позиций разное. Ну и один вагон от другого отделяется жирным подчеркиванием.

Нельзя ли задать критерий подсчета тех самых нижний подчеркиваний? Или может еще какие-то варианты...

Буду благодарен.
К сообщению приложен файл: 2874397.xls(74Kb)


Сообщение отредактировал stns - Воскресенье, 26.11.2017, 19:40
 
Ответить
СообщениеЗдравствуйте!

Нужно подсчитать в таблице, где много тысяч строк, общее количество вагонов. Вся сложность в том, что некоторые вагоны несколько раз съездили туда-сюда (в прилагаемом файле выделил два таких разными цветами) и они не попадают под критерий формул

Код
=СУММПРОИЗВ(1/СЧЁТЕСЛИ(В2:В75;В8:В75))


или

Код
=СУММ(ЕСЛИ(ЧАСТОТА(ПОИСКПОЗ(B2:B75;B2:B75;0);ПОИСКПОЗ(B2:B75;B2:B75;0))>0;1))


и еще сложность, что по условиям оформления отчета, что каждой позиции продукции в вагоне уделена отдельная строка, и номер вагона повторяется в зависимости от количества этих позиций. Количество позиций разное. Ну и один вагон от другого отделяется жирным подчеркиванием.

Нельзя ли задать критерий подсчета тех самых нижний подчеркиваний? Или может еще какие-то варианты...

Буду благодарен.

Автор - stns
Дата добавления - 26.11.2017 в 16:17
Pelena Дата: Воскресенье, 26.11.2017, 19:36 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11829
Репутация: 2604 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
stns, оформите формулы тегами с помощью кнопки fx в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеstns, оформите формулы тегами с помощью кнопки fx в режиме правки поста

Автор - Pelena
Дата добавления - 26.11.2017 в 19:36
Pelena Дата: Воскресенье, 26.11.2017, 19:44 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11829
Репутация: 2604 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
То есть 8 - неверный ответ?
А так?
Код
=СУММПРОИЗВ(--(B1:B74<>B2:B75))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТо есть 8 - неверный ответ?
А так?
Код
=СУММПРОИЗВ(--(B1:B74<>B2:B75))

Автор - Pelena
Дата добавления - 26.11.2017 в 19:44
stns Дата: Воскресенье, 26.11.2017, 20:07 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, спасибо! Но в прилагаемой здесь маленькой табличке формула сработала, а там где много тысяч строк, к сожалению не срабатывает. Подробности отправил в личке, с приложенным полным вариантом книги.
 
Ответить
СообщениеPelena, спасибо! Но в прилагаемой здесь маленькой табличке формула сработала, а там где много тысяч строк, к сожалению не срабатывает. Подробности отправил в личке, с приложенным полным вариантом книги.

Автор - stns
Дата добавления - 26.11.2017 в 20:07
Pelena Дата: Воскресенье, 26.11.2017, 20:11 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11829
Репутация: 2604 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Подробности отправил в личке,

Это нарушение Правил форума


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Подробности отправил в личке,

Это нарушение Правил форума

Автор - Pelena
Дата добавления - 26.11.2017 в 20:11
stns Дата: Воскресенье, 26.11.2017, 20:16 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, я здесь не частый гость, но ресурс ваш уважаю, правила старался читать, но наверное этот момент упустил. Неумышленно, извините!

Формула работает, внимательнее с ней разобрался (не без Вашей помощи))), все работает, спасибо большое!
 
Ответить
СообщениеPelena, я здесь не частый гость, но ресурс ваш уважаю, правила старался читать, но наверное этот момент упустил. Неумышленно, извините!

Формула работает, внимательнее с ней разобрался (не без Вашей помощи))), все работает, спасибо большое!

Автор - stns
Дата добавления - 26.11.2017 в 20:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма общего количества повторяющихся значений в столбце (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!