Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет разницы между столбцами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет разницы между столбцами (Формулы/Formulas)
Подсчет разницы между столбцами
Smetchik Дата: Воскресенье, 26.11.2017, 16:20 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Можно ли сделать так, чтобы значение в столбце разница вычислялась не путем ввода формулы "= Значение 1-Значение 2-Значение 3" без написания макросов. А если у меня их сотни? Извините за вопрос от "чайника".
К сообщению приложен файл: 6786138.xls(26Kb)


Сообщение отредактировал Smetchik - Воскресенье, 26.11.2017, 16:37
 
Ответить
СообщениеМожно ли сделать так, чтобы значение в столбце разница вычислялась не путем ввода формулы "= Значение 1-Значение 2-Значение 3" без написания макросов. А если у меня их сотни? Извините за вопрос от "чайника".

Автор - Smetchik
Дата добавления - 26.11.2017 в 16:20
Nic70y Дата: Воскресенье, 26.11.2017, 16:46 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4236
Репутация: 922 ±
Замечаний: 0% ±

Excel 2013
E6 и т.д.
Код
=ЕСЛИ(C6="";"";C6-СУММ(D6:ИНДЕКС(D6:D$27145;ЕСЛИОШИБКА(ПОИСКПОЗ("*";B7:B$27145;);27145-СТРОКА()))))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Воскресенье, 26.11.2017, 16:47
 
Ответить
СообщениеE6 и т.д.
Код
=ЕСЛИ(C6="";"";C6-СУММ(D6:ИНДЕКС(D6:D$27145;ЕСЛИОШИБКА(ПОИСКПОЗ("*";B7:B$27145;);27145-СТРОКА()))))

Автор - Nic70y
Дата добавления - 26.11.2017 в 16:46
vikttur Дата: Воскресенье, 26.11.2017, 16:47 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2555
Репутация: 460 ±
Замечаний: 0% ±

Цитата
не путем ввода формулы ... без написания макросов

Если и не формулой, и не макросом - пишите вручную...


Сообщение отредактировал vikttur - Воскресенье, 26.11.2017, 16:48
 
Ответить
Сообщение
Цитата
не путем ввода формулы ... без написания макросов

Если и не формулой, и не макросом - пишите вручную...

Автор - vikttur
Дата добавления - 26.11.2017 в 16:47
Smetchik Дата: Воскресенье, 26.11.2017, 16:54 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
vikttur, Имелось ввиду созданием сложной формулы. Не могу заставить Excel понимать, где заканчиваются платежи по одному арендатору и начинаются по следующему.


Сообщение отредактировал Smetchik - Воскресенье, 26.11.2017, 16:55
 
Ответить
Сообщениеvikttur, Имелось ввиду созданием сложной формулы. Не могу заставить Excel понимать, где заканчиваются платежи по одному арендатору и начинаются по следующему.

Автор - Smetchik
Дата добавления - 26.11.2017 в 16:54
vikttur Дата: Воскресенье, 26.11.2017, 16:56 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2555
Репутация: 460 ±
Замечаний: 0% ±

Код
=ЕСЛИ(C6;СУММ(C6:$C$19)-СУММ(D6:$D$19;E7:$E$19);"")

Правильнее вместо "" написать 0, а нулевые значения скрыть (есть галка в параметрах листа)


Сообщение отредактировал vikttur - Воскресенье, 26.11.2017, 17:07
 
Ответить
Сообщение
Код
=ЕСЛИ(C6;СУММ(C6:$C$19)-СУММ(D6:$D$19;E7:$E$19);"")

Правильнее вместо "" написать 0, а нулевые значения скрыть (есть галка в параметрах листа)

Автор - vikttur
Дата добавления - 26.11.2017 в 16:56
Smetchik Дата: Воскресенье, 26.11.2017, 17:08 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
vikttur, Спасибо. Экспериментировал до этого с ЕСЛИ, но ничего не выходило.


Сообщение отредактировал Smetchik - Воскресенье, 26.11.2017, 17:19
 
Ответить
Сообщениеvikttur, Спасибо. Экспериментировал до этого с ЕСЛИ, но ничего не выходило.

Автор - Smetchik
Дата добавления - 26.11.2017 в 17:08
Smetchik Дата: Воскресенье, 26.11.2017, 17:28 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Nic70y, Спасибо. А быстрее такую формулу написать или создать макрос?
 
Ответить
СообщениеNic70y, Спасибо. А быстрее такую формулу написать или создать макрос?

Автор - Smetchik
Дата добавления - 26.11.2017 в 17:28
Smetchik Дата: Воскресенье, 26.11.2017, 17:35 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Извините за назойливость, но в развитии данной темы возник вопрос: "А можно ли отрицательные числа автоматически выделять каким-либо цветом или заливкой, а положительные другим с использованием данной формулы"? Или это уже макросы?
 
Ответить
СообщениеИзвините за назойливость, но в развитии данной темы возник вопрос: "А можно ли отрицательные числа автоматически выделять каким-либо цветом или заливкой, а положительные другим с использованием данной формулы"? Или это уже макросы?

Автор - Smetchik
Дата добавления - 26.11.2017 в 17:35
vikttur Дата: Воскресенье, 26.11.2017, 17:48 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2555
Репутация: 460 ±
Замечаний: 0% ±

Не обязательно макросы, но обязательно в новой теме. Данная формула к этому вопросу не имеет отношения.


Сообщение отредактировал vikttur - Воскресенье, 26.11.2017, 17:49
 
Ответить
СообщениеНе обязательно макросы, но обязательно в новой теме. Данная формула к этому вопросу не имеет отношения.

Автор - vikttur
Дата добавления - 26.11.2017 в 17:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет разницы между столбцами (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!