Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Работа с датами и временными отрезками - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Работа с датами и временными отрезками (Формулы/Formulas)
Работа с датами и временными отрезками
mak7321 Дата: Четверг, 30.11.2017, 17:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте! Вроде бы есть решение задачи, но думаю существует более короткий путь. Условие: есть столбец с временем замера температуры ( 6-8 замеров за сутки с указанием времени замера часы и минуты с датой); столбец показаний замера.
Задание: вычислить сумму оптимальных температур за период с 1 мая по 31 сентября каждого года, при этом брать одно максимальное значение температуры за сутки при условии что показание >= +10 градусов.
Заранее благодарен за помощь!


Мастер
 
Ответить
СообщениеЗдравствуйте! Вроде бы есть решение задачи, но думаю существует более короткий путь. Условие: есть столбец с временем замера температуры ( 6-8 замеров за сутки с указанием времени замера часы и минуты с датой); столбец показаний замера.
Задание: вычислить сумму оптимальных температур за период с 1 мая по 31 сентября каждого года, при этом брать одно максимальное значение температуры за сутки при условии что показание >= +10 градусов.
Заранее благодарен за помощь!

Автор - mak7321
Дата добавления - 30.11.2017 в 17:26
Pelena Дата: Четверг, 30.11.2017, 18:23 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11841
Репутация: 2608 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
mak7321, приложите файл с примером в формате Excel в соответствии с Правилами форума
по 31 сентября
Это будет трудно :D


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеmak7321, приложите файл с примером в формате Excel в соответствии с Правилами форума
по 31 сентября
Это будет трудно :D

Автор - Pelena
Дата добавления - 30.11.2017 в 18:23
mak7321 Дата: Четверг, 30.11.2017, 19:11 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Файл вставить не получается он больше 100кб, может из-за 13 офиса


Мастер
 
Ответить
СообщениеФайл вставить не получается он больше 100кб, может из-за 13 офиса

Автор - mak7321
Дата добавления - 30.11.2017 в 19:11
Che79 Дата: Четверг, 30.11.2017, 19:16 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 660
Репутация: 114 ±
Замечаний: 0% ±

Excel 2007, 2013
Файл вставить не получается
принимаются в архивах и/или xlsb


Делай нормально и будет нормально!
 
Ответить
Сообщение
Файл вставить не получается
принимаются в архивах и/или xlsb

Автор - Che79
Дата добавления - 30.11.2017 в 19:16
mak7321 Дата: Четверг, 30.11.2017, 19:34 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Архив с файлом
К сообщению приложен файл: 2873829.rar(48Kb)


Мастер
 
Ответить
СообщениеАрхив с файлом

Автор - mak7321
Дата добавления - 30.11.2017 в 19:34
_Boroda_ Дата: Четверг, 30.11.2017, 20:27 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Почто такой крохотный? Пришлось все-таки самому делать файл. Влезло почти 7000 строк

Сводная по сводной. По идее можно все в одну засунуть (попробовать через Квери, например), но это сложнее

Последовательность действий
1. Выделяете весь столбец А - Данные - Текст по столбцам - Готово
2. Встаете в ячейку А1 - Вставка - Сводная таблица - На этот лист
3. Встаете на сводную - Конструктор - Макет - Показать в табличной форме. Конструктор - Макет - Повторять подписи элементов
4. Выводите даты в строки - правой мышой на любую ячейку - Группировать - выбираете Годы, Месяцы, дни
5. В значения выводите t, левой мышой на него - Параметры поля - Максимум
6. Копируете шапку, вставляете на строку выше
7. Выделяете все полученное (можно с запасом внизу), Вставка - Сводная таблица - На этот лист
8. Годы в названия строк, Месяцы в фильтр, Максимумы - в значения
9. В фильтре ставите галку Разрешить выделение нескольких элементов и снимаете галки с ненужного

* Если фильтр по месяцам сделать в первой сводной, а не во второй, то еще лучше получается

===============
Формулами тоже можно, но у Вас же там 5х365х7 примерно 13000 строк. Повиснет всё
К сообщению приложен файл: 1_4.rar(94Kb) · 1_5.rar(90Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПочто такой крохотный? Пришлось все-таки самому делать файл. Влезло почти 7000 строк

Сводная по сводной. По идее можно все в одну засунуть (попробовать через Квери, например), но это сложнее

Последовательность действий
1. Выделяете весь столбец А - Данные - Текст по столбцам - Готово
2. Встаете в ячейку А1 - Вставка - Сводная таблица - На этот лист
3. Встаете на сводную - Конструктор - Макет - Показать в табличной форме. Конструктор - Макет - Повторять подписи элементов
4. Выводите даты в строки - правой мышой на любую ячейку - Группировать - выбираете Годы, Месяцы, дни
5. В значения выводите t, левой мышой на него - Параметры поля - Максимум
6. Копируете шапку, вставляете на строку выше
7. Выделяете все полученное (можно с запасом внизу), Вставка - Сводная таблица - На этот лист
8. Годы в названия строк, Месяцы в фильтр, Максимумы - в значения
9. В фильтре ставите галку Разрешить выделение нескольких элементов и снимаете галки с ненужного

* Если фильтр по месяцам сделать в первой сводной, а не во второй, то еще лучше получается

===============
Формулами тоже можно, но у Вас же там 5х365х7 примерно 13000 строк. Повиснет всё

Автор - _Boroda_
Дата добавления - 30.11.2017 в 20:27
mak7321 Дата: Четверг, 30.11.2017, 20:49 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, благодарю за поддержку! Сижу вникаю..... Но хотел увидеть решение через функцию. Жаль, что не могу прислать своё решение, почему-то мои эксели огромные получаются,- не знаю почему


Мастер
 
Ответить
Сообщение_Boroda_, благодарю за поддержку! Сижу вникаю..... Но хотел увидеть решение через функцию. Жаль, что не могу прислать своё решение, почему-то мои эксели огромные получаются,- не знаю почему

Автор - mak7321
Дата добавления - 30.11.2017 в 20:49
_Boroda_ Дата: Четверг, 30.11.2017, 21:38 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А что ж не написали, что
хотел увидеть решение через функцию

Тогда тяните вниз в файле в столбце С формулу массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИ(ЛЕВБ(A2;2)<>ЛЕВБ(A1;2);ЕСЛИ(ТЕКСТ(E$1;"ММДД")<=ТЕКСТ(A2;"ММДД");ЕСЛИ(ТЕКСТ(F$1;"ММДД")>=ТЕКСТ(A2;"ММДД");МАКС(B2:ИНДЕКС(B2:B11;ПОИСКПОЗ(ОТБР(--A2);--A2:A11;-1))))))

и наслаждайтесь
И да, как Елена выше уже написала, внимательно с датами - 31 сентября не нужно вводить
К сообщению приложен файл: 1_8.xlsb(90Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА что ж не написали, что
хотел увидеть решение через функцию

Тогда тяните вниз в файле в столбце С формулу массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИ(ЛЕВБ(A2;2)<>ЛЕВБ(A1;2);ЕСЛИ(ТЕКСТ(E$1;"ММДД")<=ТЕКСТ(A2;"ММДД");ЕСЛИ(ТЕКСТ(F$1;"ММДД")>=ТЕКСТ(A2;"ММДД");МАКС(B2:ИНДЕКС(B2:B11;ПОИСКПОЗ(ОТБР(--A2);--A2:A11;-1))))))

и наслаждайтесь
И да, как Елена выше уже написала, внимательно с датами - 31 сентября не нужно вводить

Автор - _Boroda_
Дата добавления - 30.11.2017 в 21:38
mak7321 Дата: Пятница, 01.12.2017, 07:41 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, О чудо! Свершилось! Вы первые, кто заметил про 31 сентября :D
ОГРОМНОЕ СПАСИБО! МЫ спасены! Профессионализм высокого класса! БРАВО!


Мастер
 
Ответить
Сообщение_Boroda_, О чудо! Свершилось! Вы первые, кто заметил про 31 сентября :D
ОГРОМНОЕ СПАСИБО! МЫ спасены! Профессионализм высокого класса! БРАВО!

Автор - mak7321
Дата добавления - 01.12.2017 в 07:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Работа с датами и временными отрезками (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!