Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение места конкретного товара - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение места конкретного товара (Формулы/Formulas)
Определение места конкретного товара
ПАМ Дата: Среда, 06.12.2017, 13:38 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 124
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте.
Помогите мне пожалуйста разобраться в проблеме: мне нужно чтобы в ячейках D8-D12 (Возможно даже дальше, в зависимости от количества ячеек в столбце А) было показано какой товар занимает данное место (места у меня распределяются в ячейках D2-D6).
Я пытался сделать через [code]ВПР[code] но похоже я ее плохо знаю, [offtop]а хотелось бы понять :) :) :) [/offtop] .

Спасибо большое заранее!
К сообщению приложен файл: 5852985.xlsx(9Kb)


Сообщение отредактировал ПАМ - Среда, 06.12.2017, 13:39
 
Ответить
СообщениеЗдравствуйте.
Помогите мне пожалуйста разобраться в проблеме: мне нужно чтобы в ячейках D8-D12 (Возможно даже дальше, в зависимости от количества ячеек в столбце А) было показано какой товар занимает данное место (места у меня распределяются в ячейках D2-D6).
Я пытался сделать через [code]ВПР[code] но похоже я ее плохо знаю, [offtop]а хотелось бы понять :) :) :) [/offtop] .

Спасибо большое заранее!

Автор - ПАМ
Дата добавления - 06.12.2017 в 13:38
buchlotnik Дата: Среда, 06.12.2017, 13:42 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3430
Репутация: 920 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Код
=ИНДЕКС(A2:A6;ПОИСКПОЗ(1;D2:D6;0))
К сообщению приложен файл: 2654857.xlsx(10Kb)


"заступлюсь за Юрия" - публичный плевок в душу!
 
Ответить
Сообщение
Код
=ИНДЕКС(A2:A6;ПОИСКПОЗ(1;D2:D6;0))

Автор - buchlotnik
Дата добавления - 06.12.2017 в 13:42
_Boroda_ Дата: Среда, 06.12.2017, 13:43 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11850
Репутация: 4910 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(A$2:A$6;ПОИСКПОЗ(СТРОКА(D1);D$2:D$6;))
К сообщению приложен файл: 5852985_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(A$2:A$6;ПОИСКПОЗ(СТРОКА(D1);D$2:D$6;))

Автор - _Boroda_
Дата добавления - 06.12.2017 в 13:43
vikttur Дата: Среда, 06.12.2017, 13:46 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2555
Репутация: 460 ±
Замечаний: 0% ±

Код
=ИНДЕКС(A2:A6;ПОИСКПОЗ(C8;D2:D6;0))

Код
=ПРОСМОТР(2;1/(D2:D6=C8);A2:A6)

Если данные переставить:
Код
=ВПР(C8;G2:H6;2;0)
К сообщению приложен файл: 0083865.xlsx(9Kb)


Сообщение отредактировал vikttur - Среда, 06.12.2017, 13:47
 
Ответить
Сообщение
Код
=ИНДЕКС(A2:A6;ПОИСКПОЗ(C8;D2:D6;0))

Код
=ПРОСМОТР(2;1/(D2:D6=C8);A2:A6)

Если данные переставить:
Код
=ВПР(C8;G2:H6;2;0)

Автор - vikttur
Дата добавления - 06.12.2017 в 13:46
ПАМ Дата: Среда, 06.12.2017, 13:48 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 124
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, buchlotnik, Огромное спасибо! Выручили на все 100 :) Проблема решена


Сообщение отредактировал ПАМ - Среда, 06.12.2017, 13:49
 
Ответить
Сообщение_Boroda_, buchlotnik, Огромное спасибо! Выручили на все 100 :) Проблема решена

Автор - ПАМ
Дата добавления - 06.12.2017 в 13:48
ПАМ Дата: Среда, 06.12.2017, 13:49 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 124
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
vikttur, Вам тоже спасибо
 
Ответить
Сообщениеvikttur, Вам тоже спасибо

Автор - ПАМ
Дата добавления - 06.12.2017 в 13:49
Che79 Дата: Среда, 06.12.2017, 14:58 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 654
Репутация: 113 ±
Замечаний: 0% ±

Excel 2007, 2013
Вдогонку, вдруг пригодится
пытался сделать через ВПР
Код
=ВПР(СТРОКА(D1);ЕСЛИ({1;0};$D$2:$D$6;$A$2:$A$6);2;)
К сообщению приложен файл: 2654857_1.xlsx(10Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеВдогонку, вдруг пригодится
пытался сделать через ВПР
Код
=ВПР(СТРОКА(D1);ЕСЛИ({1;0};$D$2:$D$6;$A$2:$A$6);2;)

Автор - Che79
Дата добавления - 06.12.2017 в 14:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение места конкретного товара (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!