Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор любого значения из выбранного списка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор любого значения из выбранного списка (Формулы/Formulas)
Выбор любого значения из выбранного списка
ПАМ Дата: Среда, 06.12.2017, 21:02 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 124
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Приветствую всех!
Уважаемые специалисты помогите мне ещё раз за сегодня: мне нужно, чтобы в ячейке А1 листа основа, "принимала" любое значение из столбца В листа Определение и следовательно в ячейке B1 листа Основа был "+", а то у меня получилось только если b2 равно А1.

Заранее еще раз очень благодарен!
К сообщению приложен файл: ___1.xlsx(10Kb)
 
Ответить
СообщениеПриветствую всех!
Уважаемые специалисты помогите мне ещё раз за сегодня: мне нужно, чтобы в ячейке А1 листа основа, "принимала" любое значение из столбца В листа Определение и следовательно в ячейке B1 листа Основа был "+", а то у меня получилось только если b2 равно А1.

Заранее еще раз очень благодарен!

Автор - ПАМ
Дата добавления - 06.12.2017 в 21:02
_Boroda_ Дата: Среда, 06.12.2017, 21:28 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Немного непонятно. Если
ячейке А1 листа основа, "принимала" любое значение из столбца В листа Определение
, то в В1 листа "Основа всегда будет плюс.
В А1 вот такую формулу подойдет?
Код
=ИНДЕКС(Определение!B2:ИНДЕКС(Определение!B:B;СЧЁТЗ(Определение!B:B)+1-СЧЁТЗ(Определение!B1));СЛУЧМЕЖДУ(1;СЧЁТЗ(Определение!B:B)+1-СЧЁТЗ(Определение!B1)-1))

Случайное значение из диапазона В2:ВДоКонца листа "Определение"

Или Вы чего-то другого, более странного, хотите?
К сообщению приложен файл: _11.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНемного непонятно. Если
ячейке А1 листа основа, "принимала" любое значение из столбца В листа Определение
, то в В1 листа "Основа всегда будет плюс.
В А1 вот такую формулу подойдет?
Код
=ИНДЕКС(Определение!B2:ИНДЕКС(Определение!B:B;СЧЁТЗ(Определение!B:B)+1-СЧЁТЗ(Определение!B1));СЛУЧМЕЖДУ(1;СЧЁТЗ(Определение!B:B)+1-СЧЁТЗ(Определение!B1)-1))

Случайное значение из диапазона В2:ВДоКонца листа "Определение"

Или Вы чего-то другого, более странного, хотите?

Автор - _Boroda_
Дата добавления - 06.12.2017 в 21:28
ПАМ Дата: Среда, 06.12.2017, 22:19 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 124
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Александр, спасибо. Но мне нужно немного другое попробую объяснить еще раз: в ячейку A1 листа основа человек вводит любое слово или цифру. Если это значение совпадет с любым из списка B2:B6 на листе Определение, то в ячейке B1 листа основа должен получится просто плюс. Формулу желательно поместить в ячейку B1 листа основа
 
Ответить
Сообщение_Boroda_, Александр, спасибо. Но мне нужно немного другое попробую объяснить еще раз: в ячейку A1 листа основа человек вводит любое слово или цифру. Если это значение совпадет с любым из списка B2:B6 на листе Определение, то в ячейке B1 листа основа должен получится просто плюс. Формулу желательно поместить в ячейку B1 листа основа

Автор - ПАМ
Дата добавления - 06.12.2017 в 22:19
_Boroda_ Дата: Среда, 06.12.2017, 23:21 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11852
Репутация: 4911 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А, ну тогда
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A1;Определение!B2:B99;));"-";"+")

или
Код
=--ЕОШ(ПОИСКПОЗ(A1;Определение!B2:B99;))

и формат ячейки
-;;+

СЧЁТЕСЛИ, СУММПРОИЗВ, БД-функции (если шапки будут), ПРОСМОТР, ВПР, ...


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА, ну тогда
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A1;Определение!B2:B99;));"-";"+")

или
Код
=--ЕОШ(ПОИСКПОЗ(A1;Определение!B2:B99;))

и формат ячейки
-;;+

СЧЁТЕСЛИ, СУММПРОИЗВ, БД-функции (если шапки будут), ПРОСМОТР, ВПР, ...

Автор - _Boroda_
Дата добавления - 06.12.2017 в 23:21
ПАМ Дата: Четверг, 07.12.2017, 08:17 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 124
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Александр, низкий поклон. Спасибо от всей души, то что мне нужно. :) Проблема решена


Сообщение отредактировал ПАМ - Четверг, 07.12.2017, 08:18
 
Ответить
Сообщение_Boroda_, Александр, низкий поклон. Спасибо от всей души, то что мне нужно. :) Проблема решена

Автор - ПАМ
Дата добавления - 07.12.2017 в 08:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор любого значения из выбранного списка (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!