Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать средний рейтинг из кол-ва заполненных ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать средний рейтинг из кол-ва заполненных ячеек (Формулы/Formulas)
Как посчитать средний рейтинг из кол-ва заполненных ячеек
adilkarim Дата: Понедельник, 18.12.2017, 07:46 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 57
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Здравствуйте форумчане.

подскажите формулу, как посчитать средний рейтинг из количества заполненных ячеек.
Допустим
31 день = 31 ячеек
заполнены только 15 дней, со значениями от 1 до 10
нужно чтобы в первой ячейке показывался среднее число/рейтинг

файлик вложил

спасибо
К сообщению приложен файл: 2696159.xlsx(10.5 Kb)
 
Ответить
СообщениеЗдравствуйте форумчане.

подскажите формулу, как посчитать средний рейтинг из количества заполненных ячеек.
Допустим
31 день = 31 ячеек
заполнены только 15 дней, со значениями от 1 до 10
нужно чтобы в первой ячейке показывался среднее число/рейтинг

файлик вложил

спасибо

Автор - adilkarim
Дата добавления - 18.12.2017 в 07:46
китин Дата: Понедельник, 18.12.2017, 07:50 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4774
Репутация: 763 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Доброго и вам. как то так
Код
=СРЗНАЧЕСЛИ($C$4:$AG$4;"<>""")

да и так правильно вроде бы считает
Код
=СРЗНАЧ(C4:AG4)
К сообщению приложен файл: _2696159.xlsx(10.9 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 18.12.2017, 07:53
 
Ответить
СообщениеДоброго и вам. как то так
Код
=СРЗНАЧЕСЛИ($C$4:$AG$4;"<>""")

да и так правильно вроде бы считает
Код
=СРЗНАЧ(C4:AG4)

Автор - китин
Дата добавления - 18.12.2017 в 07:50
adilkarim Дата: Понедельник, 18.12.2017, 07:56 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 57
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
китин, Спасибо большое
Выручили
 
Ответить
Сообщениекитин, Спасибо большое
Выручили

Автор - adilkarim
Дата добавления - 18.12.2017 в 07:56
Che79 Дата: Понедельник, 18.12.2017, 09:00 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1254
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
adilkarim, а , может, так?
Код
=СУММ(C4:AG4)/СЧЁТ(C4:AG4)
Код
=СРЗНАЧЕСЛИ(C4:AG4;"<>")
См. зелёные ячейки. Результаты совпадают со второй формулой Игоря (китин), но отличаются с первой.
К сообщению приложен файл: _2696159_.xlsx(10.9 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщениеadilkarim, а , может, так?
Код
=СУММ(C4:AG4)/СЧЁТ(C4:AG4)
Код
=СРЗНАЧЕСЛИ(C4:AG4;"<>")
См. зелёные ячейки. Результаты совпадают со второй формулой Игоря (китин), но отличаются с первой.

Автор - Che79
Дата добавления - 18.12.2017 в 09:00
китин Дата: Понедельник, 18.12.2017, 09:42 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4774
Репутация: 763 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]
Леша в тех формулах просто диапазон другой и не захватывает те цифры, что ты добавил. я их для проверки самого себя писал


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]
Леша в тех формулах просто диапазон другой и не захватывает те цифры, что ты добавил. я их для проверки самого себя писал

Автор - китин
Дата добавления - 18.12.2017 в 09:42
Che79 Дата: Понедельник, 18.12.2017, 10:35 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1254
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Еще одну формулу до кучи :D
Код
СРЗНАЧ(C4:ИНДЕКС(C4:AG4;ПОИСКПОЗ(9^9;C4:AG4)))

[offtop] китин, Игорь, всё, я понял, на диапазоны сначала внимания не обратил.


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 18.12.2017, 10:36
 
Ответить
СообщениеЕще одну формулу до кучи :D
Код
СРЗНАЧ(C4:ИНДЕКС(C4:AG4;ПОИСКПОЗ(9^9;C4:AG4)))

[offtop] китин, Игорь, всё, я понял, на диапазоны сначала внимания не обратил.

Автор - Che79
Дата добавления - 18.12.2017 в 10:35
китин Дата: Понедельник, 18.12.2017, 10:55 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4774
Репутация: 763 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну и еще до кучи( с извращениями)
Код
=СУММ($C$4:ИНДЕКС($C$4:$AG$4;;ПРОСМОТР(9^99;$C$4:$AG$4;$C$3:$AG$3)))/СЧЁТ($C$4:$AG$4)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 18.12.2017, 10:55
 
Ответить
Сообщениену и еще до кучи( с извращениями)
Код
=СУММ($C$4:ИНДЕКС($C$4:$AG$4;;ПРОСМОТР(9^99;$C$4:$AG$4;$C$3:$AG$3)))/СЧЁТ($C$4:$AG$4)

Автор - китин
Дата добавления - 18.12.2017 в 10:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать средний рейтинг из кол-ва заполненных ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!