Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как найти в столбце "слово" и поставить его в начале? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как найти в столбце "слово" и поставить его в начале? (Формулы/Formulas)
Как найти в столбце "слово" и поставить его в начале?
AdwordsDirect Дата: Понедельник, 18.12.2017, 16:52 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 125
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, уважаемые.
Не могу найти решение задачи, хэлп.
Есть столбец с 1000 ячейками. Нужно найти в каждой ячейке слово "покупайте" и поставить его в начало той ячейке, где он найден.
Такое вообще возможно сделать в экселе?
Как вариант решения, подумал, может просто тогда найти слово "покупайте" и вырезать его в соседний столбец (тоже не знаю как сделать) на той же строке и затем просто СЦЕПИТЬ.
Спасибо.
К сообщению приложен файл: _Microsoft_Exce.xlsx(24.7 Kb)


Сообщение отредактировал AdwordsDirect - Понедельник, 18.12.2017, 16:53
 
Ответить
СообщениеЗдравствуйте, уважаемые.
Не могу найти решение задачи, хэлп.
Есть столбец с 1000 ячейками. Нужно найти в каждой ячейке слово "покупайте" и поставить его в начало той ячейке, где он найден.
Такое вообще возможно сделать в экселе?
Как вариант решения, подумал, может просто тогда найти слово "покупайте" и вырезать его в соседний столбец (тоже не знаю как сделать) на той же строке и затем просто СЦЕПИТЬ.
Спасибо.

Автор - AdwordsDirect
Дата добавления - 18.12.2017 в 16:52
vikttur Дата: Понедельник, 18.12.2017, 16:56 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2687
Репутация: 477 ±
Замечаний: 0% ±

Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("покупайте";A1));СЖПРОБЕЛЫ("покупайте "&ПОДСТАВИТЬ(A1;"покупайте";));A1)
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("покупайте";A1));СЖПРОБЕЛЫ("покупайте "&ПОДСТАВИТЬ(A1;"покупайте";));A1)

Автор - vikttur
Дата добавления - 18.12.2017 в 16:56
Serge_007 Дата: Понедельник, 18.12.2017, 16:58 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13185
Репутация: ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("покупайте";A1));"покупайте "&A1;A1)


[p.s.]А если "Покупайте" уже есть в начале текста ячейки?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("покупайте";A1));"покупайте "&A1;A1)


[p.s.]А если "Покупайте" уже есть в начале текста ячейки?

Автор - Serge_007
Дата добавления - 18.12.2017 в 16:58
AdwordsDirect Дата: Понедельник, 18.12.2017, 17:03 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 125
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо огромное! Работает, проверил только vikttur. Поставил + к репутации. Спасибо!


Сообщение отредактировал AdwordsDirect - Понедельник, 18.12.2017, 17:04
 
Ответить
СообщениеСпасибо огромное! Работает, проверил только vikttur. Поставил + к репутации. Спасибо!

Автор - AdwordsDirect
Дата добавления - 18.12.2017 в 17:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как найти в столбце "слово" и поставить его в начале? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!