Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Генерация случайных чисел до определенной суммы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Генерация случайных чисел до определенной суммы (Формулы/Formulas)
Генерация случайных чисел до определенной суммы
German Дата: Среда, 20.12.2017, 11:12 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день!
Сумма в ячейке B2 сгенерированная из диапазона месяца по условию в файле. Ячейка В2 должна совпадать с ячейкой В1. Число в ячейке В1 будет меняться вручную от данных полученных за месяц.
Спасибо.
К сообщению приложен файл: 5017648.xlsx(17.0 Kb)
 
Ответить
СообщениеДобрый день!
Сумма в ячейке B2 сгенерированная из диапазона месяца по условию в файле. Ячейка В2 должна совпадать с ячейкой В1. Число в ячейке В1 будет меняться вручную от данных полученных за месяц.
Спасибо.

Автор - German
Дата добавления - 20.12.2017 в 11:12
Светлый Дата: Среда, 20.12.2017, 11:38 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 657
Репутация: 179 ±
Замечаний: 0% ±

Excel 2010
В последнюю ячейку B36 записать формулу:
Код
=B1-СУММ(B6:B35)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеВ последнюю ячейку B36 записать формулу:
Код
=B1-СУММ(B6:B35)

Автор - Светлый
Дата добавления - 20.12.2017 в 11:38
German Дата: Среда, 20.12.2017, 11:56 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день!
Месяц будет меняться 30,31,28 дней. Сгенерированная сумма чисел не будет равна ячейки В1.
Спасибо за оперативность, но не подходит это решение.
 
Ответить
СообщениеДобрый день!
Месяц будет меняться 30,31,28 дней. Сгенерированная сумма чисел не будет равна ячейки В1.
Спасибо за оперативность, но не подходит это решение.

Автор - German
Дата добавления - 20.12.2017 в 11:56
pabchek Дата: Среда, 20.12.2017, 14:02 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 899
Репутация: 215 ±
Замечаний: 0% ±

Excel 2007
Пробуйте
Код
=ЕСЛИ(A7="";$B$1-СУММ(B$5:B5);СЛУЧМЕЖДУ($D$1-100;$D$1+100))*ЕЧИСЛО(A6)
К сообщению приложен файл: 8389369.xlsx(15.9 Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеПробуйте
Код
=ЕСЛИ(A7="";$B$1-СУММ(B$5:B5);СЛУЧМЕЖДУ($D$1-100;$D$1+100))*ЕЧИСЛО(A6)

Автор - pabchek
Дата добавления - 20.12.2017 в 14:02
Светлый Дата: Среда, 20.12.2017, 14:03 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 657
Репутация: 179 ±
Замечаний: 0% ±

Excel 2010
Тогда весь столбец B заменить на:
Код
=ЕСЛИ($A6="";"";ЕСЛИ($A7="";$B$1-СУММ(B$5:B5);СЛУЧМЕЖДУ($F$1;$F$2)))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеТогда весь столбец B заменить на:
Код
=ЕСЛИ($A6="";"";ЕСЛИ($A7="";$B$1-СУММ(B$5:B5);СЛУЧМЕЖДУ($F$1;$F$2)))

Автор - Светлый
Дата добавления - 20.12.2017 в 14:03
German Дата: Среда, 20.12.2017, 14:21 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Спасибо большое. Все ОК.
 
Ответить
СообщениеСпасибо большое. Все ОК.

Автор - German
Дата добавления - 20.12.2017 в 14:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Генерация случайных чисел до определенной суммы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!