Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных из другой таблицы при соблюдении условий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из другой таблицы при соблюдении условий (Формулы/Formulas)
Перенос данных из другой таблицы при соблюдении условий
Pohmel Дата: Среда, 20.12.2017, 11:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день,

второй день пытаюсь создать таблицу данных в новом файле используя данные из другого файла.
Использую формулы ВПР и ЕСЛИ. Данные переносятся если значение истина, а если ложь то пишется 0, ложь или любое значение которое я выберу.
Как сделать чтобы ячейки в столбце заполнялись только при соблюдении истины, а действие при ложь не выполнялось? Т.е. ячейки заполнялись данными подряд без пустот и 0.
Образце в приложении.
Спасибо!
К сообщению приложен файл: 9423457.xlsx(10.0 Kb)
 
Ответить
СообщениеДобрый день,

второй день пытаюсь создать таблицу данных в новом файле используя данные из другого файла.
Использую формулы ВПР и ЕСЛИ. Данные переносятся если значение истина, а если ложь то пишется 0, ложь или любое значение которое я выберу.
Как сделать чтобы ячейки в столбце заполнялись только при соблюдении истины, а действие при ложь не выполнялось? Т.е. ячейки заполнялись данными подряд без пустот и 0.
Образце в приложении.
Спасибо!

Автор - Pohmel
Дата добавления - 20.12.2017 в 11:17
китин Дата: Среда, 20.12.2017, 11:28 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5051
Репутация: 806 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
как то так
Код
=ИНДЕКС(Лист1!$B$2:$B$10;АГРЕГАТ(15;6;(СТРОКА(Лист1!$C$2:$C$10)-1)/(Лист1!$C$2:$C$10="нет");СТРОКА(A1)))
К сообщению приложен файл: _9423457.xlsx(10.0 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениекак то так
Код
=ИНДЕКС(Лист1!$B$2:$B$10;АГРЕГАТ(15;6;(СТРОКА(Лист1!$C$2:$C$10)-1)/(Лист1!$C$2:$C$10="нет");СТРОКА(A1)))

Автор - китин
Дата добавления - 20.12.2017 в 11:28
Che79 Дата: Среда, 20.12.2017, 11:28 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Pohmel, здравствуйте. Так хотите?
Код
{=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ(C:C<>"";СТРОКА($A$1:$A$20));СТРОКА(A1)));"")}
- формула массива. См. желтые ячейки

UPD
Если нужно сразу с Листа 1, то
Код
{=ЕСЛИОШИБКА(ИНДЕКС(Лист1!B:B;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!C:C="нет";СТРОКА(Лист1!B:B));СТРОКА(Лист1!A1)));"")}
- формула массива. См. синие ячейки
Файл перевложил
К сообщению приложен файл: 9423457_1.xlsx(10.5 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Среда, 20.12.2017, 11:37
 
Ответить
СообщениеPohmel, здравствуйте. Так хотите?
Код
{=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ(C:C<>"";СТРОКА($A$1:$A$20));СТРОКА(A1)));"")}
- формула массива. См. желтые ячейки

UPD
Если нужно сразу с Листа 1, то
Код
{=ЕСЛИОШИБКА(ИНДЕКС(Лист1!B:B;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!C:C="нет";СТРОКА(Лист1!B:B));СТРОКА(Лист1!A1)));"")}
- формула массива. См. синие ячейки
Файл перевложил

Автор - Che79
Дата добавления - 20.12.2017 в 11:28
Pohmel Дата: Среда, 20.12.2017, 15:23 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо ребят! По формуле массива получилось.
 
Ответить
СообщениеСпасибо ребят! По формуле массива получилось.

Автор - Pohmel
Дата добавления - 20.12.2017 в 15:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из другой таблицы при соблюдении условий (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!