Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Количество определенных месяцев - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество определенных месяцев (Формулы/Formulas)
Количество определенных месяцев
julia5555 Дата: Понедельник, 25.12.2017, 08:12 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте! Как посчитать в периоде дат отдельно полные месяца все кроме (март-июнь-сентябрь-декабрь), а март-июнь-сентябрь-декабрь отдельно?
Допустим период
15.01.2017-25.06.2017
полных месяцев (февраль-март-апрель-май)=4 использую формулу
Код
=РАЗНДАТ(КОНМЕСЯЦА(МАКС(F$2;B10)-1;0);МАКС(КОНМЕСЯЦА(B10-1;0);КОНМЕСЯЦА(C10+1;-1)+1);"m")

вот эти 4 месяца мне надо разбить на 2 столбца:
1-без месяцев (март-июнь-сентябрь-декабрь) в примере это 3
2-это только количество (март-июнь-сентябрь-декабрь) в примере это 1

Заранее спасибо
 
Ответить
СообщениеЗдравствуйте! Как посчитать в периоде дат отдельно полные месяца все кроме (март-июнь-сентябрь-декабрь), а март-июнь-сентябрь-декабрь отдельно?
Допустим период
15.01.2017-25.06.2017
полных месяцев (февраль-март-апрель-май)=4 использую формулу
Код
=РАЗНДАТ(КОНМЕСЯЦА(МАКС(F$2;B10)-1;0);МАКС(КОНМЕСЯЦА(B10-1;0);КОНМЕСЯЦА(C10+1;-1)+1);"m")

вот эти 4 месяца мне надо разбить на 2 столбца:
1-без месяцев (март-июнь-сентябрь-декабрь) в примере это 3
2-это только количество (март-июнь-сентябрь-декабрь) в примере это 1

Заранее спасибо

Автор - julia5555
Дата добавления - 25.12.2017 в 08:12
Pelena Дата: Понедельник, 25.12.2017, 09:12 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13312
Репутация: 2932 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Файл с примером приложите


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Файл с примером приложите

Автор - Pelena
Дата добавления - 25.12.2017 в 09:12
julia5555 Дата: Понедельник, 25.12.2017, 09:50 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena,
К сообщению приложен файл: v1.2-.xls(40.5 Kb)
 
Ответить
СообщениеPelena,

Автор - julia5555
Дата добавления - 25.12.2017 в 09:50
Pelena Дата: Понедельник, 25.12.2017, 10:33 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13312
Репутация: 2932 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Что-то такое монструозное получилось.
Формула рассчитана на период не более 5 лет
Код
=СУММПРОИЗВ((ДАТАМЕС(КОНМЕСЯЦА(B21-1;0)+1;СТРОКА($1:$60))<КОНМЕСЯЦА(C21+1;-1)-1)*(МЕСЯЦ(ДАТАМЕС(КОНМЕСЯЦА(B21-1;0)+1;СТРОКА($1:$60)))={3;6;9;12}))
К сообщению приложен файл: 7564651.xls(41.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЧто-то такое монструозное получилось.
Формула рассчитана на период не более 5 лет
Код
=СУММПРОИЗВ((ДАТАМЕС(КОНМЕСЯЦА(B21-1;0)+1;СТРОКА($1:$60))<КОНМЕСЯЦА(C21+1;-1)-1)*(МЕСЯЦ(ДАТАМЕС(КОНМЕСЯЦА(B21-1;0)+1;СТРОКА($1:$60)))={3;6;9;12}))

Автор - Pelena
Дата добавления - 25.12.2017 в 10:33
julia5555 Дата: Понедельник, 25.12.2017, 11:15 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, если ставлю дату 02.02.2017-31.12.2017 показывает 3 месяца, где 03-06-09-12, а по факту их 4
 
Ответить
СообщениеPelena, если ставлю дату 02.02.2017-31.12.2017 показывает 3 месяца, где 03-06-09-12, а по факту их 4

Автор - julia5555
Дата добавления - 25.12.2017 в 11:15
Pelena Дата: Понедельник, 25.12.2017, 14:02 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13312
Репутация: 2932 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
так проверьте
К сообщению приложен файл: 2256037.xls(41.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениетак проверьте

Автор - Pelena
Дата добавления - 25.12.2017 в 14:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество определенных месяцев (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!