Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Неверная сортировка ячеек в столбце. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Неверная сортировка ячеек в столбце. (Формулы/Formulas)
Неверная сортировка ячеек в столбце.
Кайли Дата: Понедельник, 25.12.2017, 21:53 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Имеется 1 столбик с 10- мя строками. В каждой ячейки есть цифра и буква, 1 А, 2 Б, 3 В, 4 Г, 5 Д, 6 Е, 7 Ж, 8 З, 9 И, 10 К. При сортировке от А до Я и от Я до А, ячейка с значением *10 К* неверно сортируется. Я сортирую эти ячейки с добавлением 0 с запятой, Пример 0,1 А, 0,2 Б ...1,0 К, Только в этом случае выходит верно. Имеется ли другой способ с неизменными значениями ?
К сообщению приложен файл: 9491485.xlsx(10.2 Kb)


Привет Мир!

Сообщение отредактировал Кайли - Понедельник, 25.12.2017, 22:26
 
Ответить
СообщениеИмеется 1 столбик с 10- мя строками. В каждой ячейки есть цифра и буква, 1 А, 2 Б, 3 В, 4 Г, 5 Д, 6 Е, 7 Ж, 8 З, 9 И, 10 К. При сортировке от А до Я и от Я до А, ячейка с значением *10 К* неверно сортируется. Я сортирую эти ячейки с добавлением 0 с запятой, Пример 0,1 А, 0,2 Б ...1,0 К, Только в этом случае выходит верно. Имеется ли другой способ с неизменными значениями ?

Автор - Кайли
Дата добавления - 25.12.2017 в 21:53
vikttur Дата: Понедельник, 25.12.2017, 22:07 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2687
Репутация: 477 ±
Замечаний: 0% ±

Сортируется верно. Как текст. Если нужна сортировка по числам, выведите их в отдельный столбец.:
Код
=--ЛЕВБ(A1;ДЛСТР(A1)-1)

Eсли числа нужны и в тексте, оставьте их там, но сортировать по новому столбцу


Сообщение отредактировал vikttur - Понедельник, 25.12.2017, 22:09
 
Ответить
СообщениеСортируется верно. Как текст. Если нужна сортировка по числам, выведите их в отдельный столбец.:
Код
=--ЛЕВБ(A1;ДЛСТР(A1)-1)

Eсли числа нужны и в тексте, оставьте их там, но сортировать по новому столбцу

Автор - vikttur
Дата добавления - 25.12.2017 в 22:07
Кайли Дата: Понедельник, 25.12.2017, 22:25 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 112
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
vikttur, сортировка нужна по цифрам, а что да как не совсем понял. Ввёл код и всё равно 10 ка не на своём месте
К сообщению приложен файл: 10-.xlsx(10.6 Kb)


Привет Мир!
 
Ответить
Сообщениеvikttur, сортировка нужна по цифрам, а что да как не совсем понял. Ввёл код и всё равно 10 ка не на своём месте

Автор - Кайли
Дата добавления - 25.12.2017 в 22:25
vikttur Дата: Понедельник, 25.12.2017, 22:28 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2687
Репутация: 477 ±
Замечаний: 0% ±

Так по второму столбцу сортируйте
[offtop]И не нужно писать в личку.[/offtop]
 
Ответить
СообщениеТак по второму столбцу сортируйте
[offtop]И не нужно писать в личку.[/offtop]

Автор - vikttur
Дата добавления - 25.12.2017 в 22:28
Che79 Дата: Понедельник, 25.12.2017, 23:05 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1254
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Кайли, такой вариант. Если у Вас всегда в таком формате, как в примере и без пробелов в конце, то можно , как вариант, так
- Выделяете столбец А - Данные - Текст по столбцам - С разделителем Пробел - Готово
- В С1 формулу
Код
=ЕСЛИОШИБКА(СТРОКА(A1)&" "&ВПР(СТРОКА(A1);A:B;2;);"")
К сообщению приложен файл: 9491485_1.xlsx(11.5 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеКайли, такой вариант. Если у Вас всегда в таком формате, как в примере и без пробелов в конце, то можно , как вариант, так
- Выделяете столбец А - Данные - Текст по столбцам - С разделителем Пробел - Готово
- В С1 формулу
Код
=ЕСЛИОШИБКА(СТРОКА(A1)&" "&ВПР(СТРОКА(A1);A:B;2;);"")

Автор - Che79
Дата добавления - 25.12.2017 в 23:05
pabchek Дата: Вторник, 26.12.2017, 11:51 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 839
Репутация: 188 ±
Замечаний: 0% ±

Excel 2007
всё равно 10 ка не на своём месте

как вариант, можно попробовать вывести цифры как текст
Код
=ТЕКСТ(ЛЕВБ(A1;ПОИСК("? ";A1));"00")

или даже проще
Код
=ТЕКСТ(ЛЕВБ(A1;2);"00")


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Вторник, 26.12.2017, 12:19
 
Ответить
Сообщение
всё равно 10 ка не на своём месте

как вариант, можно попробовать вывести цифры как текст
Код
=ТЕКСТ(ЛЕВБ(A1;ПОИСК("? ";A1));"00")

или даже проще
Код
=ТЕКСТ(ЛЕВБ(A1;2);"00")

Автор - pabchek
Дата добавления - 26.12.2017 в 11:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Неверная сортировка ячеек в столбце. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!