Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Cравнение результатов с эталонными с учетом погрешности - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Cравнение результатов с эталонными с учетом погрешности (Формулы/Formulas)
Cравнение результатов с эталонными с учетом погрешности
VingNar Дата: Воскресенье, 07.01.2018, 22:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток.
Нужно создать табличку для сравнения полученных результатов с эталонными с учетом погрешности, которая зависит от молярной доли.
1)Если значение В1 находится в диапазоне от 0.001 до 0,1 включительно, то погрешность составляет +/- 100%.
если св 0,1 до 1,0 вкл, то 50 % (и т.д. в моих каракулях есть все условия).
2)После того, как определена погрешность составляется диапазон чисел от В1 - погрешность до В1 + погрешность.
3)Второй оператор "если": Если эталонное значение А1 попадает в интервал В1+/- погрешность, то "ОК", если он меньше этого интервала, то "-", ну и если больше "+".
P.S. Помогите пожалуйста разобраться, я что-то намудрил и у меня "если" работает, но не так.
К сообщению приложен файл: ___.xls(50Kb)
 
Ответить
СообщениеДоброго времени суток.
Нужно создать табличку для сравнения полученных результатов с эталонными с учетом погрешности, которая зависит от молярной доли.
1)Если значение В1 находится в диапазоне от 0.001 до 0,1 включительно, то погрешность составляет +/- 100%.
если св 0,1 до 1,0 вкл, то 50 % (и т.д. в моих каракулях есть все условия).
2)После того, как определена погрешность составляется диапазон чисел от В1 - погрешность до В1 + погрешность.
3)Второй оператор "если": Если эталонное значение А1 попадает в интервал В1+/- погрешность, то "ОК", если он меньше этого интервала, то "-", ну и если больше "+".
P.S. Помогите пожалуйста разобраться, я что-то намудрил и у меня "если" работает, но не так.

Автор - VingNar
Дата добавления - 07.01.2018 в 22:03
Karataev Дата: Воскресенье, 07.01.2018, 22:52 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1012
Репутация: 363 ±
Замечаний: 0% ±

Excel
Для "H3":
Код
=ЕСЛИ(C3>50;C3*0,03;ЕСЛИ(C3>10;C3*0,05;ЕСЛИ(C3>1;C3*0,1;ЕСЛИ(C3>0,1;C3*0,5;ЕСЛИ(C3>=0,001;C3*1;"H.H")))))

Для "I3". Я здесь добавил "<=" (меньше или равно, но Вы сами решите, как правильно).
Код
=ЕСЛИ(H3="H.H";"";ЕСЛИ(ABS(B3-C3)<=ABS(H3);"OK";"-"))




Сообщение отредактировал Karataev - Воскресенье, 07.01.2018, 23:02
 
Ответить
СообщениеДля "H3":
Код
=ЕСЛИ(C3>50;C3*0,03;ЕСЛИ(C3>10;C3*0,05;ЕСЛИ(C3>1;C3*0,1;ЕСЛИ(C3>0,1;C3*0,5;ЕСЛИ(C3>=0,001;C3*1;"H.H")))))

Для "I3". Я здесь добавил "<=" (меньше или равно, но Вы сами решите, как правильно).
Код
=ЕСЛИ(H3="H.H";"";ЕСЛИ(ABS(B3-C3)<=ABS(H3);"OK";"-"))

Автор - Karataev
Дата добавления - 07.01.2018 в 22:52
bmv98rus Дата: Понедельник, 08.01.2018, 00:42 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 915
Репутация: 156 ±
Замечаний: 0% ±

Excel 2013/2016
Для H3 вариант без если
Код
=IFERROR(C3*LOOKUP(C3-10^-14;{0;0,00099999999999;0,1;1;10;50};{"";1;0,5;0,1;0,05;0,03});"H.H")

если знать точность, то 0,00099999999999 можно урезать до возможного.
 
Ответить
СообщениеДля H3 вариант без если
Код
=IFERROR(C3*LOOKUP(C3-10^-14;{0;0,00099999999999;0,1;1;10;50};{"";1;0,5;0,1;0,05;0,03});"H.H")

если знать точность, то 0,00099999999999 можно урезать до возможного.

Автор - bmv98rus
Дата добавления - 08.01.2018 в 00:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Cравнение результатов с эталонными с учетом погрешности (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!