Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Исключение года при суммировании - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Исключение года при суммировании (Формулы/Formulas)
Исключение года при суммировании
reklats Дата: Среда, 10.01.2018, 17:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Есть проблема просуммировать строки которые соответствуют 17 году. Есть еще пустые, они тоже как бы 17, но дату в них проставить нет никакой возможности, поэтому условие "<01.01.2018" не помогает решить проблему. Есть ли какая-то возможность записать в условие - "исключить больше или равно" и добавит к этому дату?
К сообщению приложен файл: 8506482.xlsx(8.1 Kb)
 
Ответить
СообщениеЕсть проблема просуммировать строки которые соответствуют 17 году. Есть еще пустые, они тоже как бы 17, но дату в них проставить нет никакой возможности, поэтому условие "<01.01.2018" не помогает решить проблему. Есть ли какая-то возможность записать в условие - "исключить больше или равно" и добавит к этому дату?

Автор - reklats
Дата добавления - 10.01.2018 в 17:37
Che79 Дата: Среда, 10.01.2018, 17:46 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1254
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
reklats, так хотите?
Для B9
Код
=СУММПРОИЗВ(--(ТЕКСТ(B2:B8;"ГГ")="17"))
или для C9
Код
=СУММПРОИЗВ(C2:C8*(ГОД(B2:B8)=--"2017"))


UPD
Или так?
Код
=СУММПРОИЗВ(--(ТЕКСТ(B2:B5;"ГГ")={"17";"00"}))
Код
=СУММПРОИЗВ(C2:C5*(ГОД(B2:B5)=--{"2017";"1900"}))

См. файл_2
К сообщению приложен файл: 8506482_1.xlsx(8.4 Kb) · 8506482_2.xlsx(8.4 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Среда, 10.01.2018, 17:52
 
Ответить
Сообщениеreklats, так хотите?
Для B9
Код
=СУММПРОИЗВ(--(ТЕКСТ(B2:B8;"ГГ")="17"))
или для C9
Код
=СУММПРОИЗВ(C2:C8*(ГОД(B2:B8)=--"2017"))


UPD
Или так?
Код
=СУММПРОИЗВ(--(ТЕКСТ(B2:B5;"ГГ")={"17";"00"}))
Код
=СУММПРОИЗВ(C2:C5*(ГОД(B2:B5)=--{"2017";"1900"}))

См. файл_2

Автор - Che79
Дата добавления - 10.01.2018 в 17:46
reklats Дата: Среда, 10.01.2018, 17:58 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Che79, не совсем. При суммировании должно получится 3. С пустой датой ничего не сделать. Я до этого использовал СУММЕСЛИМН с кучей условий, и считал по единицам. Но вот как понадобилось убрать все что после конца 17, не могу придумать...

UPD: Пока писал, не увидел дополнение. Да, спасибо. Второй вариант похоже что надо. Сейчас разберусь в нем specool


Сообщение отредактировал reklats - Среда, 10.01.2018, 18:02
 
Ответить
СообщениеChe79, не совсем. При суммировании должно получится 3. С пустой датой ничего не сделать. Я до этого использовал СУММЕСЛИМН с кучей условий, и считал по единицам. Но вот как понадобилось убрать все что после конца 17, не могу придумать...

UPD: Пока писал, не увидел дополнение. Да, спасибо. Второй вариант похоже что надо. Сейчас разберусь в нем specool

Автор - reklats
Дата добавления - 10.01.2018 в 17:58
Che79 Дата: Среда, 10.01.2018, 17:59 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1254
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
При суммировании должно получится 3
посмотрите Файл_2 в сообщении #2


Делай нормально и будет нормально!
 
Ответить
Сообщение
При суммировании должно получится 3
посмотрите Файл_2 в сообщении #2

Автор - Che79
Дата добавления - 10.01.2018 в 17:59
Che79 Дата: Среда, 10.01.2018, 18:09 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1254
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Что-то я как-то извращённо подошёл к решению вопроса :D
Для Вашего случая можно просто
Код
=СУММПРОИЗВ(C2:C5*(ГОД(B2:B5)<>2018))


Делай нормально и будет нормально!
 
Ответить
СообщениеЧто-то я как-то извращённо подошёл к решению вопроса :D
Для Вашего случая можно просто
Код
=СУММПРОИЗВ(C2:C5*(ГОД(B2:B5)<>2018))

Автор - Che79
Дата добавления - 10.01.2018 в 18:09
reklats Дата: Среда, 10.01.2018, 18:19 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Che79, а куда условия с диапазонами в нее пихать? Просто это для меня новая функция, а сейчас читаю ее синтаксис, так она вся про перемножения... %) Через СУММЕСЛИМН и СЧЕТЕСЛИМН никак не решить?
Цитата
=СУММПРОИЗВ(C2:C5*(ГОД(B2:B5)<>2018))


Сообщение отредактировал reklats - Среда, 10.01.2018, 18:26
 
Ответить
СообщениеChe79, а куда условия с диапазонами в нее пихать? Просто это для меня новая функция, а сейчас читаю ее синтаксис, так она вся про перемножения... %) Через СУММЕСЛИМН и СЧЕТЕСЛИМН никак не решить?
Цитата
=СУММПРОИЗВ(C2:C5*(ГОД(B2:B5)<>2018))

Автор - reklats
Дата добавления - 10.01.2018 в 18:19
Che79 Дата: Среда, 10.01.2018, 18:26 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1254
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
куда условия с диапазонами в нее пихать?
reklats, если честно, не совсем понял вопрос. Если Вы по аналогии с СУММЕСЛИМН() и она Вам более привычна, то, может, так подойдет?
Код
=СУММЕСЛИМН(C2:C5;B2:B5;"<"&КОНМЕСЯЦА("01.01.2018";0))

Не, так неверно будет!!

UPD
А вот так верно
Код
=СУММЕСЛИ(B2:B5;"<"&43101;C2:C5)+СУММЕСЛИ(B2:B5;"";C2:C5)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Среда, 10.01.2018, 19:03
 
Ответить
Сообщение
куда условия с диапазонами в нее пихать?
reklats, если честно, не совсем понял вопрос. Если Вы по аналогии с СУММЕСЛИМН() и она Вам более привычна, то, может, так подойдет?
Код
=СУММЕСЛИМН(C2:C5;B2:B5;"<"&КОНМЕСЯЦА("01.01.2018";0))

Не, так неверно будет!!

UPD
А вот так верно
Код
=СУММЕСЛИ(B2:B5;"<"&43101;C2:C5)+СУММЕСЛИ(B2:B5;"";C2:C5)

Автор - Che79
Дата добавления - 10.01.2018 в 18:26
reklats Дата: Среда, 10.01.2018, 18:41 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Che79, странно, почему так мало вариантов сравнения: <>, =, >=, <=, а именно - нельзя их комбинировать нормально между собой :(


Сообщение отредактировал reklats - Среда, 10.01.2018, 18:42
 
Ответить
СообщениеChe79, странно, почему так мало вариантов сравнения: <>, =, >=, <=, а именно - нельзя их комбинировать нормально между собой :(

Автор - reklats
Дата добавления - 10.01.2018 в 18:41
Pelena Дата: Среда, 10.01.2018, 19:38 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12603
Репутация: 2774 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Ещё вариант
Код
=СУММ(СУММЕСЛИ(B2:B5;{"<01.01.2018";""};C2:C5))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант
Код
=СУММ(СУММЕСЛИ(B2:B5;{"<01.01.2018";""};C2:C5))

Автор - Pelena
Дата добавления - 10.01.2018 в 19:38
Nic70y Дата: Среда, 10.01.2018, 20:37 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4560
Репутация: 985 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММ(ИНДЕКС((B2:B5<--"1/1/18")*C2:C5;;))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММ(ИНДЕКС((B2:B5<--"1/1/18")*C2:C5;;))

Автор - Nic70y
Дата добавления - 10.01.2018 в 20:37
reklats Дата: Четверг, 11.01.2018, 11:11 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Che79, спасибо, ваша последняя формула оказалось наиболее понятной для меня hands
А вот с другими надо будет разобраться для общего развития, так как даже после прочтения описания данных формул, их принцип действие крайне не очевиден пока для меня.
 
Ответить
СообщениеChe79, спасибо, ваша последняя формула оказалось наиболее понятной для меня hands
А вот с другими надо будет разобраться для общего развития, так как даже после прочтения описания данных формул, их принцип действие крайне не очевиден пока для меня.

Автор - reklats
Дата добавления - 11.01.2018 в 11:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Исключение года при суммировании (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!