Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Счет итога значений в скобках и перед ними. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет итога значений в скобках и перед ними. (Формулы/Formulas)
Счет итога значений в скобках и перед ними.
vich21 Дата: Пятница, 12.01.2018, 14:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день! Подскажите. Думаю о том как облегчить задачу подсчета итога. Необходимо сложить значения в скобках и значения перед ними. В примере файла, итог НРВ считался вручную. Нужно подсчитать для всех Я , Н, НРВ.
К сообщению приложен файл: 8349783.xlsx(11.6 Kb)


Сообщение отредактировал vich21 - Пятница, 12.01.2018, 14:18
 
Ответить
СообщениеДобрый день! Подскажите. Думаю о том как облегчить задачу подсчета итога. Необходимо сложить значения в скобках и значения перед ними. В примере файла, итог НРВ считался вручную. Нужно подсчитать для всех Я , Н, НРВ.

Автор - vich21
Дата добавления - 12.01.2018 в 14:15
vikttur Дата: Пятница, 12.01.2018, 14:16 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2705
Репутация: 477 ±
Замечаний: 0% ±

Где считать?


Сообщение отредактировал vikttur - Пятница, 12.01.2018, 14:17
 
Ответить
СообщениеГде считать?

Автор - vikttur
Дата добавления - 12.01.2018 в 14:16
vich21 Дата: Пятница, 12.01.2018, 14:20 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
vikttur, да где угодно интересует сама возможность подсчета значений: Например : 5(40), 5 (40) а в итоге нужно получить 10(80)


Сообщение отредактировал vich21 - Пятница, 12.01.2018, 14:21
 
Ответить
Сообщениеvikttur, да где угодно интересует сама возможность подсчета значений: Например : 5(40), 5 (40) а в итоге нужно получить 10(80)

Автор - vich21
Дата добавления - 12.01.2018 в 14:20
vikttur Дата: Пятница, 12.01.2018, 14:24 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2705
Репутация: 477 ±
Замечаний: 0% ±

Вы неправильно посчитали итог в примере:
Код
=СУММ(--ЕСЛИ($A$3:$B$13=A15;ЛЕВБ($F$3:$G$13;ПОИСК("(";$F$3:$G$13)-1)))&"("&СУММ(-ЕСЛИ($A$3:$B$13=A15;ПСТР($F$3:$G$13;ПОИСК("(";$F$3:$G$13);5)))&")"

Формула вводится как формула массива, при помощи трех клавиш Ctrl+Shift+Enter


Сообщение отредактировал vikttur - Пятница, 12.01.2018, 14:30
 
Ответить
СообщениеВы неправильно посчитали итог в примере:
Код
=СУММ(--ЕСЛИ($A$3:$B$13=A15;ЛЕВБ($F$3:$G$13;ПОИСК("(";$F$3:$G$13)-1)))&"("&СУММ(-ЕСЛИ($A$3:$B$13=A15;ПСТР($F$3:$G$13;ПОИСК("(";$F$3:$G$13);5)))&")"

Формула вводится как формула массива, при помощи трех клавиш Ctrl+Shift+Enter

Автор - vikttur
Дата добавления - 12.01.2018 в 14:24
китин Дата: Пятница, 12.01.2018, 14:30 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4924
Репутация: 786 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
формула массива
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВБ($F$3:$G$18;ПОИСК("(";$F$3:$G$18)-1);0))&"("&СУММ(--ЕСЛИОШИБКА(ПОДСТАВИТЬ(ПОДСТАВИТЬ($F$3:$G$18;ЛЕВБ($F$3:$G$18;ПОИСК("(";$F$3:$G$18));"");")";"");0))&")"
К сообщению приложен файл: _8349783.xlsx(12.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеформула массива
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВБ($F$3:$G$18;ПОИСК("(";$F$3:$G$18)-1);0))&"("&СУММ(--ЕСЛИОШИБКА(ПОДСТАВИТЬ(ПОДСТАВИТЬ($F$3:$G$18;ЛЕВБ($F$3:$G$18;ПОИСК("(";$F$3:$G$18));"");")";"");0))&")"

Автор - китин
Дата добавления - 12.01.2018 в 14:30
sboy Дата: Пятница, 12.01.2018, 14:33 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1909
Репутация: 558 ±
Замечаний: 0% ±

Excel 2010
еще вариант массивная (с примером совпало)
Код
=СУММПРОИЗВ(($A$3:$B$13=A15)*ЕСЛИОШИБКА(ПСТР($F$3:$G$13;1;ПОИСК("(";$F$3:$G$13)-1);))&"("&
СУММПРОИЗВ(($A$3:$B$13=A15)*ЕСЛИОШИБКА(ПСТР($F$3:$G$13;ПОИСК("(";$F$3:$G$13)+1;ДЛСТР($F$3:$G$13)-ПОИСК("(";$F$3:$G$13)-1);))&")"
К сообщению приложен файл: 3499513.xlsx(12.7 Kb)


Сообщение отредактировал sboy - Пятница, 12.01.2018, 14:34
 
Ответить
Сообщениееще вариант массивная (с примером совпало)
Код
=СУММПРОИЗВ(($A$3:$B$13=A15)*ЕСЛИОШИБКА(ПСТР($F$3:$G$13;1;ПОИСК("(";$F$3:$G$13)-1);))&"("&
СУММПРОИЗВ(($A$3:$B$13=A15)*ЕСЛИОШИБКА(ПСТР($F$3:$G$13;ПОИСК("(";$F$3:$G$13)+1;ДЛСТР($F$3:$G$13)-ПОИСК("(";$F$3:$G$13)-1);))&")"

Автор - sboy
Дата добавления - 12.01.2018 в 14:33
vich21 Дата: Пятница, 12.01.2018, 14:36 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
vikttur, о спасибо большое!!!
 
Ответить
Сообщениеvikttur, о спасибо большое!!!

Автор - vich21
Дата добавления - 12.01.2018 в 14:36
vich21 Дата: Пятница, 12.01.2018, 14:39 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем спасибо большое !
 
Ответить
СообщениеВсем спасибо большое !

Автор - vich21
Дата добавления - 12.01.2018 в 14:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет итога значений в скобках и перед ними. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!