Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма столбца с игнорированием #ЗНАЧ! - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма столбца с игнорированием #ЗНАЧ! (Формулы/Formulas)
Сумма столбца с игнорированием #ЗНАЧ!
vlavaden Дата: Пятница, 12.01.2018, 21:22 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 69
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, подскажите, как найти сумму значений столбца таблицы, если в ячейках встречаются "#ЗНАЧ!"?
К сообщению приложен файл: prim0.xlsx(9.9 Kb)
 
Ответить
СообщениеЗдравствуйте, подскажите, как найти сумму значений столбца таблицы, если в ячейках встречаются "#ЗНАЧ!"?

Автор - vlavaden
Дата добавления - 12.01.2018 в 21:22
vikttur Дата: Пятница, 12.01.2018, 21:48 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2716
Репутация: 477 ±
Замечаний: 0% ±

Код
=СУММ(ЕСЛИ(ЕЧИСЛО(Таблица1[Столбец1]);Таблица1[Столбец1]))

Вводится как формула массива, тремя клавишами.

А правильно: не допускать (избегать) появления ошибок
 
Ответить
Сообщение
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(Таблица1[Столбец1]);Таблица1[Столбец1]))

Вводится как формула массива, тремя клавишами.

А правильно: не допускать (избегать) появления ошибок

Автор - vikttur
Дата добавления - 12.01.2018 в 21:48
vlavaden Дата: Пятница, 12.01.2018, 21:55 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 69
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо, работает.
 
Ответить
СообщениеСпасибо, работает.

Автор - vlavaden
Дата добавления - 12.01.2018 в 21:55
bmv98rus Дата: Пятница, 12.01.2018, 21:59 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1417
Репутация: 238 ±
Замечаний: 0% ±

Excel 2013/2016
обычная для 2010 и новее
Код
=AGGREGATE(9;6;Таблица1[Столбец1])
 
Ответить
Сообщениеобычная для 2010 и новее
Код
=AGGREGATE(9;6;Таблица1[Столбец1])

Автор - bmv98rus
Дата добавления - 12.01.2018 в 21:59
Che79 Дата: Пятница, 12.01.2018, 22:34 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
До кучи
Массивная
Код
=СУММ(ЕСЛИ(ЕОШИБКА(Таблица1[Столбец1]);;Таблица1[Столбец1]))


Делай нормально и будет нормально!
 
Ответить
СообщениеДо кучи
Массивная
Код
=СУММ(ЕСЛИ(ЕОШИБКА(Таблица1[Столбец1]);;Таблица1[Столбец1]))

Автор - Che79
Дата добавления - 12.01.2018 в 22:34
sv2014 Дата: Суббота, 13.01.2018, 00:32 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 223
Репутация: 60 ±
Замечаний: 0% ±

Excel 2013
vlavaden, еще формула массива

Код
=СУММ(ЕСЛИОШИБКА(Таблица1[Столбец1];))


Сообщение отредактировал sv2014 - Суббота, 13.01.2018, 01:11
 
Ответить
Сообщениеvlavaden, еще формула массива

Код
=СУММ(ЕСЛИОШИБКА(Таблица1[Столбец1];))

Автор - sv2014
Дата добавления - 13.01.2018 в 00:32
Nic70y Дата: Суббота, 13.01.2018, 06:59 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4949
Репутация: 1070 ±
Замечаний: 0% ±

Excel 2013
немассивная, древняя
Код
=СУММЕСЛИ(Таблица1[Столбец1];">0")
или
Код
=СУММЕСЛИ(Таблица1[Столбец1];">0")+СУММЕСЛИ(Таблица1[Столбец1];"<0")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениенемассивная, древняя
Код
=СУММЕСЛИ(Таблица1[Столбец1];">0")
или
Код
=СУММЕСЛИ(Таблица1[Столбец1];">0")+СУММЕСЛИ(Таблица1[Столбец1];"<0")

Автор - Nic70y
Дата добавления - 13.01.2018 в 06:59
sv2014 Дата: Суббота, 13.01.2018, 15:04 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 223
Репутация: 60 ±
Замечаний: 0% ±

Excel 2013
vlavaden, вариант функции(UDF) в A9

[vba]
Код
Function vvv&(r As Range)
    Dim z, i&: z = r.Value
   For i = 1 To UBound(z)
    If IsNumeric(z(i, 1)) Then vvv = vvv + z(i, 1)
   Next
End Function
[/vba]
К сообщению приложен файл: example_13_01_2.xls(37.5 Kb)
 
Ответить
Сообщениеvlavaden, вариант функции(UDF) в A9

[vba]
Код
Function vvv&(r As Range)
    Dim z, i&: z = r.Value
   For i = 1 To UBound(z)
    If IsNumeric(z(i, 1)) Then vvv = vvv + z(i, 1)
   Next
End Function
[/vba]

Автор - sv2014
Дата добавления - 13.01.2018 в 15:04
vikttur Дата: Суббота, 13.01.2018, 17:50 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2716
Репутация: 477 ±
Замечаний: 0% ±

Nic70y, спасибо за напоминание о СУММЕСЛИ. Забыл начисто, что ошибки игнорирует.
 
Ответить
СообщениеNic70y, спасибо за напоминание о СУММЕСЛИ. Забыл начисто, что ошибки игнорирует.

Автор - vikttur
Дата добавления - 13.01.2018 в 17:50
jakim Дата: Суббота, 13.01.2018, 18:46 | Сообщение № 10
Группа: Друзья
Ранг: Ветеран
Сообщений: 859
Репутация: 227 ±
Замечаний: 0% ±

Excel 2010
Ещё одна формула

Код
=SUMIF(A2:A20;"<1E100")
 
Ответить
Сообщение
Ещё одна формула

Код
=SUMIF(A2:A20;"<1E100")

Автор - jakim
Дата добавления - 13.01.2018 в 18:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма столбца с игнорированием #ЗНАЧ! (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!