Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выпадающий список с записью в формулу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выпадающий список с записью в формулу (Формулы/Formulas)
Выпадающий список с записью в формулу
Soprano Дата: Вторник, 06.02.2018, 14:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!

Необходимо решить следующую задачу.

Есть ячейка с итоговой суммой, и есть ячейка с выпадающим списком, в котором на выбор есть 3 варианта:
- вариант 1 должен добавить к сумме 400 руб;
- вариант 2 добавит к сумме 600 руб;
- вариант 3 оставит сумму без изменений.

Выпадающий список сделать не проблема, а вот через какую формулу все записать - не знаю. Через ЕСЛИ не получилось.

Мне сделали вариант с галочкой, он работает, но выпадающий список был бы удобней.

Как это все можно записать? Кто подскажет?
 
Ответить
СообщениеДобрый день!

Необходимо решить следующую задачу.

Есть ячейка с итоговой суммой, и есть ячейка с выпадающим списком, в котором на выбор есть 3 варианта:
- вариант 1 должен добавить к сумме 400 руб;
- вариант 2 добавит к сумме 600 руб;
- вариант 3 оставит сумму без изменений.

Выпадающий список сделать не проблема, а вот через какую формулу все записать - не знаю. Через ЕСЛИ не получилось.

Мне сделали вариант с галочкой, он работает, но выпадающий список был бы удобней.

Как это все можно записать? Кто подскажет?

Автор - Soprano
Дата добавления - 06.02.2018 в 14:49
китин Дата: Вторник, 06.02.2018, 14:51 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4597
Репутация: 733 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Как это все можно записать

неправильный вопрос: надо начала спросить КУДА????? %)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Как это все можно записать

неправильный вопрос: надо начала спросить КУДА????? %)

Автор - китин
Дата добавления - 06.02.2018 в 14:51
Soprano Дата: Вторник, 06.02.2018, 14:52 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Это очень правильный вопрос. Если знаете на него ответ, подскажите, пожалуйста.
 
Ответить
СообщениеЭто очень правильный вопрос. Если знаете на него ответ, подскажите, пожалуйста.

Автор - Soprano
Дата добавления - 06.02.2018 в 14:52
Manyasha Дата: Вторник, 06.02.2018, 14:54 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 2092
Репутация: 862 ±
Замечаний: 0% ±

Excel 2010, 2016
Soprano, покажите пример в файле. Если результат нужен в той же итоговой ячейке, а не в соседней, то нужен макрос.


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеSoprano, покажите пример в файле. Если результат нужен в той же итоговой ячейке, а не в соседней, то нужен макрос.

Автор - Manyasha
Дата добавления - 06.02.2018 в 14:54
Soprano Дата: Вторник, 06.02.2018, 15:01 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Пожалуйста, пример.

Только я формулу не записывал
К сообщению приложен файл: 6905288.xlsx(10Kb)
 
Ответить
СообщениеПожалуйста, пример.

Только я формулу не записывал

Автор - Soprano
Дата добавления - 06.02.2018 в 15:01
Che79 Дата: Вторник, 06.02.2018, 15:06 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1057
Репутация: 200 ±
Замечаний: 0% ±

Excel 2007, 2013
Soprano, один из множества вариантов
Код
=ЕСЛИОШИБКА(СУММ(B1:B3)+ВПР(B4;{"доставка по городу";400:"доставка за МКАД";600:"самовывоз";0};2;);"выберите способ доставки!")


Делай нормально и будет нормально!
 
Ответить
СообщениеSoprano, один из множества вариантов
Код
=ЕСЛИОШИБКА(СУММ(B1:B3)+ВПР(B4;{"доставка по городу";400:"доставка за МКАД";600:"самовывоз";0};2;);"выберите способ доставки!")

Автор - Che79
Дата добавления - 06.02.2018 в 15:06
sboy Дата: Вторник, 06.02.2018, 15:18 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1400
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010
один из множества вариантов

Код
=СУММ(B1:B3)+600*ЕЧИСЛО(ПОИСК("МКАД";B4))+400*ЕЧИСЛО(ПОИСК("город";B4))
К сообщению приложен файл: 6232452.xlsx(10Kb)
 
Ответить
Сообщение
один из множества вариантов

Код
=СУММ(B1:B3)+600*ЕЧИСЛО(ПОИСК("МКАД";B4))+400*ЕЧИСЛО(ПОИСК("город";B4))

Автор - sboy
Дата добавления - 06.02.2018 в 15:18
Soprano Дата: Вторник, 06.02.2018, 15:19 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Che79, beer respect
Спасибо!
 
Ответить
СообщениеChe79, beer respect
Спасибо!

Автор - Soprano
Дата добавления - 06.02.2018 в 15:19
Soprano Дата: Вторник, 06.02.2018, 15:21 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, hands
Теперь я знаю не один вариант! specool
 
Ответить
Сообщениеsboy, hands
Теперь я знаю не один вариант! specool

Автор - Soprano
Дата добавления - 06.02.2018 в 15:21
китин Дата: Вторник, 06.02.2018, 15:23 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4597
Репутация: 733 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Через ЕСЛИ не получилось.

а почему? все получилось,
Код
=ЕСЛИ($B$4="доставка по городу";СУММ(B1:B3)+400;ЕСЛИ($B$4="доставка за МКАД";СУММ(B1:B3)+600;СУММ(B1:B3)))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Через ЕСЛИ не получилось.

а почему? все получилось,
Код
=ЕСЛИ($B$4="доставка по городу";СУММ(B1:B3)+400;ЕСЛИ($B$4="доставка за МКАД";СУММ(B1:B3)+600;СУММ(B1:B3)))

Автор - китин
Дата добавления - 06.02.2018 в 15:23
sboy Дата: Вторник, 06.02.2018, 15:26 | Сообщение № 11
Группа: Проверенные
Ранг: Старожил
Сообщений: 1400
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010
ну и еще один до кучи)
Код
=СУММ(B1:B3)+ПРОСМОТР(ПРАВБ(B4;1);{"д";"з";"у"};{600;0;400})
 
Ответить
Сообщениену и еще один до кучи)
Код
=СУММ(B1:B3)+ПРОСМОТР(ПРАВБ(B4;1);{"д";"з";"у"};{600;0;400})

Автор - sboy
Дата добавления - 06.02.2018 в 15:26
Soprano Дата: Вторник, 06.02.2018, 15:27 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, действительно, все получилось! B)
Чем я вчера пол вечера занимался? :o
Спасибо!
 
Ответить
Сообщениекитин, действительно, все получилось! B)
Чем я вчера пол вечера занимался? :o
Спасибо!

Автор - Soprano
Дата добавления - 06.02.2018 в 15:27
Soprano Дата: Вторник, 06.02.2018, 15:30 | Сообщение № 13
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем спасибо!
Вопрос закрыт, подставляю в свой файл! yes
 
Ответить
СообщениеВсем спасибо!
Вопрос закрыт, подставляю в свой файл! yes

Автор - Soprano
Дата добавления - 06.02.2018 в 15:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выпадающий список с записью в формулу (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!