Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/При суммировании колонки выдает результат вида -1,08557Е. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » При суммировании колонки выдает результат вида -1,08557Е. (Формулы/Formulas)
При суммировании колонки выдает результат вида -1,08557Е.
vivichivi Дата: Пятница, 09.02.2018, 10:25 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, уважаемые форумчане. Я новенький и прошу не кидаться шапками. В Exel я тоже не являюсь гуру, однако перед тем, как составить пост, я проштудировал различные форумы, но так и не нашел решение своей проблемы. Если кратко, то колонка из файла должна суммироваться в 0. Это обязательное условие для дальнейшей работы с огромным массивом данных. Я чистил форматы и заменял знаки, но не приложу ума, почему сумма получается такой неадекватной. В качестве проверки правильности ввода чисел можно удалить любое число, и тогда сумма будет отличаться ровно на это число. Спасите пожалуйста утопающего, сам не справляюсь.

Заранее благодарен.
К сообщению приложен файл: _2016-2017.xlsm(47.1 Kb)


Сообщение отредактировал vivichivi - Пятница, 09.02.2018, 10:26
 
Ответить
СообщениеДобрый день, уважаемые форумчане. Я новенький и прошу не кидаться шапками. В Exel я тоже не являюсь гуру, однако перед тем, как составить пост, я проштудировал различные форумы, но так и не нашел решение своей проблемы. Если кратко, то колонка из файла должна суммироваться в 0. Это обязательное условие для дальнейшей работы с огромным массивом данных. Я чистил форматы и заменял знаки, но не приложу ума, почему сумма получается такой неадекватной. В качестве проверки правильности ввода чисел можно удалить любое число, и тогда сумма будет отличаться ровно на это число. Спасите пожалуйста утопающего, сам не справляюсь.

Заранее благодарен.

Автор - vivichivi
Дата добавления - 09.02.2018 в 10:25
sboy Дата: Пятница, 09.02.2018, 10:56 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Используйте округление
Код
=ОКРУГЛ(СУММ(A2:A4471);)
К сообщению приложен файл: 3242297.xlsm(47.6 Kb)
 
Ответить
СообщениеДобрый день.
Используйте округление
Код
=ОКРУГЛ(СУММ(A2:A4471);)

Автор - sboy
Дата добавления - 09.02.2018 в 10:56
Russel Дата: Пятница, 09.02.2018, 10:58 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1293
Репутация: 293 ±
Замечаний: 0% ±

Excel 2010
Формат ячеек / Числовой / ОК

Все работает нормально.
К сообщению приложен файл: 3479898.xlsm(47.2 Kb)


QIWI 9173973973
 
Ответить
СообщениеФормат ячеек / Числовой / ОК

Все работает нормально.

Автор - Russel
Дата добавления - 09.02.2018 в 10:58
vivichivi Дата: Пятница, 09.02.2018, 11:09 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, Большое спасибо, это помогло! Можете пожалуйста подсказать, по какой причине возникает подобного рода ошибка? И можно ли как-то прописать округление в настройках?
Russel, В Вашем файле работает, а вот у меня почему-то нет. Возможно и у Вас поставлен какой-то пункт в настройках по поводу округления чисел?
 
Ответить
Сообщениеsboy, Большое спасибо, это помогло! Можете пожалуйста подсказать, по какой причине возникает подобного рода ошибка? И можно ли как-то прописать округление в настройках?
Russel, В Вашем файле работает, а вот у меня почему-то нет. Возможно и у Вас поставлен какой-то пункт в настройках по поводу округления чисел?

Автор - vivichivi
Дата добавления - 09.02.2018 в 11:09
vivichivi Дата: Пятница, 09.02.2018, 11:27 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
sboy, извиняюсь. При переводе в сводную таблицу exel снова выдает число -1,08557Е-08. Хотя теперь числа в колонке реально выдают 0. Без правильного отражения в сводной таблице мне не сделать следующий шаг.
К сообщению приложен файл: 1047522.xlsm(65.9 Kb)


Сообщение отредактировал vivichivi - Пятница, 09.02.2018, 11:30
 
Ответить
Сообщениеsboy, извиняюсь. При переводе в сводную таблицу exel снова выдает число -1,08557Е-08. Хотя теперь числа в колонке реально выдают 0. Без правильного отражения в сводной таблице мне не сделать следующий шаг.

Автор - vivichivi
Дата добавления - 09.02.2018 в 11:27
Russel Дата: Пятница, 09.02.2018, 11:35 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1293
Репутация: 293 ±
Замечаний: 0% ±

Excel 2010
При переводе в сводную таблицу exel снова выдает число -1,08557Е-08. Хотя теперь числа в колонке реально выдают 0.

И в сводной при изменении формата на числовой все отображается корректно


QIWI 9173973973
 
Ответить
Сообщение
При переводе в сводную таблицу exel снова выдает число -1,08557Е-08. Хотя теперь числа в колонке реально выдают 0.

И в сводной при изменении формата на числовой все отображается корректно

Автор - Russel
Дата добавления - 09.02.2018 в 11:35
vivichivi Дата: Пятница, 09.02.2018, 11:38 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Russel, спасибо, буду настраивать рабочий компьютер. Почему-то форматы постоянно слетают. На домашнем такого за 3 года не наблюдалось.
 
Ответить
СообщениеRussel, спасибо, буду настраивать рабочий компьютер. Почему-то форматы постоянно слетают. На домашнем такого за 3 года не наблюдалось.

Автор - vivichivi
Дата добавления - 09.02.2018 в 11:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » При суммировании колонки выдает результат вида -1,08557Е. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!