Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сделать быстрый поиск фраз в стобце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать быстрый поиск фраз в стобце (Формулы/Formulas)
Как сделать быстрый поиск фраз в стобце
akkord87 Дата: Понедельник, 12.02.2018, 10:58 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!

Имеется столбец с фразами среди которых будем искать и столбец с фразами, которые нужно найти.

Пример:



По результатам должны получить:



Т.е. в первом столбце подсвечиваются фразы, которые находятся во втором столбце.

Как реализовать этот пример? Возможно в excel есть стандартный функционал, для такого поиска, но своими силами найти не получилось:)

Буду благодарен за помощь)
К сообщению приложен файл: 7726792.xlsx(9.1 Kb)


Сообщение отредактировал akkord87 - Понедельник, 12.02.2018, 11:51
 
Ответить
СообщениеЗдравствуйте!

Имеется столбец с фразами среди которых будем искать и столбец с фразами, которые нужно найти.

Пример:



По результатам должны получить:



Т.е. в первом столбце подсвечиваются фразы, которые находятся во втором столбце.

Как реализовать этот пример? Возможно в excel есть стандартный функционал, для такого поиска, но своими силами найти не получилось:)

Буду благодарен за помощь)

Автор - akkord87
Дата добавления - 12.02.2018 в 10:58
TimSha Дата: Понедельник, 12.02.2018, 11:00 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 606
Репутация: 92 ±
Замечаний: 0% ±

Excel 2013 Pro +
Возможно в excel есть стандартный функционал

Расширенный фильтр.


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
Сообщение
Возможно в excel есть стандартный функционал

Расширенный фильтр.

Автор - TimSha
Дата добавления - 12.02.2018 в 11:00
sboy Дата: Понедельник, 12.02.2018, 11:06 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
но своими силами найти не получилось

Вкладка Главная - Условное форматирование.
Подробнее с файлом-примером
 
Ответить
Сообщение
но своими силами найти не получилось

Вкладка Главная - Условное форматирование.
Подробнее с файлом-примером

Автор - sboy
Дата добавления - 12.02.2018 в 11:06
akkord87 Дата: Понедельник, 12.02.2018, 11:51 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
sboy, Извините, подготовил файл, а в тему вложить забыл:)

Скидываю отдельно)
К сообщению приложен файл: 5243259.xlsx(9.1 Kb)
 
Ответить
Сообщениеsboy, Извините, подготовил файл, а в тему вложить забыл:)

Скидываю отдельно)

Автор - akkord87
Дата добавления - 12.02.2018 в 11:51
akkord87 Дата: Понедельник, 12.02.2018, 11:59 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Еще один нюанс, хотелось бы сделать это все одним разом, так как на реальном примере первый столбец содержит десятки тысяч срок, а во втором столбце будут сотни фраз, которые нужно найти)
 
Ответить
СообщениеЕще один нюанс, хотелось бы сделать это все одним разом, так как на реальном примере первый столбец содержит десятки тысяч срок, а во втором столбце будут сотни фраз, которые нужно найти)

Автор - akkord87
Дата добавления - 12.02.2018 в 11:59
sboy Дата: Понедельник, 12.02.2018, 12:02 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2190
Репутация: 624 ±
Замечаний: 0% ±

Excel 2010
Формула в УФ
Код
=ПОИСКПОЗ($A3;$B$3:$B$6;0)
К сообщению приложен файл: 9348758.xlsx(9.3 Kb)
 
Ответить
СообщениеФормула в УФ
Код
=ПОИСКПОЗ($A3;$B$3:$B$6;0)

Автор - sboy
Дата добавления - 12.02.2018 в 12:02
TimSha Дата: Понедельник, 12.02.2018, 12:03 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 606
Репутация: 92 ±
Замечаний: 0% ±

Excel 2013 Pro +
хотелось бы сделать это все одним разом

Так за чем дело стало? Или сами не рискуете - ждете готовенькое?.. ;)
К сообщению приложен файл: 9481117.png(14.2 Kb)


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
Сообщение
хотелось бы сделать это все одним разом

Так за чем дело стало? Или сами не рискуете - ждете готовенькое?.. ;)

Автор - TimSha
Дата добавления - 12.02.2018 в 12:03
Che79 Дата: Понедельник, 12.02.2018, 12:20 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Еще вариант. В УФ
Код
=СЧЁТЕСЛИ($B$3:$B$100;$A3)
К сообщению приложен файл: 5243259_1.xlsx(9.0 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЕще вариант. В УФ
Код
=СЧЁТЕСЛИ($B$3:$B$100;$A3)

Автор - Che79
Дата добавления - 12.02.2018 в 12:20
akkord87 Дата: Понедельник, 12.02.2018, 15:12 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
TimSha, воспользовался Вашим способом, спасибо) Просто не очень силен в Excle, пока изучаю)
 
Ответить
СообщениеTimSha, воспользовался Вашим способом, спасибо) Просто не очень силен в Excle, пока изучаю)

Автор - akkord87
Дата добавления - 12.02.2018 в 15:12
akkord87 Дата: Понедельник, 12.02.2018, 15:38 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Che79, спасибо) Разобрался, как и этот способ реализовать))
 
Ответить
СообщениеChe79, спасибо) Разобрался, как и этот способ реализовать))

Автор - akkord87
Дата добавления - 12.02.2018 в 15:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать быстрый поиск фраз в стобце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!