Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение строк по значению другой строки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение строк по значению другой строки (Формулы/Formulas)
Заполнение строк по значению другой строки
Zheka0236 Дата: Понедельник, 12.02.2018, 23:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет. Есть столбец 1 (штрихкод товара), столбец 2 (количество(нулевое), столбец 3 (штрихкод товара), столбец 4 (количество). Нужно заполнить столбец 2 значением столбца 4, условием есть штрихкод. Может, неверно задал вопрос, прилагаю файл, там яснее). Буду очень благодарен за решение. Если вопрос есть на форуме, дайте ссылку.
К сообщению приложен файл: Inventory.xls(25.5 Kb)
 
Ответить
СообщениеВсем привет. Есть столбец 1 (штрихкод товара), столбец 2 (количество(нулевое), столбец 3 (штрихкод товара), столбец 4 (количество). Нужно заполнить столбец 2 значением столбца 4, условием есть штрихкод. Может, неверно задал вопрос, прилагаю файл, там яснее). Буду очень благодарен за решение. Если вопрос есть на форуме, дайте ссылку.

Автор - Zheka0236
Дата добавления - 12.02.2018 в 23:36
gling Дата: Понедельник, 12.02.2018, 23:41 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1814
Репутация: 439 ±
Замечаний: 0% ±

2010
Здравствуйте. Почитайте про функцию ВПР(). Вставьте формулу в В3 и тяните вниз
Код
=ВПР(A3;$D$3:$E$8;2;0)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. Почитайте про функцию ВПР(). Вставьте формулу в В3 и тяните вниз
Код
=ВПР(A3;$D$3:$E$8;2;0)

Автор - gling
Дата добавления - 12.02.2018 в 23:41
buka77 Дата: Вторник, 13.02.2018, 00:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 6 ±
Замечаний: 0% ±

Excel 2010
Чтобы избежать появления ячеек #Н/Д, стоит добавить
Код
=ЕСЛИОШИБКА(ВПР(A3;$D$3:$E$8;2;0);"")
 
Ответить
СообщениеЧтобы избежать появления ячеек #Н/Д, стоит добавить
Код
=ЕСЛИОШИБКА(ВПР(A3;$D$3:$E$8;2;0);"")

Автор - buka77
Дата добавления - 13.02.2018 в 00:31
Zheka0236 Дата: Вторник, 13.02.2018, 00:39 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Огромное спасибо!!!!
 
Ответить
СообщениеОгромное спасибо!!!!

Автор - Zheka0236
Дата добавления - 13.02.2018 в 00:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение строк по значению другой строки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!