Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула ЕСЛИ использование с интервалами времени - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула ЕСЛИ использование с интервалами времени (Формулы/Formulas)
Формула ЕСЛИ использование с интервалами времени
Bill_Murray Дата: Суббота, 24.02.2018, 08:32 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго дня!
Помогите пожалуйста с функцией "ЕСЛИ".
Как её использовать со временем. Например если в ячейке время от 13:00:00 до 23:00:00, то она принимает значение "ДОП" всё остальное время "СР"?
 
Ответить
СообщениеДоброго дня!
Помогите пожалуйста с функцией "ЕСЛИ".
Как её использовать со временем. Например если в ячейке время от 13:00:00 до 23:00:00, то она принимает значение "ДОП" всё остальное время "СР"?

Автор - Bill_Murray
Дата добавления - 24.02.2018 в 08:32
Pelena Дата: Суббота, 24.02.2018, 08:45 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13017
Репутация: 2874 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИ(И(A1>=--"13:00:00";A1<=--"23:00:00");"ДОП";"СР")

или
Код
=ЕСЛИ(И(A1>=ЗНАЧЕН("13:00:00");A1<=ЗНАЧЕН("23:00:00"));"ДОП";"СР")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИ(И(A1>=--"13:00:00";A1<=--"23:00:00");"ДОП";"СР")

или
Код
=ЕСЛИ(И(A1>=ЗНАЧЕН("13:00:00");A1<=ЗНАЧЕН("23:00:00"));"ДОП";"СР")

Автор - Pelena
Дата добавления - 24.02.2018 в 08:45
Karataev Дата: Суббота, 24.02.2018, 08:46 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1249
Репутация: 481 ±
Замечаний: 0% ±

Excel
Для формулы время должно находиться в "A1".
Код
=ЕСЛИ(И(A1>=--"13:00:00";A1<=--"23:00:00");"ДОП";"СР")

Эта формула делает то же самое, но быстрее, если формул много:
Код
=ЕСЛИ(ЕСЛИ(A1>=--"13:00:00";A1<=--"23:00:00");"ДОП";"СР")


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288


Сообщение отредактировал Karataev - Суббота, 24.02.2018, 08:50
 
Ответить
СообщениеДля формулы время должно находиться в "A1".
Код
=ЕСЛИ(И(A1>=--"13:00:00";A1<=--"23:00:00");"ДОП";"СР")

Эта формула делает то же самое, но быстрее, если формул много:
Код
=ЕСЛИ(ЕСЛИ(A1>=--"13:00:00";A1<=--"23:00:00");"ДОП";"СР")

Автор - Karataev
Дата добавления - 24.02.2018 в 08:46
Bill_Murray Дата: Суббота, 24.02.2018, 08:48 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, спасибо!
Помогло!)
 
Ответить
СообщениеPelena, спасибо!
Помогло!)

Автор - Bill_Murray
Дата добавления - 24.02.2018 в 08:48
Bill_Murray Дата: Суббота, 24.02.2018, 08:59 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
И скажите пожалуйста как сделать так если например ячейка "A1" пустая, то формула оставляет пусто вместо подсчёта?
 
Ответить
СообщениеИ скажите пожалуйста как сделать так если например ячейка "A1" пустая, то формула оставляет пусто вместо подсчёта?

Автор - Bill_Murray
Дата добавления - 24.02.2018 в 08:59
abtextime Дата: Суббота, 24.02.2018, 09:51 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 828
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
Есть же функция ЕПУСТО(), в чем проблема?
 
Ответить
СообщениеЕсть же функция ЕПУСТО(), в чем проблема?

Автор - abtextime
Дата добавления - 24.02.2018 в 09:51
Karataev Дата: Суббота, 24.02.2018, 09:54 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1249
Репутация: 481 ±
Замечаний: 0% ±

Excel
Код
=ЕСЛИ(A1="";"";ЕСЛИ(И(A1>=--"13:00:00";A1<=--"23:00:00");"ДОП";"СР"))


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
Сообщение
Код
=ЕСЛИ(A1="";"";ЕСЛИ(И(A1>=--"13:00:00";A1<=--"23:00:00");"ДОП";"СР"))

Автор - Karataev
Дата добавления - 24.02.2018 в 09:54
Bill_Murray Дата: Суббота, 24.02.2018, 10:00 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
abtextime, появлялась ошибка, что много значений!
 
Ответить
Сообщениеabtextime, появлялась ошибка, что много значений!

Автор - Bill_Murray
Дата добавления - 24.02.2018 в 10:00
Bill_Murray Дата: Суббота, 24.02.2018, 10:00 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Karataev, благодарю!
 
Ответить
СообщениеKarataev, благодарю!

Автор - Bill_Murray
Дата добавления - 24.02.2018 в 10:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула ЕСЛИ использование с интервалами времени (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!