Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычисление по разным формулам в зависимости от условия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление по разным формулам в зависимости от условия (Формулы/Formulas)
Вычисление по разным формулам в зависимости от условия
maxim-1999 Дата: Воскресенье, 25.02.2018, 16:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Помогите пожалуйста,не много раскрою суть,если ячейка А1 = 0, то сложить ячейки B1 + C2; если ячейка А1 больше 0, то сложить ячейки А1 + С2.


Сообщение отредактировал maxim-1999 - Воскресенье, 25.02.2018, 16:38
 
Ответить
СообщениеПомогите пожалуйста,не много раскрою суть,если ячейка А1 = 0, то сложить ячейки B1 + C2; если ячейка А1 больше 0, то сложить ячейки А1 + С2.

Автор - maxim-1999
Дата добавления - 25.02.2018 в 16:00
Pelena Дата: Воскресенье, 25.02.2018, 16:01 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13312
Репутация: 2931 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
maxim-1999, дайте теме более конкретное название в соответствии с Правилами форума


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеmaxim-1999, дайте теме более конкретное название в соответствии с Правилами форума

Автор - Pelena
Дата добавления - 25.02.2018 в 16:01
Che79 Дата: Воскресенье, 25.02.2018, 16:36 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
maxim-1999, вряд ли такое название модераторы примут... И вопрос, а что будет, если A1<0?


Делай нормально и будет нормально!
 
Ответить
Сообщениеmaxim-1999, вряд ли такое название модераторы примут... И вопрос, а что будет, если A1<0?

Автор - Che79
Дата добавления - 25.02.2018 в 16:36
maxim-1999 Дата: Воскресенье, 25.02.2018, 16:40 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Che79, Ну я уж не знаю как еще назвать тему. Если А1 больше 0, то нужно сложить ячейки А1 + С2. Меньше нуля не рассматриваем вариант.


Сообщение отредактировал maxim-1999 - Воскресенье, 25.02.2018, 16:42
 
Ответить
СообщениеChe79, Ну я уж не знаю как еще назвать тему. Если А1 больше 0, то нужно сложить ячейки А1 + С2. Меньше нуля не рассматриваем вариант.

Автор - maxim-1999
Дата добавления - 25.02.2018 в 16:40
Che79 Дата: Воскресенье, 25.02.2018, 17:23 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
не знаю как еще назвать тему
В качестве подсказки. В теме кратко, но ёмко описывайте суть задачи, а не предпочтительный способ её реализации. И наличие файла-примера от Вас облегчило и ускорило бы получение ответа на вопрос.


Делай нормально и будет нормально!
 
Ответить
Сообщение
не знаю как еще назвать тему
В качестве подсказки. В теме кратко, но ёмко описывайте суть задачи, а не предпочтительный способ её реализации. И наличие файла-примера от Вас облегчило и ускорило бы получение ответа на вопрос.

Автор - Che79
Дата добавления - 25.02.2018 в 17:23
Pelena Дата: Воскресенье, 25.02.2018, 19:44 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13312
Репутация: 2931 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Видимо, это учебное задание, и его суть именно в том, чтобы описать формулой данное предложение...
Тему переименовала


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВидимо, это учебное задание, и его суть именно в том, чтобы описать формулой данное предложение...
Тему переименовала

Автор - Pelena
Дата добавления - 25.02.2018 в 19:44
Che79 Дата: Воскресенье, 25.02.2018, 19:53 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Если помощь разрешена, то вот самый явный вариант. Допустим, для D1
Код
=ЕСЛИ(A1;A1+C2;B1+C2)
+в проверка данных в A1 для
Меньше нуля не рассматриваем


Upd
Код
=(A1+C2)*(A1>0)+(B1+C2)*(A1=0)
Код
=C2+ЕСЛИ(A1;A1;B1)
К сообщению приложен файл: 987-.xlsx(9.6 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Воскресенье, 25.02.2018, 19:59
 
Ответить
СообщениеЕсли помощь разрешена, то вот самый явный вариант. Допустим, для D1
Код
=ЕСЛИ(A1;A1+C2;B1+C2)
+в проверка данных в A1 для
Меньше нуля не рассматриваем


Upd
Код
=(A1+C2)*(A1>0)+(B1+C2)*(A1=0)
Код
=C2+ЕСЛИ(A1;A1;B1)

Автор - Che79
Дата добавления - 25.02.2018 в 19:53
Nic70y Дата: Воскресенье, 25.02.2018, 20:05 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4948
Репутация: 1070 ±
Замечаний: 0% ±

Excel 2013
учебное задание
тогда так
Код
=ЗНАК(A1)*A1+НЕ(A1)*B1+C2


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
учебное задание
тогда так
Код
=ЗНАК(A1)*A1+НЕ(A1)*B1+C2

Автор - Nic70y
Дата добавления - 25.02.2018 в 20:05
Che79 Дата: Воскресенье, 25.02.2018, 20:22 | Сообщение № 9
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Вычисление по разным формулам
Код
=ЕСЛИОШИБКА(ПОИСК(0;A1)*B1+C2;A1+C2)
- верно для цифр, но не всегда для чисел!


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Воскресенье, 25.02.2018, 23:16
 
Ответить
Сообщение
Вычисление по разным формулам
Код
=ЕСЛИОШИБКА(ПОИСК(0;A1)*B1+C2;A1+C2)
- верно для цифр, но не всегда для чисел!

Автор - Che79
Дата добавления - 25.02.2018 в 20:22
Nic70y Дата: Воскресенье, 25.02.2018, 20:27 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4948
Репутация: 1070 ±
Замечаний: 0% ±

Excel 2013
но не для всегда чисел!
да просто три буквы дописать :)
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(0;A1;)*B1+C2;A1+C2)
зря исправлял, вроде итак работает
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(0;A1)*B1+C2;A1+C2)
+
Код
=ВЫБОР(ЗНАК(A1)+1;B1;A1)+C2


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Воскресенье, 25.02.2018, 20:35
 
Ответить
Сообщение
но не для всегда чисел!
да просто три буквы дописать :)
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(0;A1;)*B1+C2;A1+C2)
зря исправлял, вроде итак работает
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(0;A1)*B1+C2;A1+C2)
+
Код
=ВЫБОР(ЗНАК(A1)+1;B1;A1)+C2

Автор - Nic70y
Дата добавления - 25.02.2018 в 20:27
Che79 Дата: Воскресенье, 25.02.2018, 20:53 | Сообщение № 11
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Код
=C2+ЕСЛИОШИБКА(ВПР(;A1:B1;2;);ВПР(9^9;A1:B1;1))
К сообщению приложен файл: 8306429.xlsx(9.7 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
Код
=C2+ЕСЛИОШИБКА(ВПР(;A1:B1;2;);ВПР(9^9;A1:B1;1))

Автор - Che79
Дата добавления - 25.02.2018 в 20:53
Pelena Дата: Воскресенье, 25.02.2018, 20:58 | Сообщение № 12
Группа: Админы
Ранг: Местный житель
Сообщений: 13312
Репутация: 2931 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
[offtop]Ну, понесло-ось :D
Варианты как раз для учебного задания :D :D [/offtop]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение[offtop]Ну, понесло-ось :D
Варианты как раз для учебного задания :D :D [/offtop]

Автор - Pelena
Дата добавления - 25.02.2018 в 20:58
Che79 Дата: Понедельник, 26.02.2018, 01:38 | Сообщение № 13
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
обычная, без массивного ввода
Код
=ИНДЕКС(A1:B1+C2;ЕСЛИ(A1;1;2))

формула массива (ввод Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС(A1:B1;ПОИСКПОЗ(1=1;(A1:B1<>0);));)+C2


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 26.02.2018, 01:56
 
Ответить
Сообщениеобычная, без массивного ввода
Код
=ИНДЕКС(A1:B1+C2;ЕСЛИ(A1;1;2))

формула массива (ввод Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС(A1:B1;ПОИСКПОЗ(1=1;(A1:B1<>0);));)+C2

Автор - Che79
Дата добавления - 26.02.2018 в 01:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление по разным формулам в зависимости от условия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!