Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет заполненных ячеек по критерию из другого столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет заполненных ячеек по критерию из другого столбца (Формулы/Formulas)
Подсчет заполненных ячеек по критерию из другого столбца
Bankir_DV Дата: Понедельник, 26.02.2018, 14:19 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день, помогите, пожалуйста. Есть файл. Необходимо подсчитать количество заполненных ячеек в столбце D (сумма), по критерию из Столбца А (фио). Заранее благодарен.
К сообщению приложен файл: 5810986.xlsx(23.1 Kb)
 
Ответить
СообщениеДобрый день, помогите, пожалуйста. Есть файл. Необходимо подсчитать количество заполненных ячеек в столбце D (сумма), по критерию из Столбца А (фио). Заранее благодарен.

Автор - Bankir_DV
Дата добавления - 26.02.2018 в 14:19
китин Дата: Понедельник, 26.02.2018, 14:22 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5155
Репутация: 817 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Дык сумма нужна или посчитать количество
заполненных ячеек в столбце D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДык сумма нужна или посчитать количество
заполненных ячеек в столбце D

Автор - китин
Дата добавления - 26.02.2018 в 14:22
Che79 Дата: Понедельник, 26.02.2018, 14:25 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Bankir_DV, здравствуйте. Так нужно? Формулы в желтых ячейках
Код
=СУММПРОИЗВ(($D$2:$D$504>0)*($A$2:$A$504=F2))


[offtop]Я честно считал количество заполненных по фамилиям
К сообщению приложен файл: 5810986_1.xlsx(23.7 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Понедельник, 26.02.2018, 14:26
 
Ответить
СообщениеBankir_DV, здравствуйте. Так нужно? Формулы в желтых ячейках
Код
=СУММПРОИЗВ(($D$2:$D$504>0)*($A$2:$A$504=F2))


[offtop]Я честно считал количество заполненных по фамилиям

Автор - Che79
Дата добавления - 26.02.2018 в 14:25
sboy Дата: Понедельник, 26.02.2018, 14:27 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2238
Репутация: 634 ±
Замечаний: 0% ±

Excel 2010
Ну и моя угадайка, а вдруг то что надо?)))
Код
=СЧЁТЕСЛИМН($A$2:$A$504;F2;$D$2:$D$504;">0")
К сообщению приложен файл: 0487079.xlsx(25.5 Kb)
 
Ответить
СообщениеНу и моя угадайка, а вдруг то что надо?)))
Код
=СЧЁТЕСЛИМН($A$2:$A$504;F2;$D$2:$D$504;">0")

Автор - sboy
Дата добавления - 26.02.2018 в 14:27
Sancho Дата: Понедельник, 26.02.2018, 14:32 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 240
Репутация: 13 ±
Замечаний: 0% ±

2007, 2010, 2013
sboy, [offtop]А вдруг 0 это заполненная ячейка?
 
Ответить
Сообщениеsboy, [offtop]А вдруг 0 это заполненная ячейка?

Автор - Sancho
Дата добавления - 26.02.2018 в 14:32
Che79 Дата: Понедельник, 26.02.2018, 14:32 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Нет, если кол-во заполненных, наверное, так правильнее, т.к. в некоторых фамилиях встречается 0 (ноль), т.е. формально ячейка заполнена. В общем, два варианта.
Код
=СУММПРОИЗВ(($D$2:$D$504>0)*($A$2:$A$504=F2))
Код
=СУММПРОИЗВ(($D$2:$D$504<>"")*($A$2:$A$504=F2))
К сообщению приложен файл: 0866558.xlsx(23.9 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеНет, если кол-во заполненных, наверное, так правильнее, т.к. в некоторых фамилиях встречается 0 (ноль), т.е. формально ячейка заполнена. В общем, два варианта.
Код
=СУММПРОИЗВ(($D$2:$D$504>0)*($A$2:$A$504=F2))
Код
=СУММПРОИЗВ(($D$2:$D$504<>"")*($A$2:$A$504=F2))

Автор - Che79
Дата добавления - 26.02.2018 в 14:32
sboy Дата: Понедельник, 26.02.2018, 14:41 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2238
Репутация: 634 ±
Замечаний: 0% ±

Excel 2010
[offtop] Sancho,
А вдруг

а вдруг
 
Ответить
Сообщение[offtop] Sancho,
А вдруг

а вдруг

Автор - sboy
Дата добавления - 26.02.2018 в 14:41
Bankir_DV Дата: Понедельник, 26.02.2018, 14:41 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
sboy, Ваш вариант и нужен, только нужно подсчет количества всех заполненных ячеек, в том числе и нулевых.
 
Ответить
Сообщениеsboy, Ваш вариант и нужен, только нужно подсчет количества всех заполненных ячеек, в том числе и нулевых.

Автор - Bankir_DV
Дата добавления - 26.02.2018 в 14:41
sboy Дата: Понедельник, 26.02.2018, 14:45 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2238
Репутация: 634 ±
Замечаний: 0% ±

Excel 2010
в том числе и нулевых

Sancho, Ваш "а вдруг" победил :D
Bankir_DV, тогда так
Код
=СЧЁТЕСЛИМН($A$2:$A$504;F2;$D$2:$D$504;">=0")

Добавлено
еще вариант массивной
Код
=СЧЁТ(1/(($A$2:$A$504=F2)/ЕЧИСЛО($D$2:$D$504)))
К сообщению приложен файл: 2515468.xlsx(25.7 Kb)


Сообщение отредактировал sboy - Понедельник, 26.02.2018, 14:49
 
Ответить
Сообщение
в том числе и нулевых

Sancho, Ваш "а вдруг" победил :D
Bankir_DV, тогда так
Код
=СЧЁТЕСЛИМН($A$2:$A$504;F2;$D$2:$D$504;">=0")

Добавлено
еще вариант массивной
Код
=СЧЁТ(1/(($A$2:$A$504=F2)/ЕЧИСЛО($D$2:$D$504)))

Автор - sboy
Дата добавления - 26.02.2018 в 14:45
Bankir_DV Дата: Понедельник, 26.02.2018, 17:10 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо, большое. А как подсчитать количество заполненных ячеек в столбце D, если они будут иметь текстовый формат?
 
Ответить
СообщениеСпасибо, большое. А как подсчитать количество заполненных ячеек в столбце D, если они будут иметь текстовый формат?

Автор - Bankir_DV
Дата добавления - 26.02.2018 в 17:10
sboy Дата: Понедельник, 26.02.2018, 17:25 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 2238
Репутация: 634 ±
Замечаний: 0% ±

Excel 2010
да почти также(считает любые заполненные и текст и числа), массивная
Код
=СЧЁТ(1/(($A$2:$A$504=F2)/НЕ(ЕПУСТО($D$2:$D$504))))
 
Ответить
Сообщениеда почти также(считает любые заполненные и текст и числа), массивная
Код
=СЧЁТ(1/(($A$2:$A$504=F2)/НЕ(ЕПУСТО($D$2:$D$504))))

Автор - sboy
Дата добавления - 26.02.2018 в 17:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет заполненных ячеек по критерию из другого столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!