Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Необходимо вывести список всех значений без пустых ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Необходимо вывести список всех значений без пустых ячеек (Формулы/Formulas)
Необходимо вывести список всех значений без пустых ячеек
freegas Дата: Понедельник, 26.02.2018, 14:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте великие умы!
Проблема такая: Необходимо вывести список всех значений (подряд) из столбца (A3:A113) игнорируя пустые ячейки.
К сообщению приложен файл: 180226-_.xls(26.0 Kb)
 
Ответить
Сообщение Здравствуйте великие умы!
Проблема такая: Необходимо вывести список всех значений (подряд) из столбца (A3:A113) игнорируя пустые ячейки.

Автор - freegas
Дата добавления - 26.02.2018 в 14:31
Che79 Дата: Понедельник, 26.02.2018, 14:38 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1266
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
freegas, так?
Код
=ИНДЕКС($A$3:$A$13;НАИМЕНЬШИЙ(ЕСЛИ($A$3:$A$13<>"";СТРОКА($A$3:$A$13)-2);СТРОКА(A1)))

формула массива (ввод Ctrl+Shift+Enter)


Делай нормально и будет нормально!
 
Ответить
Сообщениеfreegas, так?
Код
=ИНДЕКС($A$3:$A$13;НАИМЕНЬШИЙ(ЕСЛИ($A$3:$A$13<>"";СТРОКА($A$3:$A$13)-2);СТРОКА(A1)))

формула массива (ввод Ctrl+Shift+Enter)

Автор - Che79
Дата добавления - 26.02.2018 в 14:38
freegas Дата: Понедельник, 26.02.2018, 14:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Che79,
Спасибо помогло!!! Только немного её доработал а то ниже значений выдавал - #ЧИСЛО!

Код
=ЕСЛИОШИБКА(ИНДЕКС($A$3:$A$13;НАИМЕНЬШИЙ(ЕСЛИ($A$3:$A$13<>"";СТРОКА($A$3:$A$13)-2);СТРОКА(A1)));"")
 
Ответить
СообщениеChe79,
Спасибо помогло!!! Только немного её доработал а то ниже значений выдавал - #ЧИСЛО!

Код
=ЕСЛИОШИБКА(ИНДЕКС($A$3:$A$13;НАИМЕНЬШИЙ(ЕСЛИ($A$3:$A$13<>"";СТРОКА($A$3:$A$13)-2);СТРОКА(A1)));"")

Автор - freegas
Дата добавления - 26.02.2018 в 14:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Необходимо вывести список всех значений без пустых ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!