Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для поиска одинаковых значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для поиска одинаковых значений (Формулы/Formulas)
Формула для поиска одинаковых значений
Bill_Murray Дата: Вторник, 27.02.2018, 18:06 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Помогите пожалуйста) Как сделать формулу, чтобы она искала одинаковые значения в столбике и в соседней ячейке прописывалось "Одинак"?
Например:

323240 Одинак
331548
394214
323240 Одинак
321652
 
Ответить
СообщениеДобрый день!
Помогите пожалуйста) Как сделать формулу, чтобы она искала одинаковые значения в столбике и в соседней ячейке прописывалось "Одинак"?
Например:

323240 Одинак
331548
394214
323240 Одинак
321652

Автор - Bill_Murray
Дата добавления - 27.02.2018 в 18:06
azma Дата: Вторник, 27.02.2018, 18:17 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
Код
=ЕСЛИ(СЧЁТЕСЛИ(A:A;A1)>=2;"Одинак";"")


Сообщение отредактировал azma - Вторник, 27.02.2018, 18:58
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ(A:A;A1)>=2;"Одинак";"")

Автор - azma
Дата добавления - 27.02.2018 в 18:17
Bill_Murray Дата: Вторник, 27.02.2018, 18:19 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
azma, это было так просто!)
 
Ответить
Сообщениеazma, это было так просто!)

Автор - Bill_Murray
Дата добавления - 27.02.2018 в 18:19
Bill_Murray Дата: Вторник, 27.02.2018, 18:19 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
azma, спосебо!)))
 
Ответить
Сообщениеazma, спосебо!)))

Автор - Bill_Murray
Дата добавления - 27.02.2018 в 18:19
azma Дата: Вторник, 27.02.2018, 18:23 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
там сделал маленькую поправку на случай если повтор будет больше чем 2 раза
 
Ответить
Сообщениетам сделал маленькую поправку на случай если повтор будет больше чем 2 раза

Автор - azma
Дата добавления - 27.02.2018 в 18:23
Bill_Murray Дата: Вторник, 27.02.2018, 18:25 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
azma, святый Господи вы гений!)
 
Ответить
Сообщениеazma, святый Господи вы гений!)

Автор - Bill_Murray
Дата добавления - 27.02.2018 в 18:25
Pelena Дата: Вторник, 27.02.2018, 18:44 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 13033
Репутация: 2877 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
azma, оформите формулу тегами с помощью кнопки fx в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеazma, оформите формулу тегами с помощью кнопки fx в режиме правки поста

Автор - Pelena
Дата добавления - 27.02.2018 в 18:44
azma Дата: Вторник, 27.02.2018, 19:01 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
azma, оформите формулу тегами с помощью кнопки fx в режиме правки поста

хорошо!
 
Ответить
Сообщение
azma, оформите формулу тегами с помощью кнопки fx в режиме правки поста

хорошо!

Автор - azma
Дата добавления - 27.02.2018 в 19:01
Bill_Murray Дата: Вторник, 06.03.2018, 17:10 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго вечера!
Подскажите ещё пожалуйста, а можно изменить формулу так, чтобы, если клеточки пустые, то формула оставляла пустое поле, а не значение "Одинак"?
 
Ответить
СообщениеДоброго вечера!
Подскажите ещё пожалуйста, а можно изменить формулу так, чтобы, если клеточки пустые, то формула оставляла пустое поле, а не значение "Одинак"?

Автор - Bill_Murray
Дата добавления - 06.03.2018 в 17:10
Bill_Murray Дата: Вторник, 06.03.2018, 17:11 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добавляя дополнительные значения появляется ошибка, что много аргументов!(((
 
Ответить
СообщениеДобавляя дополнительные значения появляется ошибка, что много аргументов!(((

Автор - Bill_Murray
Дата добавления - 06.03.2018 в 17:11
Che79 Дата: Вторник, 06.03.2018, 17:18 | Сообщение № 11
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Bill_Murray, покажите вручную на файле-примере, что Вы хотите получить


Делай нормально и будет нормально!
 
Ответить
СообщениеBill_Murray, покажите вручную на файле-примере, что Вы хотите получить

Автор - Che79
Дата добавления - 06.03.2018 в 17:18
Che79 Дата: Вторник, 06.03.2018, 17:24 | Сообщение № 12
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Вдруг угадал
Код
=--(СЧЁТЕСЛИ(A:A;A1)>1)
+ ФЯ "Одинак";;


Делай нормально и будет нормально!
 
Ответить
СообщениеВдруг угадал
Код
=--(СЧЁТЕСЛИ(A:A;A1)>1)
+ ФЯ "Одинак";;

Автор - Che79
Дата добавления - 06.03.2018 в 17:24
abtextime Дата: Вторник, 06.03.2018, 17:34 | Сообщение № 13
Группа: Проверенные
Ранг: Ветеран
Сообщений: 828
Репутация: 117 ±
Замечаний: 0% ±

Excel 2010
ну или так

Код
=ЕСЛИ(И(СЧЁТЕСЛИ(A:A;A1)>=2;A1<>"");"Одинак";"")
 
Ответить
Сообщениену или так

Код
=ЕСЛИ(И(СЧЁТЕСЛИ(A:A;A1)>=2;A1<>"");"Одинак";"")

Автор - abtextime
Дата добавления - 06.03.2018 в 17:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для поиска одинаковых значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!