Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Присвоение интервалам времени значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоение интервалам времени значения (Формулы/Formulas)
Присвоение интервалам времени значения
Bill_Murray Дата: Вторник, 27.02.2018, 18:31 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго дня!
Помогите пожалуйста с формулой, чтобы она присваивала значения, если в колонке время с 6:00 до 12:00, то "УТРО", с 12:00 до 13:00 "ДЕНЬ", с 13:00 до 23:00 "ВЕЧЕР", с 23:00 до 6:00 "НОЧЬ"?
Например:
12:15 ДЕНЬ
09:30 УТРО

Пробовал делать с если теряются интервалы!(
 
Ответить
СообщениеДоброго дня!
Помогите пожалуйста с формулой, чтобы она присваивала значения, если в колонке время с 6:00 до 12:00, то "УТРО", с 12:00 до 13:00 "ДЕНЬ", с 13:00 до 23:00 "ВЕЧЕР", с 23:00 до 6:00 "НОЧЬ"?
Например:
12:15 ДЕНЬ
09:30 УТРО

Пробовал делать с если теряются интервалы!(

Автор - Bill_Murray
Дата добавления - 27.02.2018 в 18:31
Che79 Дата: Вторник, 27.02.2018, 18:49 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1266
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Здравствуйте. Так?
Код
=ВПР(ЧАС(A1);{0;"Ночь":6;"Утро":12;"День":13;"Вечер":23;"Ночь"};2)
В A1 - число в формате время


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте. Так?
Код
=ВПР(ЧАС(A1);{0;"Ночь":6;"Утро":12;"День":13;"Вечер":23;"Ночь"};2)
В A1 - число в формате время

Автор - Che79
Дата добавления - 27.02.2018 в 18:49
Bill_Murray Дата: Вторник, 27.02.2018, 18:54 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Che79, да спасибо! Всё подошло!
 
Ответить
СообщениеChe79, да спасибо! Всё подошло!

Автор - Bill_Murray
Дата добавления - 27.02.2018 в 18:54
Bill_Murray Дата: Вторник, 27.02.2018, 18:55 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Che79, вы мне сэкономили уйму времени!)
 
Ответить
СообщениеChe79, вы мне сэкономили уйму времени!)

Автор - Bill_Murray
Дата добавления - 27.02.2018 в 18:55
sboy Дата: Среда, 28.02.2018, 11:52 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1872
Репутация: 552 ±
Замечаний: 0% ±

Excel 2010
еще вариант
Код
=ПРОСМОТР(A1*24;{0;6;12;13;23};{"ночь";"утро";"день";"вечер";"ночь"})

[offtop]
с 12:00 до 13:00 "ДЕНЬ"

какой-то очень короткий день :D
 
Ответить
Сообщениееще вариант
Код
=ПРОСМОТР(A1*24;{0;6;12;13;23};{"ночь";"утро";"день";"вечер";"ночь"})

[offtop]
с 12:00 до 13:00 "ДЕНЬ"

какой-то очень короткий день :D

Автор - sboy
Дата добавления - 28.02.2018 в 11:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоение интервалам времени значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!