Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение 2 столбцов с игнорированием пустых ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение 2 столбцов с игнорированием пустых ячеек (Формулы/Formulas)
Сравнение 2 столбцов с игнорированием пустых ячеек
h1dex Дата: Пятница, 02.03.2018, 13:06 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
добрый день!

где-то я видел готовое решение на форуме, но что-то не могу найти
см. образец во вложении..нужно сравнить 2 столбца на одинаковые слова, но игнорировать пустые строки

я вставил формулу ЕСЛИ, но у меня в 6 строке тоже пишет ОШИБКА

как сделать так чтобы ОШИБКА писалась только если в столбцах B и D не совпадают значения/слова..и при пустых не писало ОШИБКА..а было пусто? т.е. если значения/слова не совпадают то пишет ошибка..а если строка пустая то пишет не ошибка, а пусто?
К сообщению приложен файл: asdf.xlsx(9.7 Kb)
 
Ответить
Сообщениедобрый день!

где-то я видел готовое решение на форуме, но что-то не могу найти
см. образец во вложении..нужно сравнить 2 столбца на одинаковые слова, но игнорировать пустые строки

я вставил формулу ЕСЛИ, но у меня в 6 строке тоже пишет ОШИБКА

как сделать так чтобы ОШИБКА писалась только если в столбцах B и D не совпадают значения/слова..и при пустых не писало ОШИБКА..а было пусто? т.е. если значения/слова не совпадают то пишет ошибка..а если строка пустая то пишет не ошибка, а пусто?

Автор - h1dex
Дата добавления - 02.03.2018 в 13:06
Che79 Дата: Пятница, 02.03.2018, 13:17 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1266
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
Добрый день.
Навскидку.
Код
=ЕСЛИ(B2=D2;"ВЕРНО";ЕСЛИ(ИЛИ(B2="";D2="");"";"ОШИБКА"))


Делай нормально и будет нормально!
 
Ответить
СообщениеДобрый день.
Навскидку.
Код
=ЕСЛИ(B2=D2;"ВЕРНО";ЕСЛИ(ИЛИ(B2="";D2="");"";"ОШИБКА"))

Автор - Che79
Дата добавления - 02.03.2018 в 13:17
Che79 Дата: Пятница, 02.03.2018, 13:23 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1266
Репутация: 226 ±
Замечаний: 0% ±

Excel 2007, 2013
А вот так смешнее))
формула массива
Код
=--ИЛИ(ЕЧИСЛО(ПОИСК(B2;$D$2:$D$7)))

+формат ячейки + УФ (см. ячейки выделенные курсивом)
К сообщению приложен файл: asdf-.xlsx(10.1 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Пятница, 02.03.2018, 13:24
 
Ответить
СообщениеА вот так смешнее))
формула массива
Код
=--ИЛИ(ЕЧИСЛО(ПОИСК(B2;$D$2:$D$7)))

+формат ячейки + УФ (см. ячейки выделенные курсивом)

Автор - Che79
Дата добавления - 02.03.2018 в 13:23
h1dex Дата: Пятница, 02.03.2018, 13:26 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
работаеть..спасиба! :D
плюс в карму hands
 
Ответить
Сообщениеработаеть..спасиба! :D
плюс в карму hands

Автор - h1dex
Дата добавления - 02.03.2018 в 13:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение 2 столбцов с игнорированием пустых ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!