Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Условие для заполнение неполных ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условие для заполнение неполных ячеек (Формулы/Formulas)
Условие для заполнение неполных ячеек
nikitan95 Дата: Воскресенье, 04.03.2018, 18:25 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 308
Репутация: 0 ±
Замечаний: 0% ±

2016
Здравствуйте!
Как сформулировать условие для заполнения неполных ячеек? Буду очень признателен за помощь
К сообщению приложен файл: 0386187.xlsx(10.3 Kb)
 
Ответить
СообщениеЗдравствуйте!
Как сформулировать условие для заполнения неполных ячеек? Буду очень признателен за помощь

Автор - nikitan95
Дата добавления - 04.03.2018 в 18:25
Karataev Дата: Воскресенье, 04.03.2018, 18:41 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1250
Репутация: 481 ±
Замечаний: 0% ±

Excel
Вариант с использованием доплиста. На доплисте, в столбце "A" пишите данные, которые надо вставить на лист. В столбце "B" данные в том виде, как они могут быть. Формула для листа1, для "C2":
Код
=ИНДЕКС(доплист!A:A;ПОИСКПОЗ(B2;доплист!B:B;0);1)
К сообщению приложен файл: 0386187_kar.xlsx(11.5 Kb)


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288


Сообщение отредактировал Karataev - Воскресенье, 04.03.2018, 18:41
 
Ответить
СообщениеВариант с использованием доплиста. На доплисте, в столбце "A" пишите данные, которые надо вставить на лист. В столбце "B" данные в том виде, как они могут быть. Формула для листа1, для "C2":
Код
=ИНДЕКС(доплист!A:A;ПОИСКПОЗ(B2;доплист!B:B;0);1)

Автор - Karataev
Дата добавления - 04.03.2018 в 18:41
Karataev Дата: Воскресенье, 04.03.2018, 18:46 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1250
Репутация: 481 ±
Замечаний: 0% ±

Excel
Или вариант с использованием доплиста и табельного номера. Формула для листа1, для "C2":
Код
=ВПР(A2;Доплист!A:B;2;0)
К сообщению приложен файл: 0386187_kar_v2.xlsx(11.4 Kb)


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеИли вариант с использованием доплиста и табельного номера. Формула для листа1, для "C2":
Код
=ВПР(A2;Доплист!A:B;2;0)

Автор - Karataev
Дата добавления - 04.03.2018 в 18:46
nikitan95 Дата: Воскресенье, 04.03.2018, 18:55 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 308
Репутация: 0 ±
Замечаний: 0% ±

2016
Karataev, спасибо. Но файл громоздкий, на несколько десятка тысяча строк. Само уже создание доплиста чревато массами неудобств. Других идей нет?
 
Ответить
СообщениеKarataev, спасибо. Но файл громоздкий, на несколько десятка тысяча строк. Само уже создание доплиста чревато массами неудобств. Других идей нет?

Автор - nikitan95
Дата добавления - 04.03.2018 в 18:55
Che79 Дата: Воскресенье, 04.03.2018, 18:58 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1274
Репутация: 227 ±
Замечаний: 0% ±

Excel 2007, 2013
Здравствуйте.
Если у Вас Excel 2013/2016, то , как вариант, попробуйте Данные - Мгновенное заполнение. Возможно, на реальном файле будут нужны несколько корректировок вручную. Важно! Ячейки, куда нужно выводить полные ФИО, должны быть в соседнем столбце с ячейками поиска.


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте.
Если у Вас Excel 2013/2016, то , как вариант, попробуйте Данные - Мгновенное заполнение. Возможно, на реальном файле будут нужны несколько корректировок вручную. Важно! Ячейки, куда нужно выводить полные ФИО, должны быть в соседнем столбце с ячейками поиска.

Автор - Che79
Дата добавления - 04.03.2018 в 18:58
Karataev Дата: Воскресенье, 04.03.2018, 19:00 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1250
Репутация: 481 ±
Замечаний: 0% ±

Excel
Если в файле много формул, то используйте вместо xlsx формат xlsb. Он уменьшает размер файл и ускоряет работу с файлом.


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеЕсли в файле много формул, то используйте вместо xlsx формат xlsb. Он уменьшает размер файл и ускоряет работу с файлом.

Автор - Karataev
Дата добавления - 04.03.2018 в 19:00
nikitan95 Дата: Воскресенье, 04.03.2018, 19:09 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 308
Репутация: 0 ±
Замечаний: 0% ±

2016
Che79, у меня 2016. Попробовал Мгновенное заполнение, такая куча-мала получилось, что пришлось отказаться.
Karataev, файл как раз xlsb
 
Ответить
СообщениеChe79, у меня 2016. Попробовал Мгновенное заполнение, такая куча-мала получилось, что пришлось отказаться.
Karataev, файл как раз xlsb

Автор - nikitan95
Дата добавления - 04.03.2018 в 19:09
Karataev Дата: Воскресенье, 04.03.2018, 19:17 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1250
Репутация: 481 ±
Замечаний: 0% ±

Excel
Вариант на основе Вашей формулы. Формула для "J2":
Код
=ЕСЛИ(A2=A1;J1;B2)
К сообщению приложен файл: 0386187_kar_v3.xlsx(11.1 Kb)


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеВариант на основе Вашей формулы. Формула для "J2":
Код
=ЕСЛИ(A2=A1;J1;B2)

Автор - Karataev
Дата добавления - 04.03.2018 в 19:17
nikitan95 Дата: Воскресенье, 04.03.2018, 19:24 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 308
Репутация: 0 ±
Замечаний: 0% ±

2016
Karataev, быть по Вашему, упускаем второе условие. Спасибо
 
Ответить
СообщениеKarataev, быть по Вашему, упускаем второе условие. Спасибо

Автор - nikitan95
Дата добавления - 04.03.2018 в 19:24
Pelena Дата: Воскресенье, 04.03.2018, 19:35 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 13033
Репутация: 2877 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Можно попробовать через ВПР без доп. столбцов, но предварительно сделать двухуровневую сортировку по таб. номеру, а затем по убыванию ФИО
К сообщению приложен файл: 3293702.xlsx(10.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожно попробовать через ВПР без доп. столбцов, но предварительно сделать двухуровневую сортировку по таб. номеру, а затем по убыванию ФИО

Автор - Pelena
Дата добавления - 04.03.2018 в 19:35
nikitan95 Дата: Воскресенье, 04.03.2018, 19:49 | Сообщение № 11
Группа: Проверенные
Ранг: Обитатель
Сообщений: 308
Репутация: 0 ±
Замечаний: 0% ±

2016
Pelena, спасибо. Хорошее решение
 
Ответить
СообщениеPelena, спасибо. Хорошее решение

Автор - nikitan95
Дата добавления - 04.03.2018 в 19:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Условие для заполнение неполных ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!