Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск нескольких подтекстов в строке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск нескольких подтекстов в строке (Формулы/Formulas)
Поиск нескольких подтекстов в строке
EvelRus Дата: Воскресенье, 11.03.2018, 13:18 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем добрый день!
Нужна помощь грамотных людей.

Делаю табличку со своими фильмами (вопрос зачем - опустим), встала такая проблема:
есть колонка "Страна" и есть колонка "Ссылка", которая формируется, в том числе, на основе поля Страна. Если Страна <> Россия или СССР, то &" Дублированный"

Все хорошо, пока в фильме не выскакивает "Россия - Япония" или "СССР - Германия", тогда не работает ((( Подстановка звездочек тоже не срабатывает (
Сейчас это выглядит так [vba]
Код
ЕСЛИ(И(H529<>"Россия";H529<>"СССР");" Дублированный";"")
[/vba]

Сделал
[vba]
Код
=--ЕЧИСЛО(ПОИСК({"СССР";"Россия"};A16))
[/vba]
СССР находит, Россию нет (

Как сделать поиск по тексту я тут нашел, но не нашел, как такое сделать с двумя и более значениями, которые надо искать (

Заранее спасибо за помощь.


Сообщение отредактировал EvelRus - Воскресенье, 11.03.2018, 13:19
 
Ответить
СообщениеВсем добрый день!
Нужна помощь грамотных людей.

Делаю табличку со своими фильмами (вопрос зачем - опустим), встала такая проблема:
есть колонка "Страна" и есть колонка "Ссылка", которая формируется, в том числе, на основе поля Страна. Если Страна <> Россия или СССР, то &" Дублированный"

Все хорошо, пока в фильме не выскакивает "Россия - Япония" или "СССР - Германия", тогда не работает ((( Подстановка звездочек тоже не срабатывает (
Сейчас это выглядит так [vba]
Код
ЕСЛИ(И(H529<>"Россия";H529<>"СССР");" Дублированный";"")
[/vba]

Сделал
[vba]
Код
=--ЕЧИСЛО(ПОИСК({"СССР";"Россия"};A16))
[/vba]
СССР находит, Россию нет (

Как сделать поиск по тексту я тут нашел, но не нашел, как такое сделать с двумя и более значениями, которые надо искать (

Заранее спасибо за помощь.

Автор - EvelRus
Дата добавления - 11.03.2018 в 13:18
Nic70y Дата: Воскресенье, 11.03.2018, 13:28 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4941
Репутация: 1069 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("Россия";A1))+ЕЧИСЛО(ПОИСК("СССР";A1));"";"Дублированный")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("Россия";A1))+ЕЧИСЛО(ПОИСК("СССР";A1));"";"Дублированный")

Автор - Nic70y
Дата добавления - 11.03.2018 в 13:28
Che79 Дата: Воскресенье, 11.03.2018, 14:10 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1278
Репутация: 229 ±
Замечаний: 0% ±

Excel 2007, 2013
Здравствуйте.
Может, так? Формула массива
Код
=--ИЛИ(ЕЧИСЛО(ПОИСК({"СССР";"Россия"};A1)))
+ ФЯ ;;"Дублированный"


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте.
Может, так? Формула массива
Код
=--ИЛИ(ЕЧИСЛО(ПОИСК({"СССР";"Россия"};A1)))
+ ФЯ ;;"Дублированный"

Автор - Che79
Дата добавления - 11.03.2018 в 14:10
Светлый Дата: Воскресенье, 11.03.2018, 14:43 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 749
Репутация: 199 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Код
=СЧЁТ(ПОИСК({"СССР";"Россия"};A1))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЗдравствуйте!
Код
=СЧЁТ(ПОИСК({"СССР";"Россия"};A1))

Автор - Светлый
Дата добавления - 11.03.2018 в 14:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск нескольких подтекстов в строке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!