Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отбор уникальных значений с суммированием соседних столбцов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отбор уникальных значений с суммированием соседних столбцов (Формулы/Formulas)
Отбор уникальных значений с суммированием соседних столбцов
Aimod Дата: Вторник, 13.03.2018, 13:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Приветствую!
Не могу понять как сделать. Не понимаю сводную таблицу. Хочется макрос, не могу представить как "записать" повторяющееся действие на весь диапазон и критерии.. %)
Столбец AG (№33) имеет разные повторяющиеся имена. Нужно оставить по одной строке на каждое имя так, что бы в столбцах 34,35,36,37,38,39 осталось суммарное значение прежних ячеек. Информация в столбцах справа и слева от диапазона 33-39, в случае расхождения значений должна быть добавлена через запятую (это в идеале, так-то мне бы хоть первую часть сделать, остальное поправлю фильтрами)
К сообщению приложен файл: 8337471.xls(41.5 Kb)
 
Ответить
СообщениеПриветствую!
Не могу понять как сделать. Не понимаю сводную таблицу. Хочется макрос, не могу представить как "записать" повторяющееся действие на весь диапазон и критерии.. %)
Столбец AG (№33) имеет разные повторяющиеся имена. Нужно оставить по одной строке на каждое имя так, что бы в столбцах 34,35,36,37,38,39 осталось суммарное значение прежних ячеек. Информация в столбцах справа и слева от диапазона 33-39, в случае расхождения значений должна быть добавлена через запятую (это в идеале, так-то мне бы хоть первую часть сделать, остальное поправлю фильтрами)

Автор - Aimod
Дата добавления - 13.03.2018 в 13:44
Manyasha Дата: Вторник, 13.03.2018, 14:24 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 2197
Репутация: 893 ±
Замечаний: 0% ±

Excel 2010, 2016
Aimod, здравствуйте, если правильно поняла, можно без макроса.
Сводная таблица
К сообщению приложен файл: 8337471-1.xls(40.5 Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеAimod, здравствуйте, если правильно поняла, можно без макроса.
Сводная таблица

Автор - Manyasha
Дата добавления - 13.03.2018 в 14:24
sboy Дата: Вторник, 13.03.2018, 14:32 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2237
Репутация: 633 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Вариант формулами, т.к. непонятно где нужен результат, сделал на новом листе
для уникальных
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$AG$2:$AG$31;АГРЕГАТ(15;6;(СТРОКА($AG$2:$AG$31)-1)/(ПОИСКПОЗ(Лист1!$AG$2:$AG$31;Лист1!$AG$2:$AG$31;)=(СТРОКА($AG$2:$AG$31)-1));СТРОКА(A1)));"")

для суммы
Код
=СУММ(ЕСЛИ(Лист1!$AG$2:$AG$31=A1;Лист1!$AH$2:$AM$31))
К сообщению приложен файл: 4322472.xls(44.5 Kb)
 
Ответить
СообщениеДобрый день.
Вариант формулами, т.к. непонятно где нужен результат, сделал на новом листе
для уникальных
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$AG$2:$AG$31;АГРЕГАТ(15;6;(СТРОКА($AG$2:$AG$31)-1)/(ПОИСКПОЗ(Лист1!$AG$2:$AG$31;Лист1!$AG$2:$AG$31;)=(СТРОКА($AG$2:$AG$31)-1));СТРОКА(A1)));"")

для суммы
Код
=СУММ(ЕСЛИ(Лист1!$AG$2:$AG$31=A1;Лист1!$AH$2:$AM$31))

Автор - sboy
Дата добавления - 13.03.2018 в 14:32
Aimod Дата: Вторник, 13.03.2018, 15:08 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо! Мне нужно что бы на исходном листе осталось по одной строке на наименование, с суммой сост. из удаленных.. До сих пор не осилил, работаю,
удаление дублей ессно не складывает, запрос тоже видится нуждающимся в редактировании.. я понимаю, что это мб тривиальная задача, а я не могу сформулировать вопрос, простите за отнимаемое время


Сообщение отредактировал Aimod - Вторник, 13.03.2018, 15:18
 
Ответить
СообщениеСпасибо! Мне нужно что бы на исходном листе осталось по одной строке на наименование, с суммой сост. из удаленных.. До сих пор не осилил, работаю,
удаление дублей ессно не складывает, запрос тоже видится нуждающимся в редактировании.. я понимаю, что это мб тривиальная задача, а я не могу сформулировать вопрос, простите за отнимаемое время

Автор - Aimod
Дата добавления - 13.03.2018 в 15:08
sboy Дата: Вторник, 13.03.2018, 15:57 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2237
Репутация: 633 ±
Замечаний: 0% ±

Excel 2010
Начал вникать в Power Qwery
Вот еще вариант с помощью этого инструмента
К сообщению приложен файл: 8337471.xlsx(39.6 Kb)
 
Ответить
СообщениеНачал вникать в Power Qwery
Вот еще вариант с помощью этого инструмента

Автор - sboy
Дата добавления - 13.03.2018 в 15:57
Aimod Дата: Вторник, 13.03.2018, 16:25 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Power Qwery

Да, да, очень удобная вещь, уже выручила меня однажды.. спасибо, продолжаю работать
 
Ответить
Сообщение
Power Qwery

Да, да, очень удобная вещь, уже выручила меня однажды.. спасибо, продолжаю работать

Автор - Aimod
Дата добавления - 13.03.2018 в 16:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отбор уникальных значений с суммированием соседних столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!