Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нумерация таблицы при вставке и удалении строк. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нумерация таблицы при вставке и удалении строк. (Формулы/Formulas)
Нумерация таблицы при вставке и удалении строк.
Rudines Дата: Суббота, 31.03.2018, 09:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Имеется таблица с нумерацией, должностями и фамилиями сотрудников (типа телефонный справочник).
Периодически в таблицу по отделам, добавляются или удаляются сотрудники.
Обычной нумерацией типа =А1+1, тут не отделаться, т.к. периодически в колонке А1 попадается наименование отдела.
Как автоматизировать нумерацию (формула, макрос), что бы она (формула) игнорировала название отдела и брала порядковый номер на ячейку выше?
В организации около 20 отделов и 200 сотрудников.
Просмотрел все темы связанные с нумерацией строк, но то, что нужно не нашел.
Пример в файле ниже.
Заранее спасибо!
К сообщению приложен файл: 1863123.xls(31.5 Kb)
 
Ответить
СообщениеДобрый день!
Имеется таблица с нумерацией, должностями и фамилиями сотрудников (типа телефонный справочник).
Периодически в таблицу по отделам, добавляются или удаляются сотрудники.
Обычной нумерацией типа =А1+1, тут не отделаться, т.к. периодически в колонке А1 попадается наименование отдела.
Как автоматизировать нумерацию (формула, макрос), что бы она (формула) игнорировала название отдела и брала порядковый номер на ячейку выше?
В организации около 20 отделов и 200 сотрудников.
Просмотрел все темы связанные с нумерацией строк, но то, что нужно не нашел.
Пример в файле ниже.
Заранее спасибо!

Автор - Rudines
Дата добавления - 31.03.2018 в 09:12
RAN Дата: Суббота, 31.03.2018, 09:52 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4730
Репутация: 950 ±
Замечаний: 0% ±

2010
Код
=СЧЁТЗ($B$18:B19)*(B19>0)


Быть или не быть, вот в чем загвоздка!
 
Ответить
Сообщение
Код
=СЧЁТЗ($B$18:B19)*(B19>0)

Автор - RAN
Дата добавления - 31.03.2018 в 09:52
Nic70y Дата: Суббота, 31.03.2018, 09:54 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4559
Репутация: 985 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИОШИБКА(ВПР(9E+307;ИНДЕКС(A:A;1):ИНДЕКС(A:A;СТРОКА()-1);1)+1;1)
из файла ничего не понял.
вдруг правильно

все я понял, просто сбили мене с толку условными обозначениями.
моя формула единственная и неповторимая (я скромный, если что)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Суббота, 31.03.2018, 10:10
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР(9E+307;ИНДЕКС(A:A;1):ИНДЕКС(A:A;СТРОКА()-1);1)+1;1)
из файла ничего не понял.
вдруг правильно

все я понял, просто сбили мене с толку условными обозначениями.
моя формула единственная и неповторимая (я скромный, если что)

Автор - Nic70y
Дата добавления - 31.03.2018 в 09:54
Rudines Дата: Суббота, 31.03.2018, 11:06 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем ОГРОМНОЕ Спасибо! Nic70y! То что нужно!!! specool
 
Ответить
СообщениеВсем ОГРОМНОЕ Спасибо! Nic70y! То что нужно!!! specool

Автор - Rudines
Дата добавления - 31.03.2018 в 11:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нумерация таблицы при вставке и удалении строк. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!