Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вывести номер группы исходя из параметров - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывести номер группы исходя из параметров (Формулы/Formulas)
вывести номер группы исходя из параметров
zaak88 Дата: Среда, 04.04.2018, 19:26 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 146
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Коллеги, прошу помочь с примером: требуется вывести номер группы исходя из названия и параметра.

Спасибо!
К сообщению приложен файл: 7827674.xlsx(10.1 Kb)
 
Ответить
СообщениеКоллеги, прошу помочь с примером: требуется вывести номер группы исходя из названия и параметра.

Спасибо!

Автор - zaak88
Дата добавления - 04.04.2018 в 19:26
Pelena Дата: Среда, 04.04.2018, 21:19 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12838
Репутация: 2828 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Так подойдёт?
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(B24;ИНДЕКС($B$3:$J$19;ПОИСКПОЗ($A28;$A$3:$A$19;0);0));1)

Только проверьте оранжевые ячейки, у вас там не опечатка была?
К сообщению приложен файл: 4839009.xlsx(10.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак подойдёт?
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(B24;ИНДЕКС($B$3:$J$19;ПОИСКПОЗ($A28;$A$3:$A$19;0);0));1)

Только проверьте оранжевые ячейки, у вас там не опечатка была?

Автор - Pelena
Дата добавления - 04.04.2018 в 21:19
murza Дата: Среда, 04.04.2018, 21:33 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
у меня другой вариант :)
 
Ответить
Сообщениеу меня другой вариант :)

Автор - murza
Дата добавления - 04.04.2018 в 21:33
murza Дата: Среда, 04.04.2018, 21:33 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
вот....
К сообщению приложен файл: 7827674-1.xlsx(10.7 Kb)
 
Ответить
Сообщениевот....

Автор - murza
Дата добавления - 04.04.2018 в 21:33
murza Дата: Среда, 04.04.2018, 21:34 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
не люблю ИНДЕКС )))))
 
Ответить
Сообщениене люблю ИНДЕКС )))))

Автор - murza
Дата добавления - 04.04.2018 в 21:34
Светлый Дата: Среда, 04.04.2018, 21:36 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 523
Репутация: 125 ±
Замечаний: 0% ±

Excel 2007
У меня решение аналогичное, но исходные данные не рассортированы и выбор группы не всегда корректен.
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(B24;СМЕЩ($B$2:$J$2;ПОИСКПОЗ($A24;$A$3:$A$19;);));1)

Добавим массивную формулу. Она лучше подходит к условиям:
Код
=МИН(ЕСЛИ(СМЕЩ($B$2:$J$2;ПОИСКПОЗ($A24;$A$3:$A$19;);)>=B24;$B$2:$J$2);9)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 04.04.2018, 21:48
 
Ответить
СообщениеУ меня решение аналогичное, но исходные данные не рассортированы и выбор группы не всегда корректен.
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ(B24;СМЕЩ($B$2:$J$2;ПОИСКПОЗ($A24;$A$3:$A$19;);));1)

Добавим массивную формулу. Она лучше подходит к условиям:
Код
=МИН(ЕСЛИ(СМЕЩ($B$2:$J$2;ПОИСКПОЗ($A24;$A$3:$A$19;);)>=B24;$B$2:$J$2);9)

Автор - Светлый
Дата добавления - 04.04.2018 в 21:36
zaak88 Дата: Четверг, 05.04.2018, 09:55 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 146
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
Pelena, Спасибо отлично всё!!!
 
Ответить
СообщениеPelena, Спасибо отлично всё!!!

Автор - zaak88
Дата добавления - 05.04.2018 в 09:55
zaak88 Дата: Четверг, 05.04.2018, 09:55 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 146
Репутация: 1 ±
Замечаний: 0% ±

Excel 2013
murza, Светлый, спасибо за помощь!
 
Ответить
Сообщениеmurza, Светлый, спасибо за помощь!

Автор - zaak88
Дата добавления - 05.04.2018 в 09:55
китин Дата: Четверг, 05.04.2018, 10:08 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4930
Репутация: 787 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
не люблю ИНДЕКС )))))

murza, а СМЕЩ лучше што ли? пересчитывается при каждом изменении :p


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
не люблю ИНДЕКС )))))

murza, а СМЕЩ лучше што ли? пересчитывается при каждом изменении :p

Автор - китин
Дата добавления - 05.04.2018 в 10:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывести номер группы исходя из параметров (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!