Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как просуммировать значения ячеек до следующей пустой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как просуммировать значения ячеек до следующей пустой (Формулы/Formulas)
Как просуммировать значения ячеек до следующей пустой
ryazanov Дата: Пятница, 06.04.2018, 00:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2010
Здравствуйте!
Помогите пожалуйста, как задать формулу, чтобы суммировала значения в ячейках (по столбцу D) до следующей пустой (по столбцу B).
Файл в приложении.
К сообщению приложен файл: 1432677.xls(29.0 Kb)
 
Ответить
СообщениеЗдравствуйте!
Помогите пожалуйста, как задать формулу, чтобы суммировала значения в ячейках (по столбцу D) до следующей пустой (по столбцу B).
Файл в приложении.

Автор - ryazanov
Дата добавления - 06.04.2018 в 00:14
vikttur Дата: Пятница, 06.04.2018, 00:59 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2716
Репутация: 477 ±
Замечаний: 0% ±

Код
=ЕСЛИ(B5="";СУММ(D5:$D$37)-СУММ(E6:$E$37)-СУММЕСЛИ(B5:$B$37;"";D5:$D$37);"")
 
Ответить
Сообщение
Код
=ЕСЛИ(B5="";СУММ(D5:$D$37)-СУММ(E6:$E$37)-СУММЕСЛИ(B5:$B$37;"";D5:$D$37);"")

Автор - vikttur
Дата добавления - 06.04.2018 в 00:59
Светлый Дата: Пятница, 06.04.2018, 06:19 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 747
Репутация: 198 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Массивная формула:
Код
=СУММ(СМЕЩ(D6;;;ПОИСКПОЗ(0=0;B7:B$999="";)))

Доб.
Или чуть-чуть другая:
Код
=СУММ(СМЕЩ(D6;;;ПОИСКПОЗ(1;B7:B$999+1;)))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 06.04.2018, 06:43
 
Ответить
СообщениеЗдравствуйте!
Массивная формула:
Код
=СУММ(СМЕЩ(D6;;;ПОИСКПОЗ(0=0;B7:B$999="";)))

Доб.
Или чуть-чуть другая:
Код
=СУММ(СМЕЩ(D6;;;ПОИСКПОЗ(1;B7:B$999+1;)))

Автор - Светлый
Дата добавления - 06.04.2018 в 06:19
ryazanov Дата: Пятница, 06.04.2018, 10:38 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

2010
Спасибо большое!
 
Ответить
СообщениеСпасибо большое!

Автор - ryazanov
Дата добавления - 06.04.2018 в 10:38
AlexM Дата: Пятница, 06.04.2018, 11:06 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3780
Репутация: 952 ±
Замечаний: 0% ±

Excel 2003
Еще вариант формулы массива
Код
=СУММ(D6:ИНДЕКС(D6:D98;ПОИСКПОЗ(;-B7:B99;)))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще вариант формулы массива
Код
=СУММ(D6:ИНДЕКС(D6:D98;ПОИСКПОЗ(;-B7:B99;)))

Автор - AlexM
Дата добавления - 06.04.2018 в 11:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как просуммировать значения ячеек до следующей пустой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!