Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как сложить значения начинающиеся на определенную цифру. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как сложить значения начинающиеся на определенную цифру.
как сложить значения начинающиеся на определенную цифру.
Serg077 Дата: Пятница, 06.04.2018, 00:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый ночи!
Подскажите, пожалуйста, как сложить все значения начинающиеся на определенную цифру? Например, есть массив 2000 строк, из них нужно сложить все значения начинающиеся только на 7. В голову приходит СУММЕСЛИ, но как задать параметр отбора?
 
Ответить
СообщениеДобрый ночи!
Подскажите, пожалуйста, как сложить все значения начинающиеся на определенную цифру? Например, есть массив 2000 строк, из них нужно сложить все значения начинающиеся только на 7. В голову приходит СУММЕСЛИ, но как задать параметр отбора?

Автор - Serg077
Дата добавления - 06.04.2018 в 00:39
китин Дата: Пятница, 06.04.2018, 07:26 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а у вас Mac? или вы не в тот раздел попали.
если не в тот тогда так
Код
=СУММПРОИЗВ($A$1:$A$2000*(--ЛЕВБ($A$1:$A$2000;1)=7))

формула массива.
дла Мас не знаю


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 06.04.2018, 07:26
 
Ответить
Сообщениеа у вас Mac? или вы не в тот раздел попали.
если не в тот тогда так
Код
=СУММПРОИЗВ($A$1:$A$2000*(--ЛЕВБ($A$1:$A$2000;1)=7))

формула массива.
дла Мас не знаю

Автор - китин
Дата добавления - 06.04.2018 в 07:26
Pelena Дата: Пятница, 06.04.2018, 08:50 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13109
Репутация: 2888 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
В данном случае не имеет значения Mac или не Mac. Поэтому перенесла тему в общий раздел

Как вариант
Код
=СУММПРОИЗВ(A1:A2000*(ОТБР(A1:A2000/10^(ДЛСТР(A1:A2000)-1))=7))

А предыдущую формулу я бы так переписала
Код
=СУММПРОИЗВ($A$1:$A$2000*(ЕСЛИОШИБКА(--ЛЕВБ($A$1:$A$2000;1);0)=7))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВ данном случае не имеет значения Mac или не Mac. Поэтому перенесла тему в общий раздел

Как вариант
Код
=СУММПРОИЗВ(A1:A2000*(ОТБР(A1:A2000/10^(ДЛСТР(A1:A2000)-1))=7))

А предыдущую формулу я бы так переписала
Код
=СУММПРОИЗВ($A$1:$A$2000*(ЕСЛИОШИБКА(--ЛЕВБ($A$1:$A$2000;1);0)=7))

Автор - Pelena
Дата добавления - 06.04.2018 в 08:50
AlexM Дата: Пятница, 06.04.2018, 10:15 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3762
Репутация: 949 ±
Замечаний: 0% ±

Excel 2003
Формулу Игоря переписал бы так
Код
=СУММПРОИЗВ(A1:A2000*(ЛЕВБ(A1:A2000)="7"))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеФормулу Игоря переписал бы так
Код
=СУММПРОИЗВ(A1:A2000*(ЛЕВБ(A1:A2000)="7"))

Автор - AlexM
Дата добавления - 06.04.2018 в 10:15
Serg077 Дата: Пятница, 06.04.2018, 18:27 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Благодарю. Работает!)
 
Ответить
СообщениеБлагодарю. Работает!)

Автор - Serg077
Дата добавления - 06.04.2018 в 18:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как сложить значения начинающиеся на определенную цифру.
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!