Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма чисел для нескольких ключевых слов - в одной ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма чисел для нескольких ключевых слов - в одной ячейке (Формулы/Formulas)
Сумма чисел для нескольких ключевых слов - в одной ячейке
DJBeast Дата: Пятница, 06.04.2018, 22:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Все доброго времени суток.
Подскажите ответ.
Имеется таблица G7:I19 с текстовыми данными.

В ячейку BA4 вписано ключевое слово.
В столбцах BA7:BA19 и BC7:BC19 происходит извлечение числа стоящего в ячейках таблицы - рядом с ключевым словом.
В ячейке BC5 - происходит суммирование этих чисел.

У меня вопрос про ячейку G12 этой таблицы.
В этой ячейке - ключевое слово встречается несколько раз.
Как формулой - провести операцию суммирования найденных чисел - если ключевое слово - в одной ячейке встречаются не один, а несколько раз ?
К сообщению приложен файл: 6466968.xlsb(26.7 Kb)
 
Ответить
СообщениеВсе доброго времени суток.
Подскажите ответ.
Имеется таблица G7:I19 с текстовыми данными.

В ячейку BA4 вписано ключевое слово.
В столбцах BA7:BA19 и BC7:BC19 происходит извлечение числа стоящего в ячейках таблицы - рядом с ключевым словом.
В ячейке BC5 - происходит суммирование этих чисел.

У меня вопрос про ячейку G12 этой таблицы.
В этой ячейке - ключевое слово встречается несколько раз.
Как формулой - провести операцию суммирования найденных чисел - если ключевое слово - в одной ячейке встречаются не один, а несколько раз ?

Автор - DJBeast
Дата добавления - 06.04.2018 в 22:43
Светлый Дата: Суббота, 07.04.2018, 01:11 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 523
Репутация: 125 ±
Замечаний: 0% ±

Excel 2007
Этот файл уже был. И решение уже было выложено. Другое решение, массивная формула:
Код
=СУММ(ЕСЛИ(ПСТР(G7:I7;СТРОКА($1:$199);ДЛСТР(BA$4))=BA$4;--ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(G7:I7;СТРОКА($1:$199)+ДЛСТР(BA$4);3);" ";"     ");",";"     ");0;ЛЕВБ(1/2;2));5)))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 07.04.2018, 01:13
 
Ответить
СообщениеЭтот файл уже был. И решение уже было выложено. Другое решение, массивная формула:
Код
=СУММ(ЕСЛИ(ПСТР(G7:I7;СТРОКА($1:$199);ДЛСТР(BA$4))=BA$4;--ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(G7:I7;СТРОКА($1:$199)+ДЛСТР(BA$4);3);" ";"     ");",";"     ");0;ЛЕВБ(1/2;2));5)))

Автор - Светлый
Дата добавления - 07.04.2018 в 01:11
DJBeast Дата: Суббота, 07.04.2018, 13:57 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, вроде работает. Спасибо.
 
Ответить
СообщениеСветлый, вроде работает. Спасибо.

Автор - DJBeast
Дата добавления - 07.04.2018 в 13:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма чисел для нескольких ключевых слов - в одной ячейке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!