Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Добавление текста в ячейки, в которых его нет - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Добавление текста в ячейки, в которых его нет (Формулы/Formulas)
Добавление текста в ячейки, в которых его нет
Russt Дата: Суббота, 07.04.2018, 08:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!

Как можно добавить слово только в ячейки, в которых его нет?
К сообщению приложен файл: 070418.xls(25.5 Kb)
 
Ответить
СообщениеЗдравствуйте!

Как можно добавить слово только в ячейки, в которых его нет?

Автор - Russt
Дата добавления - 07.04.2018 в 08:00
Pelena Дата: Суббота, 07.04.2018, 08:18 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13109
Репутация: 2888 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("киви";A3));A3;A3&" киви")
К сообщению приложен файл: 7105099.xls(25.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("киви";A3));A3;A3&" киви")

Автор - Pelena
Дата добавления - 07.04.2018 в 08:18
Karataev Дата: Суббота, 07.04.2018, 08:52 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1256
Репутация: 485 ±
Замечаний: 0% ±

Excel
Вариант макросом. Предполагается, что данные начинаются со строки 2. Приложил файл, в котором работает этот макрос. В самом файле макроса нет.


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
СообщениеВариант макросом. Предполагается, что данные начинаются со строки 2. Приложил файл, в котором работает этот макрос. В самом файле макроса нет.

Автор - Karataev
Дата добавления - 07.04.2018 в 08:52
InExSu Дата: Среда, 11.04.2018, 02:14 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 398
Репутация: 50 ±
Замечаний: 20% ±

Excel 2010
Привет!

[vba]
Код

Option Explicit

Sub ДОбав()
    Application.ScreenUpdating = False

    Dim rng As Range: Set rng = ActiveSheet.UsedRange
    Dim cel As Range
    Dim str As String: str = " киви"

    For Each cel In rng.Cells
        With cel
            If Len(.Value) <> 0 And _
               InStr(.Value, str) = 0 Then
                
                .Value = .Value & str
            End If
        End With
    Next cel

    Application.ScreenUpdating = True

End Sub

[/vba]


На сохранение второго закона термодинамики: яндекс.кошелёк 410012113235839

Сообщение отредактировал InExSu - Среда, 11.04.2018, 02:15
 
Ответить
СообщениеПривет!

[vba]
Код

Option Explicit

Sub ДОбав()
    Application.ScreenUpdating = False

    Dim rng As Range: Set rng = ActiveSheet.UsedRange
    Dim cel As Range
    Dim str As String: str = " киви"

    For Each cel In rng.Cells
        With cel
            If Len(.Value) <> 0 And _
               InStr(.Value, str) = 0 Then
                
                .Value = .Value & str
            End If
        End With
    Next cel

    Application.ScreenUpdating = True

End Sub

[/vba]

Автор - InExSu
Дата добавления - 11.04.2018 в 02:14
Russt Дата: Понедельник, 16.04.2018, 13:22 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо всем! Все работает!
 
Ответить
СообщениеСпасибо всем! Все работает!

Автор - Russt
Дата добавления - 16.04.2018 в 13:22
sv2014 Дата: Вторник, 17.04.2018, 20:31 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 220
Репутация: 60 ±
Замечаний: 0% ±

Excel 2013
Russt, еще вариант макроса,для демонстрации переменной $&,кнопки test и повтор


[vba]
Код
Sub test()
  Dim i&, t$
With CreateObject("VBScript.RegExp")
  For i = 3 To Range("A3").End(xlDown).Row: t = Range("A" & i): .Pattern = "киви"
      If .test(t) = False Then
       .Pattern = ".+": Range("A" & i) = .Replace(t, "$& киви")
      End If
  Next
  End With
End Sub
[/vba]
К сообщению приложен файл: example_16_04_2.xls(41.0 Kb)
 
Ответить
СообщениеRusst, еще вариант макроса,для демонстрации переменной $&,кнопки test и повтор


[vba]
Код
Sub test()
  Dim i&, t$
With CreateObject("VBScript.RegExp")
  For i = 3 To Range("A3").End(xlDown).Row: t = Range("A" & i): .Pattern = "киви"
      If .test(t) = False Then
       .Pattern = ".+": Range("A" & i) = .Replace(t, "$& киви")
      End If
  Next
  End With
End Sub
[/vba]

Автор - sv2014
Дата добавления - 17.04.2018 в 20:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Добавление текста в ячейки, в которых его нет (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!